Координаты чертежа

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft Coordinates and the translation is 4% complete.

Outdated translations are marked like this.
Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎中文(中国大陆)‎

Во всех инструментах Draft при указании расположения точки в трёхмерном пространстве, расстояния, радиуса, угла или других числовых данных возможно задание значений графически указателем на экране или вводом числового значения. Первый способ обычно более интуитивен, но если необходима абсолютная точность, то требуется введение точных значений. Поэтому командная панель модуля Draft всегда принимает числовой ввод:

Draft Workbench tools allow you to pick points, distances, radiuses, and angles graphically by clicking on the 3D view with the pointer.

However, when these parameters need to be precise, it is possible to enter the exact values in the dialog for the tool.

There are two interfaces possible: taskview and command toolbar. The default interface is selected in the menu Edit → Preferences → Draft → General settings → Draft interface mode.

Taskview panel

The Taskview panel is an intelligent window that changes its contents according to the tool being used, and the input required from the user. For example, when using Draft Circle, the panel will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.

Whenever you see input fields appearing on the Taskview, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.

  • Press Tab or Enter to advance to the X, Y and Z fields; pressing Enter when in the Z field will record the point.

Depending on the specific Draft tool under use, there may be other options available.

  • Press R to switch between absolute and relative coordinates.
  • Press T to switch between normal mode and continue mode.
  • Press L to switch between wireframe mode and filled mode.
  • Press P to switch between original mode and copy mode.

Draft Coordinates.jpg

Draft Coordinates Taskview 2.png

Taskview, second screen for the Circle tool, entering the radius


Command toolbar

(November 2018) Since FreeCAD 0.17, the Draft command toolbar is no longer the preferred Draft interface mode. Now the Taskview is preferred. The following information may no longer be accurate or work as described.


Draft Coordinates Toolbar.png

Draft coordinates entered in the command toolbar


Командная панель Draft является "интеллектуальной", её содержимое изменяется в соответствии с используемым инструментом и требуемым вводом от пользователя. Например, при создании окружности, командная панель последовательно запрашивает цент окружности, а затем радиус. Значения могут быть указаны выбором точек на экране или вводом чисел.

В каждое числовое поле ввода в панели команд вы можете ввести значение, заметьте также, что эти значения отображают перемещения курсора. Используйте TAB для перехода между координатами X, Y и Z. Нажатие ENTER в поле ввода координаты Z установит её значение. Повторный ввод новых координат X, Y и Z создаст вторую точку для линии и/или следующую для ломаной.

Locking the Z coordinate

Draft Coordinates.jpg

Draft coordinates entered in the command toolbar (older FreeCAD)


Порой может быть сложно выровнять объекты при работе в трёхмерном пространстве. Возможно заблокировать Z-координату, так что всё создаваемое будет расположено в той же горизонтальной плоскости. По умолчанию при запуске FreeCAD Z-координата заблокирована в 0.00, чтобы изменить это разблокируйте Z-координату, введите Z-значение и заблокируйте Z-координату. Если Z-координата заблокирована, то черчение возможно только в горизонтальной плоскости.

Большинство команд Draft работает в трёх измерениях. Разблокируйте Z-координату, измените на подходящий угол вида и то что будет начерчено будет расположено в этом виде.

Set the number of decimals

По умолчанию FreeCAD работает с числами с двумя знаками после запятой. Для изменения количества знаков после запятой:

  • Добавьте новый целочисленный элемент Decimals в меню Инструменты → Редактор параметров... → BaseApp → Preferences → Units.
  • По правому щелчку выберите Новый → Новый целочисленный элемент → Введите имя Decimals и укажите желаемое количество цифр после запятой.
  • Нажмите кнопку Сохранить на диск.
  • Закройте окно и вернитесь к FreeCAD для активации изменения.

Another way is using the parameter editor:

  • Go to Tools → Edit parameters → BaseApp → Preferences → Units, and change the "Value" of "Decimals" to the desired number.
  • If "Decimals" doesn't exist you can create it; right click in the window and select New integer item → Enter the name →, type in "Decimals", and proceed to enter the desired number.
  • Then click Save to disk and Close.
  • Restart FreeCAD to activate your changes.
PreferencesDecimals 01 en.png