Coordonate în Desen 2D

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft Coordinates and the translation is 4% complete.

Outdated translations are marked like this.
Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎中文(中国大陆)‎

În toate instrumentele de proiectare, atunci când vi se solicită locații 3D, distanțe, raze, unghiuri sau orice alte date numerice, puteți alege întotdeauna să introduceți aceste valori grafic, prin selectarea pe ecran cu mouse-ul sau direct prin introducerea numerelor tastatura. Prima metodă este, de obicei, mai intuitivă, dar când lucrați cu precizie absolută, adesea trebuie să introduceți un număr precis și asigurați-vă că coordonatele pe care le-ați introdus sunt exacte. Prin urmare, bara de comandă a modulului Draft poate accepta întotdeauna introducerea numărului:

Draft Workbench tools allow you to pick points, distances, radiuses, and angles graphically by clicking on the 3D view with the pointer.

However, when these parameters need to be precise, it is possible to enter the exact values in the dialog for the tool.

There are two interfaces possible: taskview and command toolbar. The default interface is selected in the menu Edit → Preferences → Draft → General settings → Draft interface mode.

Taskview panel

The Taskview panel is an intelligent window that changes its contents according to the tool being used, and the input required from the user. For example, when using Draft Circle, the panel will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.

Whenever you see input fields appearing on the Taskview, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.

  • Press Tab or Enter to advance to the X, Y and Z fields; pressing Enter when in the Z field will record the point.

Depending on the specific Draft tool under use, there may be other options available.

  • Press R to switch between absolute and relative coordinates.
  • Press T to switch between normal mode and continue mode.
  • Press L to switch between wireframe mode and filled mode.
  • Press P to switch between original mode and copy mode.

Draft Coordinates.jpg

Draft Coordinates Taskview 2.png

Taskview, second screen for the Circle tool, entering the radius


Command toolbar

(November 2018) Since FreeCAD 0.17, the Draft command toolbar is no longer the preferred Draft interface mode. Now the Taskview is preferred. The following information may no longer be accurate or work as described.


Draft Coordinates Toolbar.png

Draft coordinates entered in the command toolbar


Bara de comandă a atelierului este o bară de instrumente "inteligentă", ceea ce înseamnă că conținutul său se modifică în funcție de instrumentul utilizat și de intrarea necesară de la utilizator. Când desenați un cerc, de exemplu, bara de comandă vă va cere succesiv centrul de cerc, apoi raza. Aceste două valori pot fi indicate atât prin selectarea unui punct pe ecran, fie prin introducerea unor numere.

Whenever you see the number input fields appearing on the command bar, you can enter numbers in them You will see that those numbers also reflect the movements of your mouse cursor. You can TAB through the X,Y and Z fields to set the coordinates. Pressing ENTER in the Z field will record the point. Repeating the entry of new X, Y and Z coordinates will set the second point for a line and/or subsequent points for a wire.

Locking the Z coordinate

Draft Coordinates.jpg

Draft coordinates entered in the command toolbar (older FreeCAD)


Sometimes, it can be hard to align objects when working in 3D space. You can lock the Z coordinate, so you'll be certain that everything you draw will lie in the same horizontal plane. When you open FreeCAD, the Z coordinate is locked by default at 0.00, but you can easily change it, just unlock, change the Z value, and lock again. If Z coordinate is locked, you won't be able to draw in non-horizontal planes.

Most of the Draft commands now work in 3D, just unlock the Z coordinate and switch the view to the appropriate angle, and what you'll draw next will be aligned to that view.

Set the number of decimals

By default, FreeCAD works with two decimal places, to change the number of decimal places, you must:

  • add a new integer element Decimals in the menu Tools → Edit parameters... → BaseApp → Preferences → Units
  • make right click in the window and select New integer item → create name Decimals and enter the number of decimal places you want.
  • then click Save to disk, to validate your change.
  • close and return to FreeCAD to activate your changes.

Another way is using the parameter editor:

  • Go to Tools → Edit parameters → BaseApp → Preferences → Units, and change the "Value" of "Decimals" to the desired number.
  • If "Decimals" doesn't exist you can create it; right click in the window and select New integer item → Enter the name →, type in "Decimals", and proceed to enter the desired number.
  • Then click Save to disk and Close.
  • Restart FreeCAD to activate your changes.
PreferencesDecimals 01 en.png