Draft: Inserire le coordinate da tastiera

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft Coordinates and the translation is 100% complete.

Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎中文(中国大陆)‎
FreeCAD.png
Pagina successiva: Vincolare Arrow-right.svg

Descrizione

Gli strumenti Draft consentono di selezionare punti, distanze, raggi e angoli graficamente facendo clic sulla vista 3D con il puntatore.

Tuttavia, quando questi parametri devono essere precisi, è possibile inserire i valori esatti nella finestra di dialogo dello strumento.

Ci sono due interfacce possibili: la scheda Azioni e la Barra degli strumenti dei comandi. L'interfaccia predefinita è selezionata nel menu Modifica → Preferenze → Draft → Impostazioni generali → Modalità d'interfaccia Draft.

Pannello Azioni

Il pannello Azioni è una finestra intelligente che cambia il suo contenuto in base allo strumento utilizzato e l'input richiesto dall'utente. Ad esempio, quando si utilizza Cerchio, il pannello chiede il punto centrale e quindi il valore del raggio. Questi due parametri possono essere indicati selezionando un punto sulla vista 3D o immettendo i numeri.

Ogni volta che si vedono i campi di input apparire nella scheda Azioni, si possono inserire dei numeri al loro interno; inoltre, si vede che quei numeri riflettono il movimento del puntatore.

  • Premere il taso Tab o Invio per avanzare nei campi X, Y e Z; premere Invio quando il campo Z registra il punto.

A seconda dello specifico strumento Draft in uso, possono essere disponibili altre opzioni.

  • Premere R per passare dalle coordinate assolute e quelle relative.
  • Premere T per passare dalla modalità normale alla modalità continua.
  • Premere L per passare dalla modalità wireframe alla modalità faccia riempita.
  • Premere P per passare dalla modalità originale alla modalità copia.

Draft Coordinates Taskview.png

Vista azioni, prima schermata dello strumento Cerchio, immissione delle coordinate del centro


Draft Coordinates Taskview 2.png

Scheda azioni, seconda schermata per lo strumento Cerchio, inserimento del raggio


Barra degli strumenti del comando

(Novembre 2018) Da FreeCAD 0.17, la barra degli strumenti dei comandi di Draft non è più la modalità di interfaccia Draft preferita. Ora è preferibile la Scheda Azioni. Le seguenti informazioni possono non essere più accurate o funzionare come descritto.


Draft Coordinates Toolbar.png

Coordinate di Draft inserite nella barra degli strumenti del comando


La barra degli strumenti del comando Draft è una barra degli strumenti intelligente che modifica il suo contenuto in base allo strumento utilizzato e all'input richiesto dall'utente. Ad esempio, quando si utilizza Cerchio, la barra degli strumenti dei comandi chiede il punto centrale e quindi il valore del raggio. Questi due parametri possono essere indicati selezionando un punto sulla vista 3D o immettendo i numeri.

Ogni volta che si vedono i campi di input apparire nella barra degli strumenti del comando, si possono inserire dei numeri al loro interno; inoltre, si vede che quei numeri riflettono il movimento del puntatore.

  • Premere il taso Tab o Invio per avanzare nei campi X, Y e Z; premere Invio quando il campo Z registra il punto.
  • Premere R per passare dalle coordinate assolute e quelle relative.
  • Premere P per passare dalla modalità originale alla modalità copia.
  • Premere L per bloccare o sbloccare la coordinata Z. Ora questo è deprecato: il tasto L ora attiva la modalità di riempimento delle forme chiuse.

Bloccare la coordinata Z

Draft Coordinates.jpg

Coordinate Draft inserite nella barra degli strumenti del comando (vecchia versione di FreeCAD)


Quando si lavora nello spazio 3D può essere difficile allineare gli oggetti. Per questo motivo, si può bloccare la coordinata Z in modo da essere certi che tutto ciò che si disegna si trovi sullo stesso piano orizzontale. Quando si apre FreeCAD, la coordinata Z è bloccata di default a 0.00, ma si può cambiarla; basta sbloccarla, cambiare il valore Z e bloccarla di nuovo. Se la coordinata Z è bloccata, non è possibile disegnare piani non orizzontali.

La maggior parte degli strumenti Draft funziona nel piano di lavoro definito da Seleziona il piano. Pertanto, di solito non è necessario bloccare la coordinata Z, basta stabilire il piano di lavoro corretto.

Impostare il numero di decimali

Di default, per le quantità FreeCAD mostra due cifre decimali. Per modificare il numero di cifre decimali visualizzate, modificare le preferenze:

  • Andare in Modifica → Preferenze → Impostazioni generali → Unità, e impostare "Numero di cifre decimali" sul valore desiderato.
  • Poi premere Applica e OK.

Un altro modo è usare l'editor dei parametri:

  • Andare in Strumenti → Modifica parametri → BaseApp → Preferences → Units, e cambiare il "Valore" di "Decimals" nel numero desiderato.
  • Se "Decimals" non esiste si può crearlo; tasto destro del mouse nella finestra e selezionare Nuovo elemento integer → Inserisci il nome →, inserire "Decimals", e procedere inserendo il numero desiderato.
  • Poi cliccare su Salva su disco e poi su Chiudi.
  • Riavviare FreeCAD per attivare le modifiche.

PreferencesDecimals 01 en.png

Editor dei parametri per modificare il numenro di cifre decimali visualizzate in un valore numerico


FreeCAD.png
Pagina successiva: Vincolare Arrow-right.svg