Coordonnées (Planche à dessin)

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft Coordinates and the translation is 4% complete.

Outdated translations are marked like this.
Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎中文(中国大陆)‎

Dans tous les outils de la Planche à dessin, quand des emplacement 3D de points, distances, rayons, angles ou autres données numériques sont requis, vous pouvez toujours choisir de saisir ces valeurs graphiquement en cliquant à l'écran à l'aide de la souris, ou en saisissant directement des nombres au clavier. La première méthode est habituellement plus intuitive, mais si une précision absolue est nécessaire, vous devez souvent saisir un nombre précis afin d'être certain que la coordonnée créée est exacte. Par conséquent, la barre de commande de la Planche à dessin peut toujours accepter la saisie de nombres :

Draft Workbench tools allow you to pick points, distances, radiuses, and angles graphically by clicking on the 3D view with the pointer.

However, when these parameters need to be precise, it is possible to enter the exact values in the dialog for the tool.

There are two interfaces possible: taskview and command toolbar. The default interface is selected in the menu Edit → Preferences → Draft → General settings → Draft interface mode.

Taskview panel

The Taskview panel is an intelligent window that changes its contents according to the tool being used, and the input required from the user. For example, when using Draft Circle, the panel will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.

Whenever you see input fields appearing on the Taskview, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.

  • Press Tab or Enter to advance to the X, Y and Z fields; pressing Enter when in the Z field will record the point.

Depending on the specific Draft tool under use, there may be other options available.

  • Press R to switch between absolute and relative coordinates.
  • Press T to switch between normal mode and continue mode.
  • Press L to switch between wireframe mode and filled mode.
  • Press P to switch between original mode and copy mode.

Draft Coordinates.jpg

Draft Coordinates Taskview 2.png

Taskview, second screen for the Circle tool, entering the radius


Command toolbar

(November 2018) Since FreeCAD 0.17, the Draft command toolbar is no longer the preferred Draft interface mode. Now the Taskview is preferred. The following information may no longer be accurate or work as described.


Draft Coordinates Toolbar.png

Draft coordinates entered in the command toolbar


La barre de commande est une barre d'outils intelligente : en effet son contenu change en fonction de l'outil utilisé, et, l'action requise de l'utilisateur. Pour dessiner un cercle, par exemple, la barre de commande demande d'abord le centre du cercle, puis le rayon. Ces deux valeurs peuvent toutes deux être renseignées en cliquant un point à l'écran, ou par la saisie de nombres.

À chaque fois qu'un champ de saisie de nombre apparaît dans la barre de commande, vous pouvez saisir un nombre. Vous constaterez également que les nombres affichés reflètent les mouvements du curseur de la souris.

Locking the Z coordinate

Draft Coordinates.jpg

Draft coordinates entered in the command toolbar (older FreeCAD)


Il peut parfois être difficile d'aligner des objets en travaillant dans l'espace 3D. Vous pouvez verrouiller la coordonnée Z afin de vous assurer que tout ce que vous dessinerez reposera sur un même plan horizontal. Quand vous ouvrez FreeCAD, la coordonnée en Z est verrouillée par défaut à 0.00, mais vous pouvez facilement la changer : simplement déverrouiller, changer la valeur en Z, puis verrouillez-la à nouveau. Si la coordonnée en Z est verrouillée, vous ne pourrez pas dessiner sur des plans non-horizontaux.

La plupart des commandes de la Planche à dessin fonctionnent désormais en 3D, il suffit de déverrouiller la coordonnée en Z, et, de passer la vue dans un angle plus approprié, et, ce que vous dessinerez ensuite sera aligné à cette vue.

Lorsque vous entrez les coordonnées à partir clavier, assurez vous que le pointeur de votre souris soit hors de la zone de travail le seul mouvement de la souris modifie les coordonnées du champ sélectionné et vous serez obligé de répéter votre entrée.

Set the number of decimals

Par défaut, FreeCAD travaille avec deux décimales, pour modifier le nombre de décimales, vous devez :

  • ajouter un nouveau élément integer Decimals dans le menu Outils → Editer parametres... → BaseApp/Preferences/Units/
  • faites clic droit dans la fenêtre → sélectionnez Nouvel article entier → tapez le nom Decimals et entrez le nombre de décimales voulues. (FreeCAD travaille avec maximum 7 décimales)
  • puis cliquez sur le bouton Sauvegarder sur disque, pour valider votre modification.
  • fermez et retournez dans FreeCAD pour activer votre modification.

Another way is using the parameter editor:

  • Go to Tools → Edit parameters → BaseApp → Preferences → Units, and change the "Value" of "Decimals" to the desired number.
  • If "Decimals" doesn't exist you can create it; right click in the window and select New integer item → Enter the name →, type in "Decimals", and proceed to enter the desired number.
  • Then click Save to disk and Close.
  • Restart FreeCAD to activate your changes.
PreferencesDecimals 01 fr.png