Kreslení Souřadnice

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft Coordinates and the translation is 4% complete.

Outdated translations are marked like this.
Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎中文(中国大陆)‎

Ve všech nástrojích Kreslení, když jste žádání o umístění, vzdálenosti, poloměry, úhly nebu jiná numerická data 3D bodů , vždy si můžete vybrat zadání těchto hodnot graficky, výběrem myší na obrazovce nebo přímo zadáním čísel z klávesnice. První metoda je obvykle více intuitivní, ale když pracujete s absolutní přesností, často budete muset využít zadání přesného čísla a tak si být jisti, že zadané souřadnice jsou přesně tam, kde je chcete mít. Proto příkazový řádek kreslicího modulu může kdykoliv přijmout číselné zadání:

Draft Workbench tools allow you to pick points, distances, radiuses, and angles graphically by clicking on the 3D view with the pointer.

However, when these parameters need to be precise, it is possible to enter the exact values in the dialog for the tool.

There are two interfaces possible: taskview and command toolbar. The default interface is selected in the menu Edit → Preferences → Draft → General settings → Draft interface mode.

Taskview panel

The Taskview panel is an intelligent window that changes its contents according to the tool being used, and the input required from the user. For example, when using Draft Circle, the panel will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.

Whenever you see input fields appearing on the Taskview, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.

  • Press Tab or Enter to advance to the X, Y and Z fields; pressing Enter when in the Z field will record the point.

Depending on the specific Draft tool under use, there may be other options available.

  • Press R to switch between absolute and relative coordinates.
  • Press T to switch between normal mode and continue mode.
  • Press L to switch between wireframe mode and filled mode.
  • Press P to switch between original mode and copy mode.

Draft Coordinates Taskview.png

Taskview, first screen for the Circle tool, entering center coordinates


Draft Coordinates Taskview 2.png

Taskview, second screen for the Circle tool, entering the radius


Command toolbar

(November 2018) Since FreeCAD 0.17, the Draft command toolbar is no longer the preferred Draft interface mode. Now the Taskview is preferred. The following information may no longer be accurate or work as described.


Draft Coordinates Toolbar.png

Draft coordinates entered in the command toolbar


Příkazový řádek kreslení je "inteligentní" nástrojový pruh, což znamená, že jeho obsah se mění podle nástroje, který je právě používán a podle vstupu požadovaného od uživatele. Když kreslíte například kružnici, příkazový řádek od Vás bude postupně vyžadovat střed kružnice a potom její poloměr. Obě tyto hodnoty mohou být zadány kliknutím na bod na obrazovce nebo zadáním čísel.

Kdykoliv uvidíte na příkazové řádce vstupní číselné pole, můžete do něj vložit číslo. Uvidíte, že to číslo má vliv na pohyb kurzoru myši na obrazovce. Pomocí klávesy TAB můžete přecházet mezi poli X,Y a Z a nastavovat souřadnice. Stisknutím klávesy ENTER v poli Z zaznamená umístění bodu. Opakovaným zadáním nových souřadnic X, Y a Z nastavíte polohu druhého bodu pro přímku a nebo případnými dalšími body vytvoříte drát.

Locking the Z coordinate

Draft Coordinates.jpg

Draft coordinates entered in the command toolbar (older FreeCAD)


Někdy je obtížné zarovnat objekty při práci ve 3D prostoru. Můžet uzamknout souřadnici Z, a tím si budete jisti, že všechno co kreslíte je ve stejné vodorovné rovině. Když spustíte FreeCAD, je souřadnice Z defaultně uzamčena na 0.00, ale to můžete snadno změnit, když ji odemknete, změnite hodnotu Z a opět ji zamknete. Je-li souřadnice Z uzamčena, nebudete moci kreslit mimo právě nastavenou vodorovnou rovinu.

Většina příkazů Kreslení nyní pracuje ve 3D, takže můžete odemknout souřadnici Z a přepnout pohled do odpovídajícího úhlu a to co budete kreslit dál, bude zarovnáno podle tohoto pohledu.

Set the number of decimals

Defaultně pracuje FreeCAD se dvěma desetinými místy. Pokud chcete změnit počet desetinných míst musíte:

  • přidat nový celočíselný prvek Decimals v menu Tools → Edit parameters... → BaseApp → Preferences → Units.
  • kliknout pravým tlačítkem na okno a vybrat New integer item → create name Decimals a vložit požadovaný počet desetinných míst.
  • potom kliknout na tlačítko Uložit na disk, pro uložení změny.
  • zavřít a znovu otevřít FreeCAD, aby se zadaná změna aktivovala.

Another way is using the parameter editor:

  • Go to Tools → Edit parameters → BaseApp → Preferences → Units, and change the "Value" of "Decimals" to the desired number.
  • If "Decimals" doesn't exist you can create it; right click in the window and select New integer item → Enter the name →, type in "Decimals", and proceed to enter the desired number.
  • Then click Save to disk and Close.
  • Restart FreeCAD to activate your changes.

PreferencesDecimals 01 en.png

Parameter editor to change the decimal places shown by a numerical value