Grundlegendes Part Design Tutorial

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Basic Part Design Tutorial 017 and the translation is 98% complete.

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎română • ‎русский • ‎Türkçe

Base ExampleCommandModel.png Tutorial

Thema
Modeling
Niveau
Beginner
Zeit zum Abschluss
Untere einer Stunde
Autor
HarryGeier (HarryGeier)
FreeCAD version
0.17 or higher
Beispieldatei(en)
Basic Part Design for v0.17


Dieses Tutorial richtet sich an Anfänger und beschreibt einige, aber nicht alle, Werkzeuge und Techniken des Arbeitsbereichs Part Design. Dem Leser wird dabei Schritt für Schritt erklärt, wie das in der nachfolgenden Abbildung sichtbare Modell mittels Skizzen in FreeCAD erstellt werden kann.

Dieses Tutorial basiert auf Basic Part Design Tutorial von Quick61 mit Änderungen für die Version v0.17.

Tut17 final refined.png

Ein Video (englisch) der kompletten Konstruktion finden Sie hier: https://youtu.be/geIrH1cOCzc

( Für jeden Teilbereich gibt es auch ein einzelnes Video )

Vorwort

Die Aufgabe

In diesem Tutorial verwenden Sie den Part Design Arbeitsbereich (Workbench), um ein 3D-Volumenmodell des in der Zeichnung (Drawing) gezeigten Teils zu erstellen. Alle notwendigen Abmessungen, um diese Aufgabe zu erfüllen, sind angegeben. Sie beginnen damit, dass Sie eine Kernform aus einer Basisskizze erstellen und dann auf dieser Form aufbauen, indem Sie sogenannte Features hinzufügen. Diese Features oder Formelemente fügen entweder dem Material Material hinzu oder entfernen es mithilfe zusätzlicher Skizzen und begleitender Feature-Operationen. Dieses Tutorial wird nicht alle Funktionen und Werkzeuge verwenden, die in der Part Design Workbench verfügbar sind, sollte aber das nötige verwenden, um dem Benutzer dieses Tutorials eine grundlegende Grundlage zu geben, auf der er sein Wissen und seine Fähigkeiten aufbauen kann.

Das Bauteil

Tutorial Drawing Sheet.png

Konstruieren des Teils

Start

Beginnen Sie zuerst damit, dass Sie in die Part Design Workbench wechseln. Dort sollten Sie ein neues Dokument erstellen, wenn Sie dies noch nicht getan haben.
Es empfiehlt sich, die Arbeit oft zu speichern, also speichern Sie das neue Dokument vor der Bearbeitung und geben Sie ihm einen beliebigen Namen.

Alle Arbeiten in Part Design beginnen mit einem Bauteil (Körper). Dann erstellen wir den Festkörper im Körper beginnend mit einer Skizze.

  1. Klicken Sie auf diese Schaltfläche PartDesign Body.png, um ein neues Bauteil zu erstellen und es zu aktivieren. Hinweis: dieser Schritt kann ausgelassen werden. Wenn eine Skizze erstellt und kein existierender Körper gefunden wird, wird automatisch ein neuer erstellt und aktiviert.
  2. Klicken Sie auf PartDesign NewSketch.pngSkizze erstellen, um eine neue Skizze innerhalb des gerade erstellten Bauteils zu erstellen.
  3. Wir müssen definieren, wo die Skizze befestigt wird. Wir werden das an einer Ebene im Ursprung des Körpers tun.
  4. Wählen Sie im Aufgaben-Reiter der Combo-Ansicht die YZ-Ebene aus der Liste und drücken OK.
Tut17 sketchplanes.png

Hinweis: Es ist möglich, dass der OK-Button nicht zu sehen ist, wenn die Seitenleiste nicht breit genug ist. Sie können sie durch Ziehen an der rechten Begrenzung vergrößern. Platzieren Sie dazu den Mauszeiger über der Begrenzung; wenn der Zeiger zu einem Pfeil mit zwei Spitzen wird, drücken und halten Sie die linke Maustaste und ziehen die Maus.

Sobald Sie OK drücken, wechselt FreeCAD automatisch zum Skizzierarbeitsbereich und öffnet die Skizze im Änderungsmodus.

Tut17 sketcherempty.png

Erstellen Sie die Skizze

Als nächstes werden Sie das Polylinien-Werkzeug Sketcher CreatePolyline.png verwenden und eine Form ähnlich der im nächsten Bild erstellen. Es muss und sollte nicht perfekt sein, da die endgültige Form mit Einschränkungen gemacht wird. Sobald Sie die Grundform haben, werden wir anfangen, diese anzuwenden. Wenn Sie die automatischen Einschränkungen aktiviert haben, werden einige dieser Einschränkungen automatisch angewendet. Wenn nicht, führen Sie die folgenden Schritte aus. Stellen Sie zuerst sicher, dass Sie das Polylinien-Werkzeug durch Rechtsklick oder zweimaliges Drücken von Esc verlassen haben; der Maus-Cursor sollte von einem Fadenkreuz zurück zum Standard-Pfeil-Cursor gewechselt sein. (Drücken Sie _nicht_ ein drittes Mal Esc, oder Sie verlassen den Skizzeneditiermodus; falls das passiert, klicken Sie auf den Modell-Reiter, dann doppelklicken Sie das Skizzenelement im Baum oder rechtsklicken Sie und wählen Skizze editieren im Kontextmenü).

  1. Wählen Sie die zwei horizontalen Linien mit der Maus aus, indem Sie darauf klicken, dann klicken Sie nach der Auswahl auf die horizontale Bedingung Constraint Horizontal.png.
  2. Wählen Sie die vertikale Linie auf der rechten Seite und klicken Sie dann auf die vertikale Einschränkung Constraint Vertical.png.
  3. Wählen Sie die Anfangs- und Endpunkte Ihrer Polylinie und klicken Sie auf die Punkt auf Punkt Koinzidenz Bedingung Sketcher ConstrainCoincident.png, um die Polylinie zu schließen.
  4. Wählen Sie die untere horizontale Linie und die rechte vertikale Linie aus und wenden Sie an und Sketcher ConstrainEqual.png Gleichheits-Beschränkung.
  5. Wählen Sie entweder die horizontale oder die vertikale Linie und wenden Sie entweder eine entsprechende horizontale Sketcher ConstrainDistanceX.png oder vertikale Sketcher ConstrainDistanceY.png vertikale Distanz an und geben Sie einen Wert von 26 mm ein .
  6. Wählen Sie die obere horizontale Linie aus und wenden Sie die horizontale Abstandsbeschränkung an und geben Sie einen Wert von 5 mm ein.
  7. Wählen Sie den unteren rechten Punkt(Endpunkt) der horizontalen Linie und dann den Mittelpunkt des Rasters und wenden Sie die Punkt auf Punkt Koinzidenz Sketcher ConstrainCoincident.png Beschränkung, um Ihre Form zu fixieren.

An diesem Punkt sollten Sie eine vollständig eingeschränkte Skizze haben, wie durch die Farbe und die in der Combo-Ansicht angezeigte Nachricht angezeigt. Es sollte jetzt genau wie das Bild unten aussehen.

Tut17 profile.png

Klicken Sie nun in der Combo-Ansicht auf die Schaltfläche Schließen, um den Skizzenbearbeitungsmodus zu verlassen, und wählen Sie Skizze aufpolstern PartDesign Pad.png (Pad) aus der Symbolleiste oder Block aus dem Aufgaben - Menü. Leider sind derzeit 2 Begriffe dafür in der Programmübersetzung Aufpolstern = Block = PAD . Dies öffnet ein Block (Pad) Dialogfeld in der Combo-Ansicht. Wählen Sie in diesem Dialogfeld zuerst das Pulldown-Menü Typ aus und dann Zwei Längen. Die Zeichnung am Anfang dieses Tutorials sagt aus, dass das Teil 53 mm lang ist. Wir erreichen dies, indem wir unsere Skizze in beide Richtungen von der Mittelebene aus auffüllen, um diese Distanz zu bilden, d. H., wir machen den Block symmetrisch bezüglich der Skizzierebene. Der Grund dafür wird später beim Erstellen von Features klar werden. Da wir wollen, dass das Teil insgesamt 53 mm lang ist, werden wir 26,5 für die Länge und 26,5 für die zweite Länge eingeben. Alternativ könnten Sie eine einzelne Länge von 53 mm einstellen und auf das Kontrollkästchen Symmetrisch zu Ebene klicken. Sobald das erledigt ist, haben wir nun unsere Basis, auf der wir zusätzliche Features hinzufügen werden, um unser Teil zu konstruieren.

Ein Video der Schritte in diesem Teil des Tutorials ist hier: https://youtu.be/cUyPnCMeTgg

Formelement Tasche und externe Geometrie

Mit der Maus oder den Ansichtssymbolen drehen Sie das Modell um, so dass Sie seine Rückseite sehen können. Sobald die Rückseite des Teils sichtbar ist, wählen Sie die Rückseite aus, indem Sie darauf klicken, wie im nächsten Bild zu sehen ist.

PD WB Tutorial003.png

Nachdem die Oberfläche ausgewählt wurde, klicken Sie auf das Symbol Neue Skizze PartDesign NewSketch.png in der Werkzeugleiste oder im Teilbild Design-Menü und dies wird unsere nächste Skizze auf die Rückseite des Teils platzieren. Wählen Sie nun das Rechteck Sketcher CreateRectangle.png Werkzeug aus und platzieren Sie dieses auf der Rückseite des Teils auf ähnliche Weise wie unten gezeigt. Folgen Sie nun den aufgeführten Schritten, und beschränken Sie die Skizze.

  1. Wählen Sie eine der horizontalen Linien aus und wenden Sie eine horizontale Abstandseinschränkung Sketcher ConstrainDistanceX.pngund einen Wert von 5 mm an.
  2. Wählen Sie eine der vertikalen Linien und geben Sie ihr eine vertikale Abstandseinschränkung Sketcher ConstrainDistanceY.png und einen Wert von 11 mm.
  3. Wählen Sie das Sketcher External.png externe Geometrie Werkzeug
  4. Wählen Sie den oberen rechten Eckpunkt der Oberfläche und klicken darauf, um einen Punkt aus der Geometrie des bereits erstellten Blocks zu erhalten, mit welchem unsere Skizze verknüpft werden soll.
    Tut17 slot unconstrained.png
  5. Rechtsklicken Sie zur Beendigung des Externe-Geometrie-Modus
  6. Wählen Sie den gerade mit dem Externe Geometrie-Werkzeug erstellten Projektionspunkt und wählen zudem den oberen rechten Eckpunkt des in der Skizze vorhandenen Rechtecks. Durch einen nun folgenden Klick auf Koinzidenz Constraint PointOnPoint.svg sollte die Skizze komplett festgelegt sein und wie das nächste Bild aussehen.
Tut17 slote constrained.png

Sobald dies geschehen ist, klicken Sie auf die Schaltfläche Schließen oben in der Registerkarte Aufgaben in der Combo-Ansicht und wählen dann Vertiefung PartDesign Pocket.png aus der Symbolleiste oder Tasche aus dem Teilentwurfsmenü. Leider sind derzeit 2 Begriffe dafür in der Programmübersetzung : Tasche = Vertiefung = POCKET . Das Tasche Werkzeug ist das Gegenteil des Pad-Werkzeugs. Während das Pad-Werkzeug dem Teil Material hinzufügt, entfernt das Pocket-Werkzeug Material aus dem Teil. Beide Operationen werden als Features bezeichnet. In diesem Pocket-Vorgang möchten wir im Pulldown-Menü Typ Durch alle auswählen und dann auf die Schaltfläche OK klicken.

Stellen Sie für die nächste Operation sicher, dass "Pocket" im Modell Tab der Combo-Ansicht ausgewählt ist und klicken Sie auf gespiegeltes Objekt erzeugen PartDesign Mirrored.png, oder Spiegeln im Part Design-Menü. Wählen Sie im Dialogfeld Mirrored Parameters in der Combo-Ansicht die Option Horizontale Skizzenachse aus dem Pulldown-Menü Ebene. Klicken Sie dann auf OK. Die Mirror-Funktion funktioniert deshalb auf diese Weise, weil das Basis-Feature unseres Modells in beiden Richtungen von der horizontalen Ebene aus, in der ersten Operation mit der Basisskizze gepolstert wurde. Wenn alles gut gegangen ist, sollten Sie jetzt ein Teil haben, welches dem Bild unten entspricht, nachdem Sie es in die Vorderansicht gedreht haben.

Tut17 profilewithslots.png

Ein Video der Schritte in diesem Teil des Tutorials ist hier: https://youtu.be/wiGXV9G7mrM

Features mit Pad und externer Geometrie

Sehen Sie sich das Bauteil aus allen Richtungen einmal an und wählen Sie wieder die Rückseite des Teils aus, um die nächste Skizze zuzuordnen.

Tut17 profilewithslotsrearplane.png

Wählen Sie Neue Skizze und erstellen Sie ein neues Rechteck in dieser, ähnlich wie im folgenden Bild gezeigt. Fahren Sie dann fort, diesem Rechteck dimensionale Einschränkungen hinzuzufügen.

  1. Wählen Sie eine horizontale Linie und wenden Sie eine horizontale Abstandseinschränkung mit einem Wert von 16.7 an.
  2. Wählen Sie eine vertikale Linie aus und wenden Sie eine vertikale Abstandseinschränkung von 7 mm an.
  3. Wählen Sie mit dem Werkzeug Externe Geometrie den oberen linken Eckpunkt der Bauteilfläche aus.
Tut17 sidblockunconstrained.png

Durch Auswahl der gerade projizierten Ecke und der oberen linken Ecke des Rechtecks werden mit Hilfe der Koinzidenzeinschränkung die noch vorhandenen Freiheitsgrade beseitigt und die Skizze vollständig festgelegt.

Tut17 sideblockconstraind.png

Close the Sketcher.

Als nächstes beenden wird diese Skizze und klicken auf Block . Im Block-Dialog der Combo-Ansicht wollen wir eine Länge von 26 mm eintragen, wobei wir den Typ als Dimension belassen und dann das Kontrollkästchen Reversed markieren. Wenn Sie das Kontrollkästchen Umgekehrt verwenden, wird der Block in das Teil und nicht in das Teil verschoben. Diese Operation liefert das folgende Ergebnis.

Tut17 sideblock.png

Verwenden Sie die Mirror-Funktion erneut, um den zweiten Block zu erhalten. Stellen Sie zunächst sicher, dass der erstellte Block in der Modellansicht ausgewählt ist, und klicken Sie dann in der Symbolleiste auf erzeuge gespiegeltes Objekt oder Spiegeln aus dem PartDesign Menü . Wir werden die oben für Pocket durchgeführte Operation wiederholen und im Pulldown-Menü Ebene die Option Horizontale Skizzenachse auswählen.

Tut17 profilewithsideblocks.png

Ein Video der Schritte in diesem Teil des Tutorials ist hier: https://youtu.be/Ido1owp8ubc

Feature mit Taschen- und Außengeometrie

An diesem Punkt drehen wir das Teil in der Ansicht nach vorne, wir können sehen, dass unser Teil nun wie das Teil in der bemaßten Zeichnung am Anfang dieses Tutorials aussieht. Sobald Sie die Ansicht der Vorderseite haben, klicken Sie mit der Maus auf die geneigte Oberfläche, um diese auszuwählen, da wir diese für die nächste Skizze verwenden werden.

Tut17 innerplane.png

Hier werden wir wieder das Rechteck-Werkzeug verwenden und ein Rechteck in unsere Skizze einfügen, und nachdem Sie dies getan haben, wenden Sie die folgenden Bedingungen an.

  1. Wählen Sie eine horizontale Linie und eine vertikale Linie, und klicken Sie nach der Auswahl beider auf die Bedingung Gleich.
  2. Wählen Sie entweder eine horizontale oder vertikale Linie und wenden Sie eine entsprechende horizontale oder vertikale Abstandseinschränkung mit einem Wert von 17 mm an.
  3. Wählen Sie mit dem Werkzeug Externe Geometrie den oberen rechten Eckpunkt aus, wie in der Abbildung unten gezeigt.
Tut17 rechtangleholeunconstrained.png

Gemäß den Maßen der nachfolgenden Abbildungen sollen folgende Beschränkungen erstellt werden.

  1. Zwischen dem projizierten Eckpunkt und dem oberen, rechten Eckpunkt des Rechtecks eine horizontale Distanz von 7 mm.
  2. Zwischen dem projizierten Eckpunkt und dem oberen, rechten Eckpunkt des Rechtecks eine vertikale Distanz von 11 mm.

Das Ergebnis sollte folgendermaßen aussehen.

Tut17 rectangleholeconstrained.png

Würde man an dieser Stelle diese Skizze einfach zu einer Tasche ausformen, wäre das resultierende Loch senkrecht zu der geneigten Fläche, welcher es zugeordnet ist, und das ist nicht, was wir wollen.

Tut17 wrongplaneforpocket.png


Wir möchten, dass das Loch senkrecht zur Rückseite steht, aber die projizierten Abmessungen des Hohlraums von der Rückseite gesehen, sind dann nicht die Abmessungen von 17 mm x 17 mm, welche in der Zeichnung angegeben sind. Man müßte erst die erforderlichen Berechnungen durchführen um die erforderlichen Abmessungen zu erhalten. Oder wir können die in FreeCAD bereitgestellten Tools verwenden, um diese Projektion für uns zu erstellen.

Ein Video der Schritte in diesem Teil des Tutorials ist hier: https://youtu.be/x4d5nZPWCLQ


Um eine Tasche zu erstellen, die das geneigte Rechteck als Auslass hat, zeichnen wir ein neues Rechteck auf der Rückseite, wobei wir die Projektion des geneigten Rechtecks als externe Referenz verwenden. Bewegen Sie das Bauteil herum, um die Rückseite des Teils zu sehen, und wählen Sie diese aus, um darauf die letzte Skizze zu erstellen.

Tut17 profilewithsideblocksrearplane.png

Wählen Sie wieder Neue Skizze. Im Skizzenbearbeitungsmodus sehen wir das skizzierte Rechteck der Steigung nun nicht mehr. Um es auswählbar zu machen, wechseln wir die Combo-Ansicht zur Modell-Registerkarte und wählen die letzte Skizze (Sketch003) auf der geneigten Ebene. Diese müssen Sie dann mit der Leertaste sichtbar machen. Als nächstes wählen Sie die Spiegelfunktion oben (Mirrored001) und wieder mit der Leertaste, verstecken Sie diese. Danach sollten Sie das Rechteck in der 3D-Ansicht sehen. Sie können weiterhin mit der sichtbaren Registerkarte "Modell" arbeiten oder zur Registerkarte "Aufgaben" zurückkehren. Wählen Sie mit dem Werkzeug Sketcher External.png Externe Geometrie die oberen und unteren horizontalen Kanten des geneigten Rechtecks aus.

Tut17 rectangleunconstrained.png
  1. Wählen Sie den oberen linken Eckpunkt des Rechtecks und den oberen linken Punkt der externen Geometrie und klicken Sie auf die Koinzidenzbedingung Constraint PointOnPoint.svg.
  2. Klicken Sie auf den unteren rechten Eckpunkt des Rechtecks und den unteren rechten Punkt der externen Geometrie und klicken Sie wiederum auf die Koinzidenzbedingung .

Und wir sollten dies erreicht haben.

Tut17 rectangleconstrained.png

Schließen Sie das Skizzierfenster für den letzten Schritt in diesem Lernprogramm mit 'Beenden' oder 'Bearbeitung beenden' aus dem Kontextmenü von sketch004 und wählen Sie dann die Funktion PartDesign Pocket.png Pocket aus der Werkzeugleiste oder aus dem Part Design-Menü. Wählen Sie im Pulldown-Menü "Typ" die Option "Durch alle" und klicken Sie auf die Schaltfläche OK.

Tut17 final.png

An diesem Punkt werden Sie einige Linien sehen, die von sich überschneidenden Merkmalen kommen. In diesem Fall schneidet der Seitenblock das Basisprofil und lässt ihn als dreieckigen Block über dem Profil erscheinen. Um diese Linien zu entfernen, können Sie entweder "Form verfeinern" in Ihren Part-Design-Einstellungen aktivieren oder, um Rechnerleistung sparen und diese Linien beim Konstruieren zu behalten, diese bei jeder Funktion einzeln aktivieren, durch welche solche Linien erzeugt werden. Die Einstellung auf Feature-Ebene kann auf der Registerkarte "Daten" der Funktion vorgenommen werden. Setzen Sie die Refine Eigenschaft auf TRUE, um die Kantenoptimierung aufzurufen.

Tut17 refine.png
Tut17 final refined.png




Ein Video dieser Schritte finden Sie hier: https://youtu.be/UYI0gvxCYeI


Dieses Tutorial und Ihr Modell sind beendet.

Siehe auch

  • Links zum zugehörigen Video wurden eingefügt.
  • FreeCAD Datei zum Vergleich (mit 0.17 ertellt) Download