Arch-Elemente-Tutorial

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Arch panel tutorial and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

Base ExampleCommandModel.png Tutorial

Thema
Modellierung eines Architektur-Panels
Niveau
Anfänger
Zeit zum Abschluss
60 Minuten
Autor
Yorik
FreeCAD version
Beispieldatei(en)

Contents


Dies ist ein Mehrfach-Posting eines Tutorials, das zuerst auf Open-Source Ecology erschienen ist.

Präsentation von FreeCAD

Arch panel tutorial 01.jpg

FreeCAD ist ein parametrisches 3D-Modellierungsprogramm. Parametrische Modellierung erlaubt es Dir, einfach Dein Design zu modifizieren, indem Du in deiner Modellierungshistorie zurückgehst und die Parameter änderst. FreeCAD ist Open-Source (LGPL-Lizenz) und sehr modular, erlaubt dadurch umfangreiche Erweiterung und Anpassung, dank der intensiven Nutzung der Python-Programmiersprache.

FreeCAD installieren

Du hast die Möglichkeit, die letzte stabile Version (im Juli 2018 die Version 0.16) oder eine Entwicklerversion (momentan 0.17) zu installieren. Tatsächlich sind Entwicklerversionen normalerweise ziemlich stabil, und Du wirst ernsthaft ermuntert, eine Entwicklerversion auszuprobieren, solange Du keinen bestimmten Grund hast, es nicht zu tun. Wenn Du Entwicklerversionen selbst herunterlädst, dann solltest Du von Zeit zu Zeit nachsehen und neu installieren/aktualisieren, um von den Verbessereungen zu profitieren, weil die FreeCAD-Entwicklung ziemlich zügig vorangeht.

  • Auf Windows: Lade die aktuellste Version für Deine Windows-Version (32- oder 64-Bit) von [1]. Doppelklicke zur Installation der Datei (Anm. d. Ü.: 0.16 ist die letzte Version für XP).
  • Auf Mac OS: Lade die aktuellste Version von [2]. Doppelklicke zur Installation der Datei.
  • Auf Ubuntu: Die von Ubuntu bereitgestellte Version ist normalerweise veraltet, daher raten wir, stattdessen das von der FreeCAD-Community gewartetet PPA zu verwenden.
  • Auf anderen Plattformen: In den am meisten verwendeten Linux-Distriutionen (Debian, Fedora, etc.) ist FreeCAD in den offiziellen Software-Repositories enthalten. Es mag allerdings nicht immer die aktuellste Version sein. Falls die von Dir benötigte Version nicht verfügbar ist, ist Deine einzige Option, FreeCAD selbst zu kompilieren (Anweisungen auf der FreeCAD-Webseite)

Zusätzliche optionale Inhalte

  • IFC Import/Export aktivieren: Um Projekte ins/vom IFC-Dateiformat zu exportieren bzw. importieren, verlässt sich FreeCAD auf den ifcOpenShell-Importer, den Du separat von [3] herunterladen musst. Achte darauf, eine Python-2.7-basierte Version zu verwenden, das ist die gleiche für FreeCAD verwendete Python-Version.
  • Drawing dimensioning workbench: Ein zusätzlicher Arbeitsbereich für FreeCad, der viele zweckmäßige Werkzeuge zum Hinzufügen von Bemaßungen und Anmerkungen zu FreeCADs 2D-Zeichenblättern bietet: https://github.com/hamish2014/FreeCAD_drawing_dimensioning (Installationshinweise auf der Webseite)
  • Assembly2 workbench: Ein zusätzlicher Arbeitsbereich für FreeCAD, der eine Reihe von wichtigen Baugruppen-Werkzeugen bietet: https://github.com/hamish2014/FreeCAD_assembly2 (Installationshinweise auf der Webseite)

Schnellstarthinweise

Die Sammlung der im FreeCAD-Wiki verfügbaren Tutorien ist immer noch sehr spärlich. Allerdings nutzen viele Mitglieder der FreeCAD-Community youtube, um Video-Tutorien zu veröffentlichen. Achte darauf, dass Du FreeCAD-bezogenen Inhalt auf youtube suchst, das ist sicherlich die beste Quelle für Lernmaterial.

FreeCAD ist eine sehr technische Anwendung und die Lernkurve kann sehr steil sein. Vertraue auf Tutorien und das Dokumentation-Wiki und zögere nicht, im Forum Fragen zu stellen, wenn Du ein bestimmtes Problem hast. Auf klar gestellte Fragen gibt es normalerweise sehr schnelle und umfangreiche Antworten.

Eine sehr grobe Liste von Dingen, die Du wissen musst

  • Das FreeCAD-Interface ist in Arbeitsbereiche unterteilt. Arbeitsbereiche sind einfach Werkzeugsammlungen (Symbolleisten von Knöpfen und Menüs), die zusammengefasst sind, normalerweise für eine bestimmte Aufgabe. Wenn Du zu einem anderen Arbeitsbereich wechselst, zeigt Dir das Interface die Werkzeuge dieses Arbeitsbereichs. Aber der Inhalt Deines 3D-Dokuments ändert sich nicht. Du arbeitest immer noch am gleichen Dokument und an den gleichen Objekten.
  • FreeCAD ist immer noch in Entwicklung, es gibt immer noch viele Bugs, und die Anwendung könnte manchmal abstürzen. Sichere oft und aktiviere Sicherungsdateien in Bearbeiten → Einstellungen → Dokument
  • Die meisten FreeCAD-Objekte sind parametrisch. Das bedeutet, dass ihre Geometrien automatisch aus einer Reihe von Parametern erstellt werden. Diese Parameter sind immer in der Eigenschaft-Ansicht änderbar. Sie sind immer unterteilt in die Parameter, die die Geometrie selbst beeinflussen (Daten-Reiter) und die Parameter, die nur die Anzeige des Objekts (Ansicht-Reiter) beeinflussen. Allerdings sind durch andere Anwendungen erzeugte und in FreeCAD importierte Objekte nicht durch Parameter definiert und deshalb nicht änderbar.
  • Einige Arbeitsbereiche (PartDesign und Arch) sind gemacht, um nur mit Volumenkörpern arbeiten, und sie werden die Arbeit an Objekten verweigern, die keine Volumenkörper sind. Eine gute Faustregel ist, möglichst nur mit Volumenkörpern zu arbeiten.
  • Obwohl FreeCAD Netzobjekte importieren und mit ihnen arbeiten kann (Mesh-Arbeitsbereich), ist es vorrangig gedacht, mit einem fortgeschritteneren Objekttyp namens brep zu arbeiten, der von den meisten Arbeitsbereichen genutzt wird (Part, PartDesign, Draft, Sketcher, Arch). Wenn Netz-basierte Dateien (.dae, .orb, .stl...) importiert werden, musst Du normalerweise diese Objekte in brep-Objekte konvertieren, bevor Du etwas Interessantes mit ihnen machen kannst. Volumenkörper-basierte Dateiformate (.step, .iges) erzeugen beim Import in FreeCAD direkt brep-Objekte. 2D-Formate (.dxf, .svg) erzeugen ebenfalls brep-Inhalte.
  • FreeCAD hat verschiedene Wege oder Arten, um die Maus-Knöpfe zu nutzen. Diese Arten können in den Einstellungen gesetzt werden oder ändern sich während der Laufzeit durch Rechtsklicken auf den Hintergrund der 3D-Ansicht. Sie sind beschrieben auf http://www.freecadweb.org/wiki/index.php?title=Mouse_Model. Die am besten gefallenden Arten für die CAD-Arbeit sind CAD oder Gestures.

Übung: Eine Dachhaut modellieren

Um einen typischen Arbeitsablauf in FreeCAD zu präsentieren, werden wir eine Dachhaut wie auf MicroHouse_4_Roof_-_Module_-_Build_Instructions erstellen. Um das zu tun, starten wir mit dem Zeichnen der verschiedenen Teile in einer 2D-Skizze mit Festlegungen (Constraints), dann nutzen wir die Vorteile des speziellen Arch-Fenster-Objekts, das in der Lage ist, komplexe 3D-Objekte aus einer 2D-Skizze zu erstellen, die die Konturen verschiedener Teile enthält. Schließlich, da wir kein Fenster, sondern eine Dachhaut benötigen, werden wir das Fenster-Objekt in einen weiteren Arch-Typ konvertieren.

1. Öffne FreeCAD, dann setze die bevorzugten Einheiten auf "imperial"

Im Menü Bearbeiten → Einstellungen → Allgemein → Einheiten → Einheitsystem (Anm. d. Ü.: Um Unklarheiten zu vermeiden, wurde im Text die Einheit "in" durch "Inch" ersetzt).

2. Wechsel' zum Sketcher-Arbeitsbereich und erstelle eine neue Skizze in der XY-Ebene

Arch panel tutorial 02.jpg

Solange es keinen bestimmten Grund gibt, es nicht zu tun, wirst Du Deine 2D-Skizzen normalerweise immer auf dem Boden beginnen, um den Ursprung (0,0) herum. Dann wird das daraus generierte 3D-Objekt in Position gedreht/rotiert.

3. Zeichne zwei Rechtecke. Setze auf jedem eine vertikale Festlegung von 16 ft und eine horizontale Festlegung von 2 Inch

Arch panel tutorial 03.jpg

Mach' Dir beim Zeichnen keine Gedanken über die Abmessungen der Teile, denn die Festlegungen werden die Größen entsprechend anpassen. Um eine (horizontale oder vertikale) Abmessungsfestlegung hinzuzufügen, kannst Du entweder eine Linie oder (mit gedrückter Strg) zwei Punkte auswählen.

4. Sobald Deine beiden Rechtecke die richtige Größe haben, setze eine vertikale Festlegung von 0 zwischen ihre Eckpunkte und eine horizontale Festlegung von 4 ft

Arch panel tutorial 04.jpg

Dies stellt sicher, dass unsere beiden Rechtecke richtig positioniert sind in Relation zueinander.

5. Füge zwei zusätzliche 2 Inch x 6 Inch-Teile hinzu

Arch panel tutorial 05.jpg

Füge zwei weitere Rechtecke hinzu und wiederhole den Vorgang. Beachte, dass wir im obigen Beispiel die Länge der Teile nicht angegeben, sondern eine Längenfestlegung zwischen den Endpunkten und den langen vertikalen Teilen getroffen und eine schmale Lücke von 0,05 Inch zwischen ihnen gelassen haben. Der Grund dafür ist, dass FreeCAD die Vierecke (loops) falsch ermitteln könnte, wenn sich die Rechtecke berühren würden, und wir dadurch merkwürdige Ergebnisse beim Arch-Fenster-Werkzeug erhalten würden. Dieser kleine Trick stellt sicher, dass jedes Rechteck vom Arch-Fenster-Werkzeug als ein unabhängiges Viereck erkannt wird.

6. Die Eckverstärkungsstücke hinzufügen

Arch panel tutorial 06.jpg

Das Gleiche nochmal. Mach' sie 6 Inch breit und mit einem Abstand von 0,05 Inch zu den anderen Rechtecken.

7. Zeichne sieben dazwischenliegende Verstärkungsteile mit einer Breite von 2 Inch und setze eine Festlegung bei 0,05 Inch von den linken und rechten Endpunkten der vertikalen Rechtecke (oder bei 0 Inch der Endpunkte der anderen horizontalen Rechtecke)

Arch panel tutorial 07.jpg

Abhängig von Deinem System kann es sein, dass FreeCAD beginnt, neue Festlegungen langsamer zu verarbeiten. Dies ist der Nachteil, wenn man festgelegte Objekte benutzt, dass sie schnell eine Menge von Systemressourcen schlucken. Du musst immer entscheiden, ob Du sie wirklich brauchst. Du kannst auch Festlegungen löschen, wenn sie nicht mehr benötigt werden. Diese Abmessungen werden nicht mehr festgelegt, aber solange Du die Teile nicht bewegst, ändern sie sich auch nicht. Falls nötig, kannst Du später auch Festlegungen erneut hinzufügen.

8. Berechne den Abstand zwischen den sieben Verstärkungsteilen und setze vertikale Festlegungen zwischen sie

In unseren Fall ist die Gesamtlänge 192 Inch, minus die beiden Endstücke (2 x 2 Inch) und die beiden Eckverstärkungen (2 x 6 Inch), also 192 - (4 + 12) = 176. Abzüglich der sieben Verstärkungsteile (7 x 2 Inch) bleiben 162. Dividiert durch 8 ergibt das den Platz zwischen den Verstärkungsteilen: 20,25 Inch.

Arch panel tutorial 08.jpg

9. Eine vollständig festgelegte Skizze erreichen

Im rechten Bereich ("Aufgaben"-Reiter in der Combo-Ansicht, unter "Meldungen des Lösers") siehst Du die Meldung "Skizze mit 2 Freiheitsgraden". Das bedeutet, dass unsere Skizze nicht vollständig festgelegt ist (es gibt noch zwei "Wege", sie zu deformieren). Der Grund ist, dass, obwohl kein Teil mehr in Relation zu einem anderen bewegt werden kann, die Skizze noch vertikal oder horizontal verschoben werden kann. Um dies zu verhindern, können wir einfach einen der Eckpunkte nehmen, den Ursprung des Rasters (dort, wo sich die grüne und rote Achse schneiden) auswählen und den Button "Eine Koinzidenzbeschränkung ..." drücken. Dies lässt unsere Skizze grün werden, sie ist also vollständig festgelegt, weil kein Teil mehr bewegt werden kann.

Arch panel tutorial 09.jpg

Dies ist tatsächlich nicht absolut notwendig. Es ist aber immer besser, die exakte Position der Objekte im Auge zu behalten (wir sind nun sicher, dass unsere Ecke am Punkt (0,0) ist). Falls später etwas schiefgeht oder wir die Position eines Objekts herausfinden müssen, das auf dieser Skizze basiert, ist das nützlich.

Wir können jetzt Schließen drücken und unsere Basisskizze ist fertig:

Arch panel tutorial 10.jpg

10. Wechsel' zum Arbeitsbereich und drücke den "Fenster"-Button, während die Skizze ausgewählt ist

Unsere Skizze ist nun verschwunden und eins der Rechtecke wurde nun in einen Volumenkörper extrudiert:

Arch panel tutorial 11.jpg

Obwohl das falsch aussieht, liegt das einfach daran, dass das Arch-Fenster-Werkzeug ein Standardteil aus dem größten Viereck gemacht hat, das es in der Basisskizze finden konnte. Wir werden das bald korrigieren. Beachte, dass die Skizze nicht verschwunden ist, sondern einfach ausgeschaltet und vom neuen Elternobjekt "geschluckt" wurde. Du kannst es weiterhin in der Baumansicht finden, indem Du das Fenster-Objekt expandierst und die Sichtbarkeit durch Drücken der Leertaste ein-/ausschaltest.

11. Die Fensterkomponenten durch Doppelklicken in der Baumansicht ändern

Arch panel tutorial 12.jpg

Durch Doppelklicken des Fensters wird die Skizze wieder sichtbar und wir können ihr Aussehen ändern: Auf der linken Seite eine Liste der Vierecke in der Basisskizze, auf der rechten die darauf erzeugten Volumenkörper.

Beginne mit dem Entfernen des "Default"-Teils.

Dann wähle das erste Viereck (Wire0). Es wird in der 3D-Ansicht hervorgehoben. Drücke den "Hinzufüge"-Button, um ein neues Teil daraus zu erzeugen. Gib ihm einen Namen, stell' sicher, dass der richtige Draht gesetzt ist und setze die Dicke auf 6 Inch. Der Z-Abstand sollte bei 0 bleiben, weil wir es "auf dem Boden" platzieren wollen.

Der "Typ"-Wert wird verwendet, um Material für das Fenster festzulegen (noch nicht implementiert ?), so dass Du es im Moment auf "Frame" lassen kannst.

Arch panel tutorial 13.jpg

Dann drücke "Erstelle/aktualisiere Komponente". Manchmal errät FreeCAD die Richtung der Extrusion nicht richtig, so dass Du Deine Komponente ändern und den 6 Inch-Wert auf -6 setzen musst.

Wiederhole das für alle benötigen Teile:

Arch panel tutorial 14.jpg

Beim Schließen des Edit-Panels erhalten wir das obige Objekt. Beachte, dass standardmäßig Fenster-Objekte semitransparent dargestellt werden. Da dies tatsächlich kein Fenster wird, können wir das durch Ändern des Transparency-Wertes auf 0 in den Ansicht-Eigenschaften abstellen.

12. Die Verkleidung hinzufügen

Jetzt haben wir unseren Rahmen, aber nicht das Basis-Panel selbst. Um das zu erledigen, ist der beste Weg, unsere Basisskizze zu öffnen und ein neues Rechteck hinzuzufügen. Denke allerdings daran, keine Ecke dieses Rechtecks mit einer Ecke anderer Rechtecke übereinstimmen zu lassen, um unser Fenster-Objekt nicht durcheinander zu bringen, was es erfordern könnte, die ganze Reihe von Komponenten erneut zu erstellen, wenn sich die Reihenfolge der Vierecke ändern würde.

Wir können daher dieses neue Rechteck 0,05 Inch innerhalb des Umkreises festlegen. Das erfordert, dass wir vier neue Festlegungen erstellen.

Wir können dann unser Fenster erneut ändern und neue Komponenten hinzufügen. Wir sehen, dass ein neuer Draht gefunden wurde. Dieses Mal werden wir ihn nutzen, um ein 8mm Polycarbonat-Panel (beachte, dass Du ohne Probleme verschiedene Einheiten in FreeCAD mischen kannst und "8mm" als Dicke angeben kannst, selbst wenn Du in Inch arbeitest). Wir werden ihm außerdem einen Z-Abstand von 0,05 Inch geben, so dass er einen geringen Abstand vom Rahmen hat, nur damit alle Teile unseres Objekts den gleichen Abstand haben.

Arch panel tutorial 15.jpg

Wir können nun eine weitere Komponente erstellen, die ebenfalls auf dem gleichen Draht basiert, um ein weiteres Panel auf unserem Rahmen zu erzeugen. Dieses Mal geben wir ihm einen Z-Abstand von 6,05 Inch. Unser Panel ist endlich fertig:

Arch panel tutorial 16.jpg

13. Das Fenster in einen anderen Typ von Arch-Komponente ändern

Das ist zu diesem Zeitpunkt nicht wirklich nötig, aber es könnte später wichtig werden, wenn wir exportieren oder mit anderen konstruktions-orientierten Anwendungen arbeiten, z.B. via IFC, denn dann wollen wir nicht, dass unser Panel als ein Fenster erkannt wird.

Der Arch-Arbeitsbereich von FreeCAD bietet einen einfachen Weg, damit umzugehen, dadurch dass jeder Objekttyp immer zu einem anderen werden kann, indem er die Basis eines anderen Typ ist. In diesem Fall wird unser Fenster zu einem Panel-Objekt, einfach durch auswählen des Fensters und drücken des Panel-Werkzeugs.

Arch panel tutorial 17.jpg

Beachte, dass sich die Farbe des entstehenden Panels geändert hat, weil die Materialunterstützung in FreeCAD und im Arch-Modul noch unvollständig sind. Wenn sie fertig ist, wird so etwas richtig behandelt.

14. Duplizieren des Panels

Unser Panel kann auf verschiedene Weisen dupliziert und kopiert werden, z.B. durch Kopieren/Einfügen. Aber ein interessanterer Weg ist die Nutzung des Draft-Clone-Werkzeugs (auch im Arch-Arbeitsbereich verfügbar, genau wie alle anderen Draft-Werkzeuge). Das Clone-Werkzeug behält die Beziehung zwischen dem Basisobjekt und dem Klon, so dass sich Änderungen am Basisobjekt auch auf die Klone auswirken.

Arch panel tutorial 18.jpg

In der aktuellen Entwicklerversion von FreeCAD sind Klone von Arch-Objekten nun auch selbst Arch-Objekte.

15. Drehen und Positionieren des Panels

Solange der Assembly-Arbeitsbereich von FreeCAD noch nicht fertig ist, müssen wir unsere Teile manuell positionieren, entweder durch manipulieren der Placement-Eigenschaft oder durch Nutzen des Draft-Move-and-Rotate-Werkzeugs, was im Moment nur visuelle Wege der Änderung des Placements von Objekten erlaubt.

Beide Draft-Move-and-Rotate-Werkzeuge nutzen das Draft-Einrast-System. Verschiedene Einrastpositionen (Endpunkte, Mittelpunkte, etc.) sind verfügbar, können ein-/ausgeschaltet werden, und erlauben sehr genaue Positionierungen und Rotationen.

Arch panel tutorial 19.jpg

Arch panel tutorial 20.jpg