View Issue Details

IDProjectCategoryView StatusLast Update
0000906PartDesignBugpublic2012-12-07 12:05
ReporterdanielpoplawskiAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000906: Segmentation Fault when try to use linear pattern on Part
DescriptionFreeCAD crash with Segmentation Fail when try to create linear pattern on Part. Part created on different version FreeCAD (0.12 from Ubuntu repo).
Additional InformationFreeCAD:
Version: 0.13
Revision number: 1737 (Git)
Operating system: Ubuntu 12.04.1 LTS (it's Kubuntu)
Platform: 32-bit
Branch: master
Own compilation with dependencies from ubuntu repos.
=======================================================
uname -r
3.2.0-34-generic-pae

=======================================================
I have core dump but it's 177 MB.
Backtrace form gdb:
Reading symbols from /usr/bin/FreeCAD...(no debugging symbols found)...done.
[New LWP 31524]
[New LWP 31527]
[New LWP 31528]
[New LWP 31531]
[New LWP 31534]
[New LWP 31533]
[New LWP 31530]
[New LWP 31532]
[New LWP 31529]

warning: Can't read pathname for load map: B??d wej?cia/wyj?cia.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
Core was generated by `FreeCAD'.
Program terminated with signal 11, Segmentation fault.
#0 0xaa04ea38 in TopoDS_ListIteratorOfListOfShape::Initialize(TopoDS_ListOfShape const&) () from /usr/lib/libTKBRep-6.5.0.so
(gdb) bt
#0 0xaa04ea38 in TopoDS_ListIteratorOfListOfShape::Initialize(TopoDS_ListOfShape const&) () from /usr/lib/libTKBRep-6.5.0.so
#1 0xaa096fee in TopoDS_Iterator::Initialize(TopoDS_Shape const&, unsigned int, unsigned int) () from /usr/lib/libTKBRep-6.5.0.so
0000002 0xaa070628 in BRepTools_Modifier::Put(TopoDS_Shape const&) () from /usr/lib/libTKBRep-6.5.0.so
0000003 0xaa0707c6 in BRepTools_Modifier::Init(TopoDS_Shape const&) () from /usr/lib/libTKBRep-6.5.0.so
0000004 0xa9eeabfb in BRepBuilderAPI_ModifyShape::DoModif(TopoDS_Shape const&) () from /usr/lib/libTKTopAlgo-6.5.0.so
0000005 0xa9edb3ab in BRepBuilderAPI_Copy::BRepBuilderAPI_Copy(TopoDS_Shape const&, unsigned int) () from /usr/lib/libTKTopAlgo-6.5.0.so
0000006 0xa1f1a8bd in PartDesign::Transformed::execute() () from /opt/freecad/Mod/PartDesign/PartDesign.so
0000007 0xb6c628dd in App::DocumentObject::recompute() () from /opt/freecad/lib/libFreeCADApp.so
0000008 0xab5ea59f in Part::Feature::recompute() () from /opt/freecad/Mod/Part/Part.so
0000009 0xb6c251bf in App::Document::_recomputeFeature(App::DocumentObject*) () from /opt/freecad/lib/libFreeCADApp.so
0000010 0xb6c24edf in App::Document::recompute() () from /opt/freecad/lib/libFreeCADApp.so
0000011 0xb6c7dc6e in App::DocumentPy::recompute(_object*) () from /opt/freecad/lib/libFreeCADApp.so
0000012 0xb6c79736 in App::DocumentPy::staticCallback_recompute(_object*, _object*) () from /opt/freecad/lib/libFreeCADApp.so
0000013 0xb66f78cf in PyCFunction_Call () from /usr/lib/libpython2.7.so.1.0
0000014 0xb66568bf in PyEval_EvalFrameEx () from /usr/lib/libpython2.7.so.1.0
0000015 0xb660c4d2 in PyEval_EvalCodeEx () from /usr/lib/libpython2.7.so.1.0
0000016 0xb660c813 in PyEval_EvalCode () from /usr/lib/libpython2.7.so.1.0
0000017 0xb660c8b3 in PyRun_StringFlags () from /usr/lib/libpython2.7.so.1.0
0000018 0xb699f4a1 in Base::InterpreterSingleton::runString(char const*) () from /opt/freecad/lib/libFreeCADBase.so
0000019 0xb7118c77 in Gui::Command::doCommand(Gui::Command::DoCmd_Type, char const*, ...) () from /opt/freecad/lib/libFreeCADGui.so
0000020 0xb7119022 in Gui::Command::updateActive() () from /opt/freecad/lib/libFreeCADGui.so
0000021 0xa1d1b818 in CmdPartDesignLinearPattern::activated(int) () from /opt/freecad/Mod/PartDesign/PartDesignGui.so
0000022 0xb7118560 in Gui::Command::invoke(int) () from /opt/freecad/lib/libFreeCADGui.so
0000023 0xb710fc80 in Gui::Action::onActivated() () from /opt/freecad/lib/libFreeCADGui.so
0000024 0xb71148f7 in Gui::Action::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /opt/freecad/lib/libFreeCADGui.so
0000025 0xb59836b1 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
0000026 0xb5c409bd in QAction::triggered(bool) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000027 0xb5c40c5b in QAction::activate(QAction::ActionEvent) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000028 0xb614d410 in QToolButton::nextCheckState() () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000029 0xb6074c57 in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000030 0xb6074f56 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000031 0xb614d4ad in QToolButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000032 0xb5ca21ac in QWidget::event(QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000033 0xb60741f9 in QAbstractButton::event(QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000034 0xb614ebdc in QToolButton::event(QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000035 0xb5c47ed4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000036 0xb5c4e024 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000037 0xb70b5604 in Gui::GUIApplication::notify(QObject*, QEvent*) () from /opt/freecad/lib/libFreeCADGui.so
0000038 0xb596c97e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#39 0xb5c48e95 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#40 0xb5cd5074 in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000041 0xb5cd3c0d in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000042 0xb5d00eac in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000043 0xb404bd86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
0000044 0xb404c125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
0000045 0xb404c201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
0000046 0xb599f887 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
0000047 0xb5d00aaa in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000048 0xb596b50d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
0000049 0xb596b7a9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
0000050 0xb5970eba in QCoreApplication::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
0000051 0xb5c45a74 in QApplication::exec() () from /usr/lib/i386-linux-gnu/libQtGui.so.4
0000052 0xb70b1bd8 in Gui::Application::runApplication() () from /opt/freecad/lib/libFreeCADGui.so
0000053 0x0804f1b9 in main ()

===================================================

Attached file is my simple project that crash. I tried Linear pattern on "Revlotion" Part.
TagsNo tags attached.

Activities

2012-12-07 09:00

 

prototype-test.FCStd (13,409 bytes)

wmayer

2012-12-07 11:48

administrator   ~0002623

Your Revolution object is broken because it hasn't defined an axis. But there are also some checks required when doing the pattern feature to avoid the crash.

wmayer

2012-12-07 12:04

administrator   ~0002624

git show 3c3abd4

Issue History

Date Modified Username Field Change
2012-12-07 09:00 danielpoplawski New Issue
2012-12-07 09:00 danielpoplawski File Added: prototype-test.FCStd
2012-12-07 11:48 wmayer Note Added: 0002623
2012-12-07 12:04 wmayer Note Added: 0002624
2012-12-07 12:04 wmayer Status new => closed
2012-12-07 12:05 wmayer Resolution open => fixed
2012-12-07 12:05 wmayer Fixed in Version => 0.13