View Issue Details

IDProjectCategoryView StatusLast Update
0000903FreeCADBugpublic2012-12-07 10:15
ReporterscopaevAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version0.14Fixed in Version0.13 
Summary0000903: V0.13 - Change Individual face color on solid is missing
DescriptionI am probably doing something wrong, but for the life of me I can't figure it out. Maybe FC thinks I am selecting a whole object but, I can't seem to get an option to select a face color.

When I select a face and right click on it, I am presented with the following 2 options to modify coloring:
Appearance
Random Color

When I select Appearance, I can choose:
Material, Shape Color, Line Color, Color Plot? But no face color.

I could have swore I used to be able to change individual face colors (but Maybe I am just confused).

I looked through the forum and found a topic where a "Set Colors" item might have existed 6 weeks ago?
https://sourceforge.net/apps/phpbb/free-cad/viewtopic.php?f=8&t=3138&p=24319&hilit=different+face+color#p24319

Thanks.
Additional InformationOS: Ubuntu 12.04.1 LTS
Platform: 64-bit
Version: 0.13.1733 (Git)
Branch: master
Hash: 6455c4edadcae79cb58be76eb0f91359160b93d3
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0
TagsNo tags attached.

Activities

2012-12-06 15:18

 

ApearanceMenu.png (Attachment missing)

sliptonic

2012-12-06 17:29

developer   ~0002617

Right click on the object in the tree and use the "set colors" dialog.

scopaev

2012-12-06 17:47

reporter   ~0002618

Darn it! Red Faced! Sorry guys.
SlipTonic, you are 100% correct. Thank you so much
This can be closed out.

I kept staying on the main screen left clicking the face (to select it), then right clicking over the face to change it's properties. I think in my mind selecting the entire solid from the tree was not right because I wanted to only change a portion of the model, not the whole thing. Either way, its user misuse (which apparently happens more often as more gray hairs appear ;-) ).

Does anyone feel it would be beneficial to add the "Set colors" and maybe the "Transform" to the menu that pops up when you right click over the actual part on the main screen?

wmayer

2012-12-07 08:37

administrator   ~0002619

> Does anyone feel it would be beneficial to add the "Set colors" and maybe the "Transform" to the menu that pops up when you right click over the actual part on the main screen?
Yes, that should be available also in the normal menu because now it's a bit hard to find.

wmayer

2012-12-07 10:15

administrator   ~0002620

The code is prepared to add the two missing commands but we have to wait until 0000477 is properly implemented. Nevertheless, I'll close this ticket.

Issue History

Date Modified Username Field Change
2012-12-06 15:18 scopaev New Issue
2012-12-06 15:18 scopaev File Added: ApearanceMenu.png
2012-12-06 17:29 sliptonic Note Added: 0002617
2012-12-06 17:47 scopaev Note Added: 0002618
2012-12-07 08:37 wmayer Note Added: 0002619
2012-12-07 08:55 wmayer Target Version => 0.14
2012-12-07 10:15 wmayer Note Added: 0002620
2012-12-07 10:15 wmayer Status new => closed
2012-12-07 10:15 wmayer Resolution open => fixed
2012-12-07 10:15 wmayer Fixed in Version => 0.13