View Issue Details

IDProjectCategoryView StatusLast Update
0000009FreeCADBugpublic2009-12-21 09:53
ReporterJriegelAssigned Towmayer  
PrioritylowSeverityminorReproducibilityunable to reproduce
Status closedResolutionnot fixable 
PlatformLinuxOSFedora OS Version11
Product Version0.8 
Target VersionFixed in Version 
Summary0000009: configure fails at boost on Fedora 11
DescriptionFreeCAD-0.8.2237



checking for xercesc/framework/XMLBuffer.hpp... yes

checking whether xerces lib is available... yes

checking for boost... configure: error: failed



$ rpm -qa boost
boost-1.37.0-6.fc11.i586


$ cat /tmp/conftest.cpp

/* confdefs.h. */

#define PACKAGE_NAME "FreeCAD"

#define PACKAGE_TARNAME "FreeCAD"

#define PACKAGE_VERSION "0.8.2237"

#define PACKAGE_STRING "FreeCAD 0.8.2237"

#define PACKAGE_BUGREPORT "wmayer@users.sourceforge.net"

#define PACKAGE "FreeCAD"

#define VERSION "0.8.2237"

#define STDC_HEADERS 1

#define HAVE_SYS_TYPES_H 1

#define HAVE_SYS_STAT_H 1

#define HAVE_STDLIB_H 1

#define HAVE_STRING_H 1

#define HAVE_MEMORY_H 1
#define HAVE_STRINGS_H 1
#define HAVE_INTTYPES_H 1
#define HAVE_STDINT_H 1
#define HAVE_UNISTD_H 1
#define HAVE_ISTREAM 1
#define HAVE_OSTREAM 1
#define HAVE_ISTREAM 1
#define HAVE_FSTREAM 1
#define HAVE_IOS 1
#define HAVE_IOMANIP 1
#define HAVE_IOSTREAM 1
#define HAVE_IOMANIP_H 1
#define HAVE_LIMITS_H 1
#define HAVE_VALUES_H 1
#define HAVE_FLOAT_H 1
#define HAVE_BITS_SIGSET_H 1
#define HAVE_SYS_TYPES_H 1
#define HAVE_SYS_SELECT_H 1
#define HAVE_SYS_MMAN_H 1
#define HAVE_SSTREAM 1
#define HAVE_NAMESPACES
#define HAVE_STD_IOSTREAM
#define HAVE_DLFCN_H 1
#define LT_OBJDIR ".libs/"
#define HAVE_GETENVIRONMENTVARIABLE 1
#define HAVE_GL_GL_H 1
#define HAVE_QGLFORMAT_EQ_OP 1
#define HAVE_QGLFORMAT_SETOVERLAY 1
#define HAVE_QGLWIDGET_SETAUTOBUFFERSWAP 1
#define HAVE_QT_KEYPAD_DEFINE 1
#define HAVE_QWIDGET_SHOWFULLSCREEN 1
#define HAVE_SYS_TYPES_H 1
#define USE_STD_IOSTREAM 1
/* end confdefs.h. */
#include <boost/program_options.hpp>
int
main ()
{
namespace po = boost::program_options;
po::options_description generic("Generic options");
generic.add_options()
("version,v", "print version string")
("help", "produce help message");

;
return 0;
}


$ g++ -o conftest -g -O2 -I/usr/include -L/usr/lib conftest.cpp
-lboost_program_options-mt
/usr/lib/libboost_program_options-mt.so: undefined reference to
`std::basic_ostream<char, std::char_traits<char> >&
std::__ostream_insert<char, std::char_traits<char>
>(std::basic_ostream<char, std::char_traits<char> >&, char const*,
int)@GLIBCXX_3.4.9'
/usr/lib/libboost_program_options-mt.so: undefined reference to
`std::ctype<char>::_M_widen_init() const@GLIBCXX_3.4.11'
collect2: ld returned 1 exit status
TagsNo tags attached.
FreeCAD Information

Activities

wmayer

2009-09-28 10:40

administrator   ~0000001

Does this solve the problem?

g++ -o conftest -g -O2 -I/usr/include -L/usr/lib conftest.cpp
-lboost_program_options-mt -lstdc++

wmayer

2009-09-28 10:42

administrator   ~0000004

doesn't appear to change things:

FreeCAD-0.8.2237]$ g++ -o conftest -g -O2 -I/usr/include -L/usr/lib
conftest.cpp -lboost_program_options-mt -lstdc++
/usr/lib/libboost_program_options-mt.so: undefined reference to
`std::basic_ostream<char, std::char_traits<char> >&
std::__ostream_insert<char, std::char_traits<char>
>(std::basic_ostream<char, std::char_traits<char> >&, char const*,
int)@GLIBCXX_3.4.9'
/usr/lib/libboost_program_options-mt.so: undefined reference to
`std::ctype<char>::_M_widen_init() const@GLIBCXX_3.4.11'
collect2: ld returned 1 exit status

wmayer

2009-09-28 10:42

administrator   ~0000006

Hmm, I'm not quite sure but for me it sounds like a problem with boost or
gcc. Did you install the boost stuff from the Fedora package repositories
or did you build them on your own?

Which version of gcc was used to build the boost libs and which version of
gcc do you use to try to build FreeCAD?

wmayer

2009-09-28 10:42

administrator   ~0000008

boost is from the fedora, and I don't know what version of gcc they used in
the build for boos

$ rpm -qa gcc
gcc-4.4.1-2.fc11.i586

wmayer

2009-09-28 10:43

administrator   ~0000010

Searching in the web for "__ostream_insert" I've found some advices you may
check on your system:
* is libstdc++ installed, normally this should be version 6.x but you can
check libboost_program_options-mt.so with the tool ldd on which it depends
on, for furhter info see:
http://www.linuxquestions.org/questions/programming-9/compile-error-undefined-reference-to-stdbasicostream-669541/

* have a look to:
http://www.nabble.com/compilation-errors-on-rhel-5-td20695159.html

*
http://www.linuxquestions.org/questions/fedora-35/how-to-install-gcc-4.1-with-fedora-10-735162/

wmayer

2009-09-28 10:43

administrator   ~0000011

ok ... will do

I submitted this as a configure bug, because in theory, configure should
be able to safely navigate common platform configurations without these
kinds of failures.

wmayer

2009-12-21 09:53

administrator   ~0000076

I didn't get any further feedback for more than three months. So, there is nothing further I can do.

Issue History

Date Modified Username Field Change
2009-09-28 10:34 Jriegel New Issue
2009-09-28 10:34 Jriegel Status new => assigned
2009-09-28 10:34 Jriegel Assigned To => wmayer
2009-09-28 10:36 Jriegel Product Version => 0.8
2009-09-28 10:40 wmayer Note Added: 0000001
2009-09-28 10:42 wmayer Note Added: 0000004
2009-09-28 10:42 wmayer Note Added: 0000006
2009-09-28 10:42 wmayer Note Added: 0000008
2009-09-28 10:43 wmayer Note Added: 0000010
2009-09-28 10:43 wmayer Note Added: 0000011
2009-12-21 09:53 wmayer Note Added: 0000076
2009-12-21 09:53 wmayer Status assigned => closed
2009-12-21 09:53 wmayer Resolution open => not fixable