View Issue Details

IDProjectCategoryView StatusLast Update
0000892DraftBugpublic2012-12-20 22:25
Reportermore10Assigned Toyorik 
PrioritynormalSeveritymajorReproducibilityrandom
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000892: Snap to grid cannot be turned off
DescriptionIn draft module the working plane is set to a surface not aligned to any axis.

Always snap to objects is unticked.

When starting a line (or making a point) the location of the start is random around the mouse click location, but not exactly under the mouse.

Snap on/off makes no difference.

I will try reboot to see if that helps.
Additional Informationrevision 1694 on a 32 bit ubuntu 12.04 running in vmware workstation
TagsNo tags attached.

Relationships

duplicate of 0000891 closedyorik Snap to intersection doesn't work in draft module 

Activities

more10

2012-11-28 22:24

reporter   ~0002591

Problem is only when trying to place a new line on top of existing selectable lines. So there is no snap to grid in work here. When selectable is set to false for the existing lines, the new line is placed exactly under the cursor.

So this is a minor problem.

yorik

2012-11-28 23:49

administrator   ~0002593

I don't understand exactly what you mean... As far as I can see, the clicked point is always under the mouse cursor, unless it got snapped to the nearest object, which is the desired behaviour. Can you explain better?

Also the description of your problem is different from the title... Are you reporting 2 different problems?

more10

2012-11-29 00:31

reporter   ~0002597

Initially I thought that new lines where snapping to grid. I am trying to start a new line at the intersection between two other lines, because snap to intersection doesn´t work. If the two other lines are selectable, the new line will start from a place close, but not under the cursor.

Use the uploaded file for the other report I made if you want to reproduce.

yorik

2012-11-29 20:20

administrator   ~0002603

This is the same problem as 0000891 and 0000893, probably a precision problem. As for clicking on top of an object, for me all seems to work normally...

yorik

2012-12-20 22:25

administrator   ~0002733

This is fixed in 496a216

Issue History

Date Modified Username Field Change
2012-11-28 22:10 more10 New Issue
2012-11-28 22:24 more10 Note Added: 0002591
2012-11-28 23:49 yorik Note Added: 0002593
2012-11-28 23:50 yorik Assigned To => yorik
2012-11-28 23:50 yorik Status new => feedback
2012-11-29 00:31 more10 Note Added: 0002597
2012-11-29 20:18 yorik Relationship added duplicate of 0000891
2012-11-29 20:20 yorik Note Added: 0002603
2012-11-29 20:20 yorik Status feedback => assigned
2012-12-05 13:50 yorik Project FreeCAD => Draft
2012-12-20 22:25 yorik Note Added: 0002733
2012-12-20 22:25 yorik Status assigned => closed
2012-12-20 22:25 yorik Resolution open => fixed
2012-12-20 22:25 yorik Fixed in Version => 0.13