View Issue Details

IDProjectCategoryView StatusLast Update
0000873FreeCADBugpublic2013-12-23 17:41
Reporterjrheinlaender Assigned Tojrheinlaender  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version0.14Fixed in Version0.14 
Summary0000873: RefineModel() does not mark edges/faces as modified
DescriptionSee the attached picture. I tried to label four entities (from left to right):
Face2
Edge7,8,9

After the ModelRefine() run, the three edges are joined into a single edge. But only Edge7 is marked as modified, Edge8 and 9 are marked neither as modified nor deleted (IMO they should be marked as modified so that later methods can deduce that these three edges were joined into one new edge).

Also, Face2 should also be marked as modified because its limiting wire has changed. For example, IsSame() will not recognize old and new Face2 as equal.
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0000860 closedjrheinlaender PartDesign/modelrefine.cpp in FaceUniter::process() : United faces should all be marked as modified 
child of 0000922 assignedjnxd Topological Naming 

Activities

2012-11-07 15:08

 

Unrefined.jpg (Attachment missing)

jrheinlaender

2013-11-04 18:37

developer   ~0003852

Implemented on

http://github.com/jrheinlaender/FreeCAD/tree/jrheinlaender/dev-assembly-partdesign-modelrefine [^]

wmayer

2013-12-23 17:41

administrator   ~0003976

git show b2a341540e0482e8aaf80545f39fc08cf71f8a4d

Issue History

Date Modified Username Field Change
2012-11-07 15:08 jrheinlaender New Issue
2012-11-07 15:08 jrheinlaender File Added: Unrefined.jpg
2012-11-08 08:24 wmayer Relationship added related to 0000860
2012-12-20 19:27 Jriegel Relationship added child of 0000922
2012-12-20 19:27 Jriegel Status new => assigned
2012-12-20 19:27 Jriegel Assigned To => Jriegel
2012-12-20 19:28 Jriegel Target Version => 0.14
2013-11-04 18:37 jrheinlaender Note Added: 0003852
2013-11-04 18:37 jrheinlaender Assigned To Jriegel => jrheinlaender
2013-12-23 17:41 wmayer Note Added: 0003976
2013-12-23 17:41 wmayer Status assigned => closed
2013-12-23 17:41 wmayer Resolution open => fixed
2013-12-23 17:41 wmayer Fixed in Version => 0.14