View Issue Details

IDProjectCategoryView StatusLast Update
0000870SketcherFeaturepublic2015-12-15 13:15
ReporterjonasthomasAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.16 
Summary0000870: Center sketch to a constraint that has been double clicked in the constraint list.
DescriptionCurrently when a constraint in the constraint list is single clicked it is highlighted green. Double clicking a length constraints a dialog box pops up.

Double clicking concentricity, horizontal, vertical constraints has no effect.

When resolving constraint conflicts it is difficult to find the constraint.
It would be nice to have the sketch centered to the constraint when it has been double clicked in the constraint list.
TagsNo tags attached.

Activities

wmayer

2013-06-29 13:13

administrator   ~0003291

IMO this is not a good idea because:
1. what if you have a length constraint that causes a conflict. With a double-click it won't be centered.

2. Centering could become very annoying if you do it by accident.

It might be better to have an extra button for that purpose, also because you don't know if we want to make editable the other constraint types, too.

Related Changesets

FreeCAD: master fa1d4334

2015-09-15 17:24:23

wmayer

Details Diff
+ fixes 0000870: Center sketch to a constraint that has been double clicked in the constraint list. Affected Issues
0000870
mod - src/Gui/Document.cpp Diff File
mod - src/Gui/Document.h Diff File
mod - src/Mod/Sketcher/Gui/TaskSketcherConstrains.cpp Diff File
mod - src/Mod/Sketcher/Gui/TaskSketcherConstrains.h Diff File
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.cpp Diff File
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.h Diff File

Issue History

Date Modified Username Field Change
2012-11-04 16:12 jonasthomas New Issue
2013-06-29 13:13 wmayer Note Added: 0003291
2015-09-15 15:24 wmayer Changeset attached => FreeCAD Master master fa1d4334
2015-09-15 15:24 wmayer Assigned To => wmayer
2015-09-15 15:24 wmayer Status new => closed
2015-09-15 15:24 wmayer Resolution open => fixed
2015-12-15 13:15 yorik Fixed in Version => 0.16