View Issue Details

IDProjectCategoryView StatusLast Update
0000865FreeCADBugpublic2012-11-02 10:48
Reporternormandc Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000865: Document.xml in project file contains invalid string
Descriptionhttp://sourceforge.net/apps/phpbb/free-cad/viewtopic.php?f=3&t=3160&sid=4d70ae4fa2fcb0caaf161b886dd616ac

Hello guys,

I think one of the latest commits may have broken something. I spent quite some time on this file, and upon opening again FreeCAD informs me of this error:
Fatal Error at file /home/normand/Bureau/NOCTAR-bracket_PartDesign_v2.FCStd, line 494, char 21
Invalid Document.xml: Expected whitespace

Then all PartDesign features seem dissociated from their sketches in the Project tree, and every sketch aprt from the first one is empty. They all had reference geometry.

I had created this file in FreeCAD 0.13-git201210312201~precise1, then updated to 0.13-git201211011953~precise1, closed FreeCAD and reopened it.

Actually, I did not create this file from scratch but edited the one in the bug report 0000864.

OS: Ubuntu 12.04.1 LTS
Platform: 64-bit
Version: 0.13.1559 (Git)
Branch: master
Hash: a47b5f9f1339b600ed4e3ecb479eb63177e2c4dd
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0
TagsNo tags attached.
FreeCAD Information

Activities

2012-11-02 08:49

 

NOCTAR-bracket_PartDesign_v2.fcstd (Attachment missing)

wmayer

2012-11-02 08:54

administrator   ~0002481

I can confirm the problem in Document.xml. There is a string property "FaceName" which contains the French translation of "No face selected" namely "Aucune face slectionn?e" but the string is broken because it probably wasn't converted into UTF-8.

This FaceName property should not be a translated string at all but something like Face23. If it doesn't point to a face of a part object it should be empty.

wmayer

2012-11-02 10:48

administrator   ~0002482

git show 03c46bc

Issue History

Date Modified Username Field Change
2012-11-02 08:44 wmayer New Issue
2012-11-02 08:45 wmayer Reporter wmayer => normandc
2012-11-02 08:49 wmayer File Added: NOCTAR-bracket_PartDesign_v2.fcstd
2012-11-02 08:54 wmayer Note Added: 0002481
2012-11-02 10:48 wmayer Note Added: 0002482
2012-11-02 10:48 wmayer Status new => closed
2012-11-02 10:48 wmayer Resolution open => fixed
2012-11-02 10:48 wmayer Fixed in Version => 0.13