View Issue Details

IDProjectCategoryView StatusLast Update
0000851SketcherFeaturepublic2015-09-07 12:33
ReporterpperisinAssigned Toabdullah 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.16 
Summary0000851: [Sketcher] Symmetry command
DescriptionHi,

With current box selection it would be nice to have symmetry command. It could work this way:

1 - select some primitives
2 - click on a toolbar command
3 - command prompts you to click on a mirror line (axis,construction line...)
4 - after clicking on a construction line, new set of primitives is created on another side of a line, and it has mirrored constraints on all of it's points.

this would be easier to use than mirror constraint, because it would automatically create copies of selected primitives.

Regards,
Petar
TagsNo tags attached.

Activities

abdullah

2015-09-07 12:32

manager   ~0006338

Sketcher:: Symmetry about a line or point in master starting at this commit:

https://github.com/FreeCAD/FreeCAD/commit/359e9a5d78f25e73fb4bdd7c2aa3080b26ca7aba

See:
http://forum.freecadweb.org/viewtopic.php?f=10&t=11840&start=80

abdullah

2015-09-07 12:33

manager   ~0006339

Symmetry tool (mirror) in Sketcher is implemented and merged in master.

Issue History

Date Modified Username Field Change
2012-09-28 11:46 pperisin New Issue
2014-02-04 15:39 yorik Project FreeCAD => Sketcher
2015-09-07 12:30 abdullah Assigned To => abdullah
2015-09-07 12:30 abdullah Status new => assigned
2015-09-07 12:32 abdullah Note Added: 0006338
2015-09-07 12:33 abdullah Note Added: 0006339
2015-09-07 12:33 abdullah Status assigned => closed
2015-09-07 12:33 abdullah Resolution open => fixed
2015-09-07 12:33 abdullah Fixed in Version => 0.16