View Issue Details

IDProjectCategoryView StatusLast Update
0000848PartDesignFeaturepublic2018-09-16 16:52
ReporterpperisinAssigned Toabdullah 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.17 
Summary0000848: [PartDesign] Keep Transparency and Colors when adding a feature
DescriptionHi,

It would be nice if transparency + colors (solid color and color-per-face) are not lost when adding a feature to a solid (such as Pad, Pocket, Groove, Revolution, and Patterns).

0.14 should get robust references (Or Names, I do not know how it will be called). Maybe this should wait until that is implemented.

Regards
Petar
Tagscolors, transparency

Relationships

related to 0002806 closedyorik FreeCAD Loading a boolean objects Transparency get lost 
related to 0001626 new FreeCAD Transparency not respected when highlighting 
related to 0001029 closedyorik FreeCAD Transparency lost in compound 
related to 0003028 assignedabdullah PartDesign [PartDesign] Per face colors and keeping colors when adding a feature 
related to 0003148 closedwmayer PartDesign PartDesign does not allow colouring of single faces for non-primitives 
related to 0002725 closedwmayer PartDesign Random color for features in PartDesignNext 

Activities

mrlukeparry

2014-02-08 00:37

developer   ~0004165

Wouldn't this be part of the new PartDesign? I haven't used it for a while. Shouldn't only the Body Feature be the only feature that can have the material properties set...

Kunda1

2017-04-28 11:34

administrator   ~0008794

Abdullah wrote:
I am not sure of the current applicability of this issue:
1. Keeping transparency, I just fixed this a couple of days ago.
2. Per face colors, I do not think it is currently possible with PD NEXT (I do not know how at least).

Maybe this feature request should be updated/rewritten in line with the current user requirements for v0.17 PD NEXT.


@Abdullah what commit did you add for number 1?
Since this ticket is old I'm not sure @pperisin will respond to point number 2. How to proceed if not?

abdullah

2017-04-29 16:51

manager   ~0008829

https://github.com/FreeCAD/FreeCAD/pull/685

Face per color is a feature PD should have. So I think that a feature request asking for this is appropriate.

We should have a procedure for those cases where part of a bug is fixed but not the whole and the same for feature request. Something like splitting a ticket into two, so that one can be marked as fixed while the other remains open. Or a new ticket deriving from an old one...

Kunda1

2017-05-13 12:35

administrator   ~0008984

@abdullah I'd be happy to clone this ticket and you can edit the clone so that it's rewritten correctly to PDN specs?

abdullah

2017-05-13 12:47

manager   ~0008985

@kunda1

Sure!! Give me the new ticket number and I will edit it.

Kunda1

2017-05-13 12:50

administrator   ~0008991

@abdullah awesome! 0003028

normandc

2018-09-16 16:52

manager   ~0011765

Fixed by commit b53c12d3 for the whole body transparency, separate issue 0003028 was created for face color and transparency.

Issue History

Date Modified Username Field Change
2012-09-27 06:18 pperisin New Issue
2014-02-04 15:39 yorik Project FreeCAD => PartDesign
2014-02-08 00:37 mrlukeparry Note Added: 0004165
2017-02-10 04:59 Kunda1 Tag Attached: transparency
2017-02-10 05:03 Kunda1 Relationship added related to 0001029
2017-02-10 05:06 Kunda1 Relationship added related to 0002806
2017-02-10 05:07 Kunda1 Relationship added related to 0001626
2017-04-28 11:34 Kunda1 Assigned To => abdullah
2017-04-28 11:34 Kunda1 Status new => feedback
2017-04-28 11:34 Kunda1 Note Added: 0008794
2017-04-29 16:51 abdullah Note Added: 0008829
2017-05-13 12:35 Kunda1 Note Added: 0008984
2017-05-13 12:47 abdullah Note Added: 0008985
2017-05-13 12:49 Kunda1 Issue cloned: 0003028
2017-05-13 12:49 Kunda1 Relationship added related to 0003028
2017-05-13 12:50 Kunda1 Note Added: 0008991
2017-06-07 21:16 Kunda1 Tag Attached: colors
2017-10-19 11:32 Kunda1 Relationship added related to 0003148
2017-10-19 11:33 Kunda1 Relationship added related to 0002725
2018-09-16 16:52 normandc Status feedback => closed
2018-09-16 16:52 normandc Resolution open => fixed
2018-09-16 16:52 normandc Fixed in Version => 0.17
2018-09-16 16:52 normandc Note Added: 0011765