View Issue Details

IDProjectCategoryView StatusLast Update
0000084FreeCADFeaturepublic2011-08-25 07:35
ReporterJriegelAssigned ToJriegel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.12Fixed in Version0.12 
Summary0000084: Start Workbench
DescriptionAt the moment the Complete workbench is the default start workbench.
while FreeCAD is growing its not feasibly to start with the complete
modules loaded.
There fore the Start workbench will allow to choose the needed group of
modules needed for certain task, like CAD-modeling, working with meshes or
CAM. It will then load the modules needed and switch to a certain start
workbench...
TagsNo tags attached.
FreeCAD Information

Relationships

child of 0000276 closedJriegel Stringent user interface behavior 

Activities

yorik

2010-04-07 12:48

administrator   ~0000193

I think at the end 99% of the users will fall into one of these 2 categories:
- the "pro" users who will want to make dedicated use of freecad, and use only some workbenches, switching to what they need
- the "newcomer" users who will want the complete workbench, even if it means more load time (if you come from any other professional CAD package, freecad loading time even with all modules is still fast)

So I think why not simply, instead of one more workbench, make a nice UI dialog (a "Welcome to FreeCAD" dialog, with a "don't show this message next time FC starts" checkbox) asking you which module to set as default? The dialog would simply set the start workbench preference setting... Maybe it can even be together with the splash screen? Look at blender's new splash screen:

http://deathblood.cn/blog/attachments/month_0911/32009112481141.jpg

If you want I can try to make a nice one with small portions of screenshots showing the different workbenches to choose from, for ex. complete, part, mesh and draft (the most usable ones)?

What do you think?

Jriegel

2010-04-07 15:04

administrator   ~0000195

Mhhh,
I think at the moment your are right. But complete only links some of the
modules. If FEM, CAM and other special modules come in play you will load
a lot crap you usually not need...
Especelly if you work with recent files or open a .fcstd file. Normally FreeCAD load only the modules needed to read the document (if no mesh is in there it
wont load the mesh module). But if Complete is the start, it will take forever to start the application and then he loads the file...

For the start I think more to a start screen like eclipse:
http://www.comp.mq.edu.au/units/comp229/images/Welcome-WinXP.png

which is basically a html page. Since Werner did this great fix for the start
page we can use the browser to make a really good looking start page!
This start page could also embed links to recent files (with pictures)
and e.g. tutorials or
even video tutorials (in not so distant future) ;)
Also we can embed sample files in the welcome/start page to allow people
to load fast some example files. A lot possibilities.

Would be great if you could do the design! Your artwork for FreeCAD was
allays fantastic!

Jriegel

2010-04-07 15:13

administrator   ~0000196

Also interesting:
http://www.developer.com/java/ent/article.php/3698021/Eclipse-Tip-Making-a-Good-First-Impression.htm

yorik

2010-04-07 17:57

administrator   ~0000197

Yes that makes sense.
And you're right, I hadn't thought about that, but the html startpage can become a very powerful thing, fully integrate with the online doc, etc... we should anyway give a good lifting to the wiki... I started playing with some stuff here:
http://sourceforge.net/userapps/mediawiki/yorikvanhavre/index.php?title=Alt_Main_Page
but it is still very basic. could go much further... (I'm trying to integrate rss feeds, stuff like that)
But I'll work on it!

Jriegel

2010-04-07 19:08

administrator   ~0000198

Ahh,
looks promising!

Jriegel

2011-08-25 07:35

administrator   ~0000999

implemented

Issue History

Date Modified Username Field Change
2010-04-07 11:03 Jriegel New Issue
2010-04-07 11:03 Jriegel Status new => assigned
2010-04-07 11:03 Jriegel Assigned To => Jriegel
2010-04-07 12:48 yorik Note Added: 0000193
2010-04-07 15:04 Jriegel Note Added: 0000195
2010-04-07 15:13 Jriegel Note Added: 0000196
2010-04-07 17:57 yorik Note Added: 0000197
2010-04-07 19:08 Jriegel Note Added: 0000198
2010-06-29 13:40 Jriegel Target Version => 0.11
2010-06-29 13:49 Jriegel Target Version 0.11 =>
2011-01-31 09:14 Jriegel Target Version => 0.12
2011-02-22 11:58 Jriegel Relationship added child of 0000276
2011-08-25 07:35 Jriegel Note Added: 0000999
2011-08-25 07:35 Jriegel Status assigned => closed
2011-08-25 07:35 Jriegel Resolution open => fixed
2011-08-25 07:35 Jriegel Fixed in Version => 0.12