View Issue Details

IDProjectCategoryView StatusLast Update
0000830FreeCADPatchpublic2013-07-06 13:56
Reporternormandc Assigned Towmayer  
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000830: Part Design Fillet and Chamfer icons should be different from the Part icons
DescriptionCurrently the same icons are used for the Fillet and chamfer tools from Part and Part Design workbenches.

Only, the tools work differently, which can lead to confusion.

Since Part Design is for solids only, I propose that the icon represents a cube instead of two surfaces. Attached is a first try for the fillet one, to be refined. Chamfer to follow later. Contributions are welcomed.
TagsNo tags attached.
FreeCAD Information

Activities

2012-09-10 01:34

 

PartDesign_Fillet.svg (Attachment missing)

wmayer

2012-09-10 10:45

administrator   ~0002366

git show 5196c92

pperisin

2012-09-10 12:41

reporter   ~0002367

...and a chamfer match to it

2012-09-10 12:41

 

PartDesign_Chamfer.svg (Attachment missing)

wmayer

2012-09-10 13:51

administrator   ~0002369

git show a6bc50d

The only thing that seems wrong is the shadow of the icons.

normandc

2012-09-10 14:49

manager   ~0002370

Yes, I mentioned it in the forum topic. It's because the cube is too big, the shadow extends outside the icon's borders and thus is cropped. Solution would be to reduce the cube's size to get the full shadow.

Which is why I wrote "to be refined". :-)

pperisin

2012-09-10 16:14

reporter   ~0002371

maybe this in a zip file

2012-09-10 16:15

 

Fillet-and-chamfer.zip (Attachment missing)

normandc

2012-09-11 00:46

manager   ~0002372

Yes, they look a lot better... but! Sorry I just thought about it. I think the colors need to be changed.

- the cube's faces need to be the same dark blue as the pocket and groove icons. Right now the blue is too light.
- the fillet and chamfer need to be red, since in a sense it removes material from the solid like for pocket and groove.

What do you think? In any case maybe we should discuss further before committing new versions.

normandc

2012-09-11 01:18

manager   ~0002373

Last edited: 2012-09-11 01:54

Added two new versions:

PartDesign_Chamfer_v3.svg
PartDesign_Fillet_v3.svg

Completely redone to match Pocket icon style:

- no shadow
- perspective cube
- dark blue gradient for main object
- dark red gradient for feature

Sorry for the deleted/re-attached files. Previous ones had bad gradients.

Added PartDesign_Fillet_v4.svg with all the edges dark blue. Not sure which one is best: edges around feature red, or blue...

2012-09-11 01:51

 

PartDesign_Chamfer_v3.svg (Attachment missing)

2012-09-11 01:52

 

PartDesign_Fillet_v3.svg (Attachment missing)

2012-09-11 01:52

 

PartDesign_Fillet_v4.svg (Attachment missing)

2012-09-11 06:01

 

PartDesign_Fillet_v5.svg (Attachment missing)

pperisin

2012-09-11 06:05

reporter   ~0002376

minor suggestion to filet v3 (now v5) - reflected transient color on red fill, to look,

also, rotated linear color on chamfer.

2012-09-11 06:05

 

PartDesign_Chamfer_v5.svg (Attachment missing)

wmayer

2012-09-11 07:20

administrator   ~0002378

git show f62c36a

pperisin

2012-09-11 07:52

reporter   ~0002380

Hi,

maybe this should be assigned to Yorik, for master's review. Also, werner, I saw that you have added this icons, but it looks like part design chamfer command is still using part_chamfer icon.

Regards,
Petar

2012-09-11 09:28

 

icons.zip (Attachment missing)

pperisin

2012-09-11 09:29

reporter   ~0002381

ok, I have just compiled, and it seemed to me red border looked ugly when comiled - so I re-added blue outline, and expanded size of chamfer/fillet.

normandc

2012-09-15 04:18

manager   ~0002397

I just got your changes in the PPA. They look much better with the enlarged fillet/chamfer and the blue outline. Thanks!

I think this "bug" may be closed. Or maybe we wait for our icon guru's (Yorik) seal of approval? :-P

pperisin

2012-09-15 18:35

reporter   ~0002398

Yes, I think Yorik should approve them. He will probably have few tips to make them better. :-)

wmayer

2013-07-06 13:56

administrator   ~0003340

Has been fixed for a while now.

Issue History

Date Modified Username Field Change
2012-09-10 01:34 normandc New Issue
2012-09-10 01:34 normandc File Added: PartDesign_Fillet.svg
2012-09-10 10:45 wmayer Note Added: 0002366
2012-09-10 12:41 pperisin Note Added: 0002367
2012-09-10 12:41 pperisin File Added: PartDesign_Chamfer.svg
2012-09-10 13:51 wmayer Note Added: 0002369
2012-09-10 14:49 normandc Note Added: 0002370
2012-09-10 16:14 pperisin Note Added: 0002371
2012-09-10 16:15 pperisin File Added: Fillet-and-chamfer.zip
2012-09-11 00:46 normandc Note Added: 0002372
2012-09-11 01:16 normandc File Added: PartDesign_Chamfer_v3.svg
2012-09-11 01:17 normandc File Added: PartDesign_Fillet_v3.svg
2012-09-11 01:18 normandc Note Added: 0002373
2012-09-11 01:45 normandc File Deleted: PartDesign_Chamfer_v3.svg
2012-09-11 01:45 normandc File Deleted: PartDesign_Fillet_v3.svg
2012-09-11 01:51 normandc File Added: PartDesign_Chamfer_v3.svg
2012-09-11 01:51 normandc File Added: PartDesign_Fillet_v4.svg
2012-09-11 01:52 normandc File Deleted: PartDesign_Fillet_v4.svg
2012-09-11 01:52 normandc File Added: PartDesign_Fillet_v3.svg
2012-09-11 01:52 normandc File Added: PartDesign_Fillet_v4.svg
2012-09-11 01:54 normandc Note Edited: 0002373
2012-09-11 06:01 pperisin File Added: PartDesign_Fillet_v5.svg
2012-09-11 06:05 pperisin Note Added: 0002376
2012-09-11 06:05 pperisin File Added: PartDesign_Chamfer_v5.svg
2012-09-11 07:20 wmayer Note Added: 0002378
2012-09-11 07:52 pperisin Note Added: 0002380
2012-09-11 09:28 pperisin File Added: icons.zip
2012-09-11 09:29 pperisin Note Added: 0002381
2012-09-15 04:18 normandc Note Added: 0002397
2012-09-15 18:35 pperisin Note Added: 0002398
2013-06-29 15:40 wmayer Status new => assigned
2013-06-29 15:40 wmayer Assigned To => wmayer
2013-07-06 13:56 wmayer Note Added: 0003340
2013-07-06 13:56 wmayer Status assigned => closed
2013-07-06 13:56 wmayer Resolution open => fixed
2013-07-06 13:56 wmayer Fixed in Version => 0.13