View Issue Details

IDProjectCategoryView StatusLast Update
0000825FreeCADBugpublic2012-09-16 16:00
Reportersliptonic Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000825: dxf import failing: invalid literal
DescriptionWhen trying to import a simple dxf file created with librecad, FreeCAD fails and the following error is in the console:

Exception (Thu Sep 6 08:27:00 2012): invalid literal for int() with base 16: 'Standard'
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2012-09-06 17:07

administrator   ~0002353

Can't reproduce this... Could you attach the problematic file?

2012-09-06 17:08

 

dxfimport-nospline.dxf (Attachment missing)

sliptonic

2012-09-06 17:09

developer   ~0002354

File attached. Sorry. Thought I attached it the first time around.

yorik

2012-09-06 17:58

administrator   ~0002355

okay there is indeed some error happening in the parser. I'll try to fix that...

yorik

2012-09-16 16:00

administrator   ~0002401

Fixed in 63ff342. Appearently some dxf code not supported by our parser...

Issue History

Date Modified Username Field Change
2012-09-06 11:30 sliptonic New Issue
2012-09-06 17:07 yorik Note Added: 0002353
2012-09-06 17:08 sliptonic File Added: dxfimport-nospline.dxf
2012-09-06 17:09 sliptonic Note Added: 0002354
2012-09-06 17:58 yorik Note Added: 0002355
2012-09-06 17:58 yorik Status new => assigned
2012-09-06 17:58 yorik Assigned To => yorik
2012-09-16 16:00 yorik Note Added: 0002401
2012-09-16 16:00 yorik Status assigned => closed
2012-09-16 16:00 yorik Resolution open => fixed
2012-09-16 16:00 yorik Fixed in Version => 0.13