View Issue Details

IDProjectCategoryView StatusLast Update
0000823FreeCADPatchpublic2012-09-06 08:38
Reporterzappl Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000823: Extension of Facet class for getting vertex indices natively
DescriptionFor exporting a mesh it's important to know the indices of the mesh vertices a facet consists of.
This data exists in a Facet and is even "given" by it's string representation, but is not accessable directly.
This really limits the ability of mesh exporters coded in python.
Additional InformationThe attached patch adds an attribute "MeshIndices" and a native method "FacetPy::getMeshIndices()" to get the vertex indices as a three-int-tuple.
TagsNo tags attached.
FreeCAD Information

Activities

2012-09-03 14:28

 

0001-FacetPy-added-Attribute-MeshIndices-for-getting-the-.patch (Attachment missing)

wmayer

2012-09-05 10:35

administrator   ~0002344

Would you mind if I rename the attribute to "PointIndices" because this is what it actually means? Additionally we can have another attribute "NeighbourIndices" which gives the indices of the neighbour facets.

zappl

2012-09-05 13:44

reporter   ~0002347

I don't mind of course, PointIndices is probably the better name.
Good idea to provide NeighbourIndices as well.
Thanks.

wmayer

2012-09-06 08:38

administrator   ~0002351

git show 629cf65

Issue History

Date Modified Username Field Change
2012-09-03 14:28 zappl New Issue
2012-09-03 14:28 zappl File Added: 0001-FacetPy-added-Attribute-MeshIndices-for-getting-the-.patch
2012-09-05 10:35 wmayer Note Added: 0002344
2012-09-05 13:44 zappl Note Added: 0002347
2012-09-06 08:38 wmayer Note Added: 0002351
2012-09-06 08:38 wmayer Status new => closed
2012-09-06 08:38 wmayer Resolution open => fixed
2012-09-06 08:38 wmayer Fixed in Version => 0.13