View Issue Details

IDProjectCategoryView StatusLast Update
0000008FreeCADBugpublic2009-12-21 09:47
ReporterJriegelAssigned Towmayer 
PrioritylowSeverityminorReproducibilityunable to reproduce
Status closedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000008: segfault on repairing mesh
DescriptionSegfault in r2237 on Ubuntu 64bit.

(gdb) backtrace
#0 0x00007fbdee2beb1e in
MeshCore::MeshTopoAlgorithm::RemoveDegeneratedFacet
() from /usr/lib/freecad/Mod/Mesh/libMesh.so.2
#1 0x00007fbdee268ee3 in MeshCore::MeshFixDegeneratedFacets::Fixup ()
from /usr/lib/freecad/Mod/Mesh/libMesh.so.2
0000002 0x00007fbdee3656a0 in Mesh::MeshObject::validateDegenerations ()
from /usr/lib/freecad/Mod/Mesh/libMesh.so.2
0000003 0x00007fbdee376312 in Mesh::PropertyMeshKernel::validateDegenerations
()
from /usr/lib/freecad/Mod/Mesh/libMesh.so.2
0000004 0x00007fbdee370c44 in Mesh::MeshFeaturePy::fixDegenerations ()
from /usr/lib/freecad/Mod/Mesh/libMesh.so.2
0000005 0x00007fbdee370e5e in
Mesh::MeshFeaturePy::staticCallback_fixDegenerations
() from /usr/lib/freecad/Mod/Mesh/libMesh.so.2
0000006 0x00007fbe02afedbe in PyEval_EvalFrameEx ()
from /usr/lib/libpython2.6.so.1.0
0000007 0x00007fbe02b009a9 in PyEval_EvalCodeEx ()
from /usr/lib/libpython2.6.so.1.0
0000008 0x00007fbe02b00ac2 in PyEval_EvalCode () from
/usr/lib/libpython2.6.so.1.0
0000009 0x00007fbe02b1f3cc in PyRun_StringFlags ()
from /usr/lib/libpython2.6.so.1.0
0000010 0x00007fbe03793d44 in Base::InterpreterSingleton::runString ()
from /usr/lib/freecad/lib/libFreeCADBase.so.2
0000011 0x00007fbe082e7273 in Gui::Application::runCommand ()
from /usr/lib/freecad/lib/libFreeCADGui.so.2
---Type <return> to continue, or q <return> to quit---
0000012 0x00007fbdee642c65 in
MeshGui::DlgEvaluateMeshImp::on_repairAllTogether_clicked () from
/usr/lib/freecad/Mod/Mesh/libMeshGui.so.2
0000013 0x00007fbdee646eca in MeshGui::DlgEvaluateMeshImp::qt_metacall ()
from /usr/lib/freecad/Mod/Mesh/libMeshGui.so.2
0000014 0x00007fbe07e6a1f2 in QMetaObject::activate () from
/usr/lib/libQtCore.so.4
0000015 0x00007fbe06958267 in QAbstractButton::clicked ()
from /usr/lib/libQtGui.so.4
0000016 0x00007fbe066b5deb in ?? () from /usr/lib/libQtGui.so.4
0000017 0x00007fbe066b7a52 in ?? () from /usr/lib/libQtGui.so.4
0000018 0x00007fbe066b7ca5 in QAbstractButton::mouseReleaseEvent ()
from /usr/lib/libQtGui.so.4
0000019 0x00007fbe063648cf in QWidget::event () from /usr/lib/libQtGui.so.4
0000020 0x00007fbe0631378d in QApplicationPrivate::notify_helper ()
from /usr/lib/libQtGui.so.4
0000021 0x00007fbe0631c0da in QApplication::notify () from
/usr/lib/libQtGui.so.4
0000022 0x00007fbe082ebda8 in Gui::GUIApplication::notify ()
from /usr/lib/freecad/lib/libFreeCADGui.so.2
0000023 0x00007fbe07e5475c in QCoreApplication::notifyInternal ()
from /usr/lib/libQtCore.so.4
0000024 0x00007fbe0631b328 in QApplicationPrivate::sendMouseEvent ()
from /usr/lib/libQtGui.so.4
0000025 0x00007fbe06384e19 in ?? () from /usr/lib/libQtGui.so.4
0000026 0x00007fbe06383a88 in QApplication::x11ProcessEvent ()
---Type <return> to continue, or q <return> to quit---
from /usr/lib/libQtGui.so.4
0000027 0x00007fbe063ac464 in ?? () from /usr/lib/libQtGui.so.4
0000028 0x00007fbe0127e20a in g_main_context_dispatch ()
from /usr/lib/libglib-2.0.so.0
0000029 0x00007fbe012818e0 in ?? () from /usr/lib/libglib-2.0.so.0
0000030 0x00007fbe01281a7c in g_main_context_iteration ()
from /usr/lib/libglib-2.0.so.0
0000031 0x00007fbe07e7de6f in QEventDispatcherGlib::processEvents ()
from /usr/lib/libQtCore.so.4
0000032 0x00007fbe063abbef in ?? () from /usr/lib/libQtGui.so.4
0000033 0x00007fbe07e53002 in QEventLoop::processEvents ()
from /usr/lib/libQtCore.so.4
0000034 0x00007fbe07e533cd in QEventLoop::exec () from /usr/lib/libQtCore.so.4
0000035 0x00007fbe07e55694 in QCoreApplication::exec ()
from /usr/lib/libQtCore.so.4
0000036 0x00007fbe082e9ae9 in Gui::Application::runApplication ()
from /usr/lib/freecad/lib/libFreeCADGui.so.2
0000037 0x0000000000402f22 in ?? ()
0000038 0x00007fbe019345a6 in __libc_start_main () from /lib/libc.so.6
#39 0x00000000004022d9 in ?? ()
#40 0x00007fff10aa7df8 in ?? ()
0000041 0x000000000000001c in ?? ()
0000042 0x0000000000000001 in ?? ()
---Type <return> to continue, or q <return> to quit---
0000043 0x00007fff10aa9628 in ?? ()
0000044 0x0000000000000000 in ?? ()
TagsNo tags attached.

Activities

wmayer

2009-12-21 09:47

administrator   ~0000075

This can't be fixed without some test data that forces the crash. I had a look on the source code but couldn't find any obvious errors. And if the mesh structure isn't invalid but contains degenerate edges everything works fine for me.

Issue History

Date Modified Username Field Change
2009-09-28 10:30 Jriegel New Issue
2009-09-28 10:30 Jriegel Status new => assigned
2009-09-28 10:30 Jriegel Assigned To => wmayer
2009-12-21 09:47 wmayer Note Added: 0000075
2009-12-21 09:47 wmayer Status assigned => closed
2009-12-21 09:47 wmayer Resolution open => unable to reproduce