View Issue Details

IDProjectCategoryView StatusLast Update
0000776FreeCADBugpublic2012-07-05 07:01
ReporterpperisinAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000776: Splashscreen shows errors
DescriptionWhenever I start FreeCAD, splashscreen is showing errors. this is not very user frendly IMO.
Additional Informationwin7
TagsNo tags attached.

Activities

2012-07-04 11:49

 

splashscreen.png (Attachment missing)

wmayer

2012-07-04 13:34

administrator   ~0002270

Last edited: 2012-07-04 13:44

The splash screen shows log messages as issued by the modules. It has no control over what it shows.

Originally, the intention of it is to show which modules are loaded at start up but if a module dumps any nonsense the splash screen shows it as is.

So, the actual issue is to solve the problem that the file cannot be loaded rather than changing the behaviour of the splash screen.

BTW, I don't have this message. Can you debug your version to see where the message comes from? Make a break point in Splashscreen.cpp in line 111.

shoogen

2012-07-04 17:05

developer   ~0002271

i have similar messages on debian squeeue 64bit complaining yout not finding icons of the draft module.
But those are not only shown on the splash screen but also shown on the Console. maybe you can check the log windows and stdout output before you need to employ breakpoints.

shoogen

2012-07-04 17:40

developer   ~0002272

i guess it is DraftGui.setupToolBar() (when loaded from outside the Draft module)
which does not properly loads the ressource file or sets the icons paths

yorik

2012-07-04 18:00

administrator   ~0002273

I just pushed a fix with commit b6b5757, that should fix the missing Draft icons message..
Since I don't get that message, I can't check it's all fixed, can you guys test if it solves the problem?

pperisin

2012-07-04 21:37

reporter   ~0002274

sure, I'll test tomorrow.

I just installed it on my frend's PC, and first thing he said was "There are some problems"

will test tomorrow and post how it went.

Regards,
Petar

pperisin

2012-07-05 04:40

reporter   ~0002278

it's fixed. close.

Issue History

Date Modified Username Field Change
2012-07-04 11:49 pperisin New Issue
2012-07-04 11:49 pperisin File Added: splashscreen.png
2012-07-04 13:34 wmayer Note Added: 0002270
2012-07-04 13:44 wmayer Note Edited: 0002270
2012-07-04 17:05 shoogen Note Added: 0002271
2012-07-04 17:40 shoogen Note Added: 0002272
2012-07-04 18:00 yorik Note Added: 0002273
2012-07-04 21:37 pperisin Note Added: 0002274
2012-07-05 04:40 pperisin Note Added: 0002278
2012-07-05 07:01 wmayer Status new => closed
2012-07-05 07:01 wmayer Resolution open => fixed
2012-07-05 07:01 wmayer Fixed in Version => 0.13