View Issue Details

IDProjectCategoryView StatusLast Update
0000076FreeCADBugpublic2010-04-11 09:40
Reporterunauthenticated Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.9 
Target VersionFixed in Version 
Summary0000076: Crash when trying to insert a new view of a part
DescriptionWhen a new Drawing is created with "Insert new A3 landscape drawing" the path of the page template is set wrong. In the python console view it shows:
App.activeDocument().Page.Template = App.getResourceDir()+'Mod/Drawing/Templates/A3_Landscape.svg'
This results in the following path:
/opt/FreeCAD/shareMod/Drawing/Templates/A3_Landscape.svg
There is a slash missing between "share" and "Mod".
This can be corrected with giving the command:
App.activeDocument().Page.Template = App.getResourceDir()+'/Mod/Drawing/Templates/A3_Landscape.svg'
Then the template is found.

After that when a part is selected and "insert a new view of a part ..." is clicked, then FreeCAD crashes with the following line on the cli:
FreeCAD: PropertyFile.cpp:115: void App::PropertyFileIncluded::setValue(const char*, const char*): Assertion `done' failed.
Abnormal program termination...

TagsNo tags attached.
FreeCAD Information

Activities

unauthenticated

2010-03-17 00:32

viewer   ~0000183

Last edited: 2010-03-17 00:33

Addition:

Both Templates in /opt/FreeCAD/shareMod/Drawing/Templates/ contains wrong lines.
In file A3_Landscape.svg line 1604 and in file A4_Simple.svg line 12 starts with "<!-", but a comment should start with "<!--"

The correction of these errors don't change anything in the crash behavior.

unauthenticated

2010-03-21 15:58

viewer   ~0000184

The bug with the missing slash and the crash are quited old and already fixed. The missing second hyphen for SVG block comments is fixed now.

unauthenticated

2010-03-21 20:56

viewer   ~0000185

May I ask in which version this was fixed?
I use the packman-rpm for opensuse and 'rpm -qi' shows version 0.9.2646 with build date of '17 Mär 2010'.
Is this an outdated version?

yorik

2010-03-27 02:00

administrator   ~0000186

The hyphen bug was fixed 5 days ago (rev 3051), the other one I can't find back but I think it was in the lot of fixes that happened after the 0.9 release (the one you have)... I know that the debian people made a new package after the fixes, but I can't say for packman packages...

wmayer

2010-04-11 09:22

administrator   ~0000205

The bug with the missing slash was already reported on the Debian mailing list in December 2009 for package 0.9.2646.3 and fixed in 0.9.2646.4 (also released in December). See also http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=559849

In our SVN sources you'll find the fix in rev. 2712 (for the 0.9 branch) and in rev. 2711 for trunk.

So, I think it's very likely that you have not the latest (released) version which is now 0.9.2646.5. Can you double-check this again, please?

wmayer

2010-04-11 09:40

administrator   ~0000206

I'm not familiar with the openSuse repos and its version numbering but according to this link it still seems to be the outdated 0.9.2646-1 package.

So, I'll close this item but you can reopen it if needed...

Issue History

Date Modified Username Field Change
2010-03-16 15:11 unauthenticated New Issue
2010-03-17 00:32 unauthenticated Note Added: 0000183
2010-03-17 00:33 unauthenticated Note Edited: 0000183
2010-03-21 15:58 unauthenticated Note Added: 0000184
2010-03-21 20:56 unauthenticated Note Added: 0000185
2010-03-27 02:00 yorik Note Added: 0000186
2010-04-11 09:22 wmayer Note Added: 0000205
2010-04-11 09:40 wmayer Note Added: 0000206
2010-04-11 09:40 wmayer Status new => closed
2010-04-11 09:40 wmayer Resolution open => fixed