View Issue Details

IDProjectCategoryView StatusLast Update
0000759FreeCADBugpublic2012-06-22 20:09
Reportershoogen Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000759: importSVG produces unorientable shapes by creating Faces from open Wires.
DescriptionThe SVG standard allows open paths to be filled. Which means the path will be closed but the contour is of the closing line is not drawn.
The previous behavior produces broken shpaes.
Additional InformationThe suggested behavior is to neglect the fill style in case of an open path.

The following changes since commit 2828a91b7bded9757a96a93905b815ccdc5a1a50:
  Fix a couple of dfsg issues, make git the default vcs (2012-06-21 12:25:53 +0200)

are available in the git repository at:

  git://github.com/5263/FreeCAD.git svgimport

for you to fetch changes up to 7147f3dd55ae1661d6fee431cafccd4e7e536f8a:

  importSVG: create Face only if path is closed (2012-06-21 15:11:16 +0200)

----------------------------------------------------------------
shoogen (2):
      importSVG: fixes in preserveAspectRatio and sweepflag handling
      importSVG: create Face only if path is closed

 src/Mod/Draft/importSVG.py | 22 ++++++++++++----------
 1 file changed, 12 insertions(+), 10 deletions(-)
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2012-06-22 00:56

administrator   ~0002232

Will check that ASAP. Thanks for the fix!

yorik

2012-06-22 20:09

administrator   ~0002233

Merged!

Issue History

Date Modified Username Field Change
2012-06-21 16:54 shoogen New Issue
2012-06-22 00:56 yorik Status new => assigned
2012-06-22 00:56 yorik Assigned To => yorik
2012-06-22 00:56 yorik Note Added: 0002232
2012-06-22 20:09 yorik Note Added: 0002233
2012-06-22 20:09 yorik Status assigned => closed
2012-06-22 20:09 yorik Resolution open => fixed
2012-06-22 20:09 yorik Fixed in Version => 0.13