View Issue Details

IDProjectCategoryView StatusLast Update
0000752SketcherBugpublic2017-12-15 19:13
ReporterjmaustpcAssigned Toian.rees 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platform32 bitOSKubuntuOS Version12.04
Product Version 
Target VersionFixed in Version0.17 
Summary0000752: sketcher constraint visuals default location and auto constraint visuals are often placed over the top of others
DescriptionBoth
1) sketcher manual constraint visuals default editable (i.e. partly moveable) location on a sketch, after creation
2)as well as auto constraint visuals default non-editable location on a sketch

are often placed over the top of others of their type and each other.

For example, length of line constraint and distance of point along line constraint, located somewhere along the same line will both print their value in the same spot on the screen and thus sit over the top of each other.

This bug is less important that it may have otherwise been due to the fact that manual constraint values can be dragged with the mouse in one direction, and thus pull one out from under the other.
Steps To Reproducesee file and screen shots attached.

Additional InformationFull version data

Platform: Ubuntu 12.04 LTS (32-bit)
Version: 0.13.1160 (Git)
Branch: master
Hash: 9ae96083d37d0952307fda2ad3cc3764d3ff793c
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.1
Tagsconstraints

Activities

2012-06-16 04:04

 

2012-06-16 04:05

 

2012-06-16 04:08

 

lukessketcher_angleconstraint in wrong place3.FCStd (8,079 bytes)

mrlukeparry

2012-06-23 05:42

developer   ~0002235

I made a few small improvements to this, but I've still got a problem with constraints such as horizontal and distance that share the same line. It's a problem with the ray pick method and needs further investigation.

I am hoping it can be improved further, but has less priority respectively.

Jriegel

2012-12-20 20:19

administrator   ~0002702

Since Luke already confessed ;)

mrlukeparry

2012-12-23 16:09

developer   ~0002757

I am not happy with the overlapping constraints icons. It seems to not work at all now. I think this needs a complete re-write for 0.14 and hopefully improve the performance at the same time if time permits.

bejant

2014-07-09 14:35

reporter   ~0004783

User ian.rees has done some work on this issue:
http://forum.freecadweb.org/viewtopic.php?f=10&t=6965&p=56342

bejant

2014-08-24 18:38

reporter   ~0005002

Last edited: 2015-07-02 22:32

View 3 revisions

I stumbled on this again wanted to add the following links
http://forum.freecadweb.org/viewtopic.php?f=17&t=7176
http://forum.freecadweb.org/viewtopic.php?f=17&t=7228
which may be of help to devs regarding the status of this ticket.
------
Edit 2014-11-23: The issue of constraint symbols being placed on top of one another has been fixed.

Kunda1

2017-12-11 06:22

administrator   ~0010563

@bejant you wrote
bejant wrote

Edit 2014-11-23: The issue of constraint symbols being placed on top of one another has been fixed.

does that mean this ticket is fixed ?

bejant

2017-12-12 03:01

reporter   ~0010577

Kunda1 wrote

does that mean this ticket is fixed ?

@Kunda1 : Yes

Kunda1

2017-12-12 03:02

administrator   ~0010578

Last edited: 2017-12-12 03:03

View 2 revisions

Thanks bejant! Resolving ticket. Will defer to a dev to close it.

Issue History

Date Modified Username Field Change
2012-06-16 04:04 jmaustpc New Issue
2012-06-16 04:04 jmaustpc File Added: lukessketcherbranch_anglecontraint shows in wrong place.jpg
2012-06-16 04:05 jmaustpc File Added: lukessketcherbranch_anglecontraint shows in wrong place1_similarsketchmadeingitmaster.jpg
2012-06-16 04:08 jmaustpc File Added: lukessketcher_angleconstraint in wrong place3.FCStd
2012-06-23 05:42 mrlukeparry Note Added: 0002235
2012-07-01 12:50 yorik Project FreeCAD => Sketcher
2012-12-20 20:18 Jriegel Status new => assigned
2012-12-20 20:18 Jriegel Assigned To => mrlukeparry
2012-12-20 20:19 Jriegel Note Added: 0002702
2012-12-20 20:19 Jriegel Status assigned => confirmed
2012-12-23 16:09 mrlukeparry Note Added: 0002757
2014-07-09 14:35 bejant Note Added: 0004783
2014-08-24 18:38 bejant Note Added: 0005002
2014-11-24 03:11 bejant Note Edited: 0005002 View Revisions
2015-07-02 22:32 bejant Note Edited: 0005002 View Revisions
2017-12-11 06:22 Kunda1 Note Added: 0010563
2017-12-11 06:25 Kunda1 Tag Attached: #pending
2017-12-11 06:25 Kunda1 Tag Attached: constraints
2017-12-12 03:01 bejant Note Added: 0010577
2017-12-12 03:02 Kunda1 Assigned To mrlukeparry => ian.rees
2017-12-12 03:02 Kunda1 Status confirmed => resolved
2017-12-12 03:02 Kunda1 Resolution open => fixed
2017-12-12 03:02 Kunda1 Note Added: 0010578
2017-12-12 03:03 Kunda1 Note Edited: 0010578 View Revisions
2017-12-12 03:03 Kunda1 Tag Detached: #pending
2017-12-15 19:13 abdullah Status resolved => closed
2017-12-15 19:13 abdullah Fixed in Version => 0.17