View Issue Details

IDProjectCategoryView StatusLast Update
0000747PartDesignBugpublic2012-11-01 09:11
Reporterjmaustpc Assigned To 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Platform32bitOSKubuntuOS Version12.04
Product Version 
Target VersionFixed in Version0.13 
Summary0000747: Groove tool in PartDesign WB reverts to producing a solid revolve
DescriptionGroove tool in PartDesign WB reverts to producing a solid revolve, rather than removing material with a groove, on anything other than an initial Pad




Full version data

Version: 0.13.1124 (Git)
Branch: master
Hash: 6c16628f4e0ed88ca12c05877c43602d71219134
Steps To Reproducecreate a sketch,
pad,
select a side face of Pad,
create another sketch,
groove from the second sketch,

create another sketch,
try to groove,

groove produces a solid revolve, not a groove

Or an alternative method
go to Part WB click on Box
create a sketch try to groove
you get a solid revolve
Additional InformationHere's a test file as an example
TagsNo tags attached.
FreeCAD Information

Relationships

child of 0000745 closed Groove often fails or does unexpected things 

Activities

2012-06-11 09:41

 

testofgroove1_groovein_pad.FCStd (17,769 bytes)

jmaustpc

2012-06-11 09:57

manager   ~0002174

Quote: -
Or an alternative method
go to Part WB click on Box
create a sketch try to groove
you get a solid revolve

Actually on further testing, the above is not correct, it does work on Part box, just only the first time, that is it will work on another box created then moved elsewhere,

the problem is when you try to Groove on the solid produced from a previous groove .

2012-06-11 09:57

 

test_of_groove2_groove_in_Part_box.FCStd (8,516 bytes)

jrheinlaender

2012-06-11 12:37

developer   ~0002176

The groove feature was not checking whether the sketch has a support. Therefore the cutout of the groove fails when the sketch is not placed on the face of some solid.

I pushed an updated FeatureGroove.cpp to
https://github.com/jrheinlaender/FreeCAD
branch jrheinlaender/PartDesign

Or should I post a diff here instead?

Issue History

Date Modified Username Field Change
2012-06-11 09:41 jmaustpc New Issue
2012-06-11 09:41 jmaustpc File Added: testofgroove1_groovein_pad.FCStd
2012-06-11 09:57 jmaustpc Note Added: 0002174
2012-06-11 09:57 jmaustpc File Added: test_of_groove2_groove_in_Part_box.FCStd
2012-06-11 10:40 wmayer Relationship added child of 0000745
2012-06-11 12:37 jrheinlaender Note Added: 0002176
2012-07-01 12:53 yorik Project FreeCAD => PartDesign
2012-11-01 09:11 logari81 Resolution open => fixed
2012-11-01 09:11 logari81 Status new => closed
2012-11-01 09:11 logari81 Fixed in Version => 0.13