View Issue Details

IDProjectCategoryView StatusLast Update
0000746PartDesignBugpublic2012-12-04 11:14
Reporterjmaustpc Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platform32 bitOSKubuntuOS Version12.04
Product Version 
Target VersionFixed in Version0.13 
Summary0000746: Groove tool in PartDesign WB can't be moved nor can its sketch
DescriptionGroove tool in PartDesign WB once a groove has been made it can't be moved nor rotated either by adjusting its own parameters nor the parameters of its sketch


Full version data
Version: 0.13.1124 (Git)
Branch: master
Hash: 6c16628f4e0ed88ca12c05877c43602d71219134
Steps To Reproducedo a sketch, pad, do a sketch on the side of the Pad, groove a few degrees,

then try and adjust any axis or position parameters.

The groove objects parameters are, I believe, deliberately set to read only. However the sketches parameters change but immediately revert once you click away from the parameter.
TagsNo tags attached.
FreeCAD Information

Relationships

child of 0000745 closed Groove often fails or does unexpected things 

Activities

jmaustpc

2012-06-11 10:05

manager   ~0002175

This same problem exists in the same manner with PartDesign Revolve

jrheinlaender

2012-06-11 14:02

developer   ~0002178

Same problem with pocket and pad.

Maybe this is intended behaviour because with the upcoming Body Feature there should only be a single placement, namely that of the Body, which all other features inherit from?

wmayer

2012-11-23 16:52

administrator   ~0002581

I think this issue is fixed. But I realized a different problem: if the groove axis intersect its sketch the application hangs.

jrheinlaender

2012-11-30 12:01

developer   ~0002604

Proposed fix see github jrheinlaender/PartDesign-0.14

http://github.com/jrheinlaender/FreeCAD/tree/jrheinlaender/PartDesign-0.14

Issue History

Date Modified Username Field Change
2012-06-11 09:30 jmaustpc New Issue
2012-06-11 10:05 jmaustpc Note Added: 0002175
2012-06-11 10:39 wmayer Relationship added child of 0000745
2012-06-11 14:02 jrheinlaender Note Added: 0002178
2012-07-01 12:53 yorik Project FreeCAD => PartDesign
2012-11-23 16:52 wmayer Note Added: 0002581
2012-11-30 12:01 jrheinlaender Note Added: 0002604
2012-12-04 11:14 wmayer Status new => closed
2012-12-04 11:14 wmayer Resolution open => fixed
2012-12-04 11:14 wmayer Fixed in Version => 0.13