View Issue Details

IDProjectCategoryView StatusLast Update
0000742DraftBugpublic2012-06-13 20:37
Reporterjmaustpc Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platform32 bitOSKubuntuOS Version12.04
Product Version 
Target Version0.13Fixed in Version0.13 
Summary0000742: popup window "workbench failure" - "float divide by zero"
DescriptionWhen switching to Draft or Arch WB a window pops up titled "workbench failure" with a message "float division by zero".

It only happens if you have a document, either a new empty doc, or one containing a project. It does not happen if you first start FreeCAD then switch between workbenches before you have created a new document or opened an existing one.

This problem only started for me, this morning my time, a few hours before this post. On

Kubuntu 12.04 32bit

Version: 0.13.1097 (Git)
Branch: master
Hash: 04d21035669c99e77e5b2b5c4a01d678e0181456

I have since upgraded from git /master and compiled and the problem is still there in the new version of FreeCAD as below: -

Version: 0.13.1104 (Git)
Branch: master
Hash: e7644fd3b32e487b915249ac86949495e9401ae6




Steps To Reproducestart FreeCAD
either open existing project or create a new blank project
then switch to either Arch or Draft WB

then the error window will pop up.
 

TagsNo tags attached.
FreeCAD Information

Activities

yorik

2012-06-08 13:21

administrator   ~0002157

Hm I can't reproduce this, no matter what I do...

yorik

2012-06-11 15:40

administrator   ~0002181

Do you still have this problem Jim? I can't reproduce it...

pperisin

2012-06-11 18:08

reporter   ~0002183

I have bug: 'NoneType' object has no attribute 'set' when switching to draft module.

git 1129 win7

yorik

2012-06-11 18:18

administrator   ~0002184

Okay I think I got it... See if it works now?

pperisin

2012-06-11 19:19

reporter   ~0002185

ok, it works now.

yorik

2012-06-13 20:37

administrator   ~0002199

Ok this looks fixed so I close it. Don't hesitate to reopen if needed...

Issue History

Date Modified Username Field Change
2012-06-07 23:52 jmaustpc New Issue
2012-06-08 05:28 wmayer Status new => assigned
2012-06-08 05:28 wmayer Assigned To => yorik
2012-06-08 13:21 yorik Note Added: 0002157
2012-06-11 15:40 yorik Note Added: 0002181
2012-06-11 15:41 yorik Status assigned => feedback
2012-06-11 18:08 pperisin Note Added: 0002183
2012-06-11 18:18 yorik Note Added: 0002184
2012-06-11 19:19 pperisin Note Added: 0002185
2012-06-12 16:53 yorik Project FreeCAD => Draft
2012-06-12 16:54 yorik Target Version => 0.13
2012-06-13 20:37 yorik Note Added: 0002199
2012-06-13 20:37 yorik Status feedback => closed
2012-06-13 20:37 yorik Resolution open => fixed
2012-06-13 20:37 yorik Fixed in Version => 0.13