View Issue Details

IDProjectCategoryView StatusLast Update
0000736FreeCADFeaturepublic2012-07-07 09:37
ReporterpperisinAssigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000736: when object is deleted, auto show it's parametric objects
DescriptionHi,

currenlty when you have a sketch - you can create pad from it. then sketch gets hidden and appears under pad in the Combo view.

now, if you delete pad, sketch gets to be unhidden again. This is a really nice touch IMO.

It would be nice if this would work on fillet, chamfer and boolean operations (actually in all parametric objects) - if object is deleted, it's 1.st level parametric shapes get to be unhidden.

Regards
Petar
TagsNo tags attached.

Activities

shoogen

2012-06-05 11:05

developer   ~0002129

but not necessarily if the Features has other parents.

pperisin

2012-06-05 11:39

reporter   ~0002130

what do you mean. can you give example?

Also, after thinking about this little more, maybe it would be good idea to allow showing only one object in entire branch. so, if you have sketch and it's pad, and you wish to show sketch, pad will get auto hidden. also, if you have 4-5 level branches, you have ability to show only one "shape" in it at the time.

take a look at the picture. If i would show Fusion, cut would get auto hidden. Then after that if I show box, fusion is auto hidden.

2012-06-05 11:39

 

branch.png (Attachment missing)

yorik

2012-06-05 18:05

administrator   ~0002136

The problem is that one object can be included in several others (several extrusions based on the same sketch, etc...). I have the feeling there are case where it would be good, others where it wouldn't. And it's a pretty complex matter to define all the possible cases...

shoogen

2012-06-06 04:01

developer   ~0002137

Maybe it would be better if the children of the deleted object would be selected and the tree expanded (to make them visible in the tree view), so they can be unhidden using the space bar?
Of course this feature should be configurable in the preferences.

pperisin

2012-06-06 12:04

reporter   ~0002138

Last edited: 2012-06-06 12:05

Maybe I can explain little further why I made this request.

When doing something parametric in FreeCAD (i.e. boolean) shapes used for operation get hidden. Now, when you want to modify source shape, this is what you do:

- hide top shape
- show under-shape
- modify under-shape
- hide under-shape
- show top-shape

notice that in this case you have two show/Hide operations that are always executed one after another one. I was thinking about merging them into one command, so that if you show sub-shape, top shape gets to be hidden.

also, even bigger issue you have when you delete object. then it's subshape remains hidden, and if in the combo view you have a lot of shapes, it can be really hard to find and unhide sub shape of a deleted shape (I hope this is not so hard to understand).

one other thing came to my though - maybe using SHIFT+Delete to delete shape and all it's sub-shapes (maybe it does not make much sense, I don't know, but it does not hurt to tell).

Regards,
Petar

wmayer

2012-07-07 09:36

administrator   ~0002285

Basically it's correct that a feature can be referenced by more than one parent object BUT this is usually bad modelling practice. There might be cases where it is unavoidable but it's bad style, at least.

I think it really makes sense for the above mentioned objects to implement this feature.

wmayer

2012-07-07 09:37

administrator   ~0002286

git show fc50177

Issue History

Date Modified Username Field Change
2012-06-05 07:36 pperisin New Issue
2012-06-05 11:05 shoogen Note Added: 0002129
2012-06-05 11:39 pperisin Note Added: 0002130
2012-06-05 11:39 pperisin File Added: branch.png
2012-06-05 18:05 yorik Note Added: 0002136
2012-06-06 04:01 shoogen Note Added: 0002137
2012-06-06 12:04 pperisin Note Added: 0002138
2012-06-06 12:05 pperisin Note Edited: 0002138
2012-07-07 09:36 wmayer Note Added: 0002285
2012-07-07 09:37 wmayer Note Added: 0002286
2012-07-07 09:37 wmayer Status new => closed
2012-07-07 09:37 wmayer Resolution open => fixed
2012-07-07 09:37 wmayer Fixed in Version => 0.13