View Issue Details

IDProjectCategoryView StatusLast Update
0000717FreeCADBugpublic2012-05-25 07:26
ReportershoogenAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000717: Version info causes crash
Descriptionif compiled from a detached head (branch is Null)
FreeCAD crashes on accssesing list items.
>>> FreeCAD.Version()
['0', '13', '0950 (Git)', <NULL>, 'ssh://host/free-cad']
>>> FreeCAD.Version()[3]
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff64d9178 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
>>> list(FreeCAD.Version())
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff646a174 in ?? () from /usr/lib/libpython2.6.so.1.0
TagsNo tags attached.

Activities

wmayer

2012-05-23 08:08

administrator   ~0002077

The implementation of this function seemed a bit strange. Can you check if git 27aef69 fixes the issue?

shoogen

2012-05-25 06:47

developer   ~0002082

Last edited: 2012-05-25 06:48

Thanks Werner.
Unfortunatly i lost the old Version.h and I was not able to reproduce the Problem anymore neither by manipulating my local git repo nor by faking the branch Value in the Version.h.
I think it is the best to close the ticket.

Issue History

Date Modified Username Field Change
2012-05-22 16:38 shoogen New Issue
2012-05-23 08:08 wmayer Note Added: 0002077
2012-05-25 06:47 shoogen Note Added: 0002082
2012-05-25 06:48 shoogen Note Edited: 0002082
2012-05-25 07:26 wmayer Status new => closed
2012-05-25 07:26 wmayer Resolution open => fixed
2012-05-25 07:26 wmayer Fixed in Version => 0.13