View Issue Details

IDProjectCategoryView StatusLast Update
0000712FreeCADBugpublic2012-05-21 14:28
ReporterdjreichelAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000712: Cad Navigation Zoom with Ctrl + causes shapes to pan off screen
DescriptionFedora 16 32 bit
Version: 0.13.0952 (Git)
Branch: master
Hash: 1a79480bd61bda58381d48b1c1543f61273d2976

I start with a default box 10 mm cube, zoom to fit, then 3 steps of zoom in with Ctrl + (in CAD navigation mode)

The position values appear to be shifted each time the zoom is processed.

If I execute setCamera with the original values for position, the view would once again be "centered" at
any of these zoom levels.

Initial condition: position (5, -3.6602554, 5)

after zoom1: position (-86.491455, -3.6602554, -44.871216) delta (-91.491455, 0, -49.871216)

after zoom2: position (-169.27637, -3.6602554, -89.996582) delta (-82.784915. 0, -45.125366)

Additional InformationOriginally this bug was posted on the forum, where Werner said he was able to replicate the behavior. This was surprising because PPA daily builds I've been running on Vbox guest: Ubuntu Lucid (10.04) always have zoomed in/out correctly leading me to presume it was an issue only on Fedora.
TagsNo tags attached.

Activities

wmayer

2012-05-21 14:28

administrator   ~0002067

This only happened if the "zoom at cursor" option is on.
Fix in git f33a6b9

Issue History

Date Modified Username Field Change
2012-05-20 09:42 djreichel New Issue
2012-05-21 14:28 wmayer Note Added: 0002067
2012-05-21 14:28 wmayer Status new => closed
2012-05-21 14:28 wmayer Resolution open => fixed
2012-05-21 14:28 wmayer Fixed in Version => 0.13