View Issue Details

IDProjectCategoryView StatusLast Update
0000699FreeCADBugpublic2013-08-28 09:01
Reportershoogen Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.14 
Summary0000699: Shape.removeSplitter() loses Shape.Placements on some Shapes
DescriptionThis is only happens with certain Shapes like the result of booleans while others, like most primitives keep their Placement.
Additional Informationdoc=App.ActiveDocument
doc.addObject("Part::Sphere","Sphere")
doc.addObject("Part::Box","Box")
doc.addObject("Part::MultiCommon","Common")
doc.Common.Shapes = [App.activeDocument().Sphere,App.activeDocument().Box,]
doc.recompute()
doc.Common.Placement = App.Placement(App.Vector(10,0,0),App.Rotation())
doc.Common.Shape.removeSplitter().Placement.Base==doc.Common.Shape.Placement.Base
TagsNo tags attached.
FreeCAD Information

Activities

shoogen

2012-05-07 14:17

developer   ~0002029

The BoundBox seems to be fine.

shoogen

2012-05-07 14:30

developer   ~0002030

fp.Shape=sh.transformGeometry(fp.Base.Placement.multiply(sh.Placement.inverse()).toMatrix()) does not fix the problem either.

shoogen

2012-05-07 14:37

developer   ~0002031

but fp.Shape=sh.transformGeometry(sh.Placement.inverse.toMatrix()) did. Please close the Ticket.

shoogen

2012-05-27 17:23

developer   ~0002087

The problem is not Shape.removeSplitter(). Please close this ticket with 'no change required'

The problem is how to modify the shape of a sub object to calculate the shape of a Feature. Since the Placement belonging to the Shape gets lost at shape assignment there needds to be a special function 'apply placemnt' for this.
This function would apply the rotation and translation of placement to each Vertex of a Shape, without converting the geometry to b-splines (opposed to the beahivor of transformShape().) Secondly the funtion would nullify the placement of the Shape.

wmayer

2012-05-27 19:12

administrator   ~0002090

These are the best reports :)

shoogen

2013-08-27 05:09

developer   ~0003525

Last edited: 2013-08-27 05:13

This behavior had to be changed because of the drawbacks of transformGeometry (see ticket 0001221)

git show 48f8d67b509a61875ee32fb809c8a66c4cafe6fe

please close with fixed in version 0.14

Issue History

Date Modified Username Field Change
2012-05-07 14:07 shoogen New Issue
2012-05-07 14:17 shoogen Note Added: 0002029
2012-05-07 14:30 shoogen Note Added: 0002030
2012-05-07 14:37 shoogen Note Added: 0002031
2012-05-27 17:23 shoogen Note Added: 0002087
2012-05-27 19:12 wmayer Note Added: 0002090
2012-05-27 19:12 wmayer Status new => closed
2012-05-27 19:12 wmayer Resolution open => no change required
2012-05-27 19:12 wmayer Fixed in Version => 0.13
2013-08-27 05:09 shoogen Note Added: 0003525
2013-08-27 05:09 shoogen Status closed => feedback
2013-08-27 05:09 shoogen Resolution no change required => reopened
2013-08-27 05:10 shoogen Note Edited: 0003525
2013-08-27 05:11 shoogen Note Edited: 0003525
2013-08-27 05:12 shoogen Note Edited: 0003525
2013-08-27 05:13 shoogen Note Edited: 0003525
2013-08-28 09:01 wmayer Status feedback => closed
2013-08-28 09:01 wmayer Resolution reopened => fixed
2013-08-28 09:01 wmayer Fixed in Version 0.13 => 0.14