View Issue Details

IDProjectCategoryView StatusLast Update
0000691SketcherBugpublic2013-02-13 13:18
ReportermathrickAssigned Tologari81 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000691: Sketcher: Symmetry constraint broken for arc endpoints
DescriptionSymmetry constraint is broken for arc endpoints and always results in conflicting constraints error, even if it's the only one in the sketch.

Tested with both 0857 and 0899. It works fine in 0.12.
TagsNo tags attached.

Activities

2012-05-01 23:12

 

symmetry-bug.FCStd (2,719 bytes)

mathrick

2012-05-01 23:57

reporter   ~0001991

Actually, that's incorrect. The file I attached does NOT work in 0.12. It seems that making the arc centre and one of the line's points coincident triggers the error. Both 0.12 and 0.13 can enforce the symmetry otherwise. It used to work before, as demonstrated by http://freecad-tutorial.blogspot.com/2011/09/engine-1-piston-pin-and-pin-ring.html

djreichel

2012-05-05 13:26

reporter   ~0002013

Last edited: 2012-05-06 12:40

I have a sketch that may shed some light on what's happening.

See uploaded file: MirrorConstraintFailExample.fcstd

The line can not have mirror constraint about Y axis unless horizontal constraint is removed.

Tha arc can not have mirror constraint about Y axis unless point-line constraint between arc center and Y axis is first removed.

A general observation is that it looks like mirror/symmetric constraint wants to remove two degrees of freedom and reults in overconstraint condition if there is only one degree to be removed.

Version: 0.13.0930 (Git)
Branch: master
Hash: 7b2e15bedf5743fda7439581203619aae29cd9e7

2012-05-05 13:27

 

MirrorConstraintFailExample.fcstd (3,677 bytes)

logari81

2012-05-14 07:31

developer   ~0002039

it should now be fixed in the sketch-diagnostics branch:

http://free-cad.git.sourceforge.net/git/gitweb.cgi?p=free-cad/free-cad;a=commit;h=ce5d9a332a75c3e02c79709f38c62311d60a0b2e

which needs some more testing and polishing before merged to master.

djreichel

2012-05-16 01:30

reporter   ~0002048

Last edited: 2012-05-16 01:46

Version: 0.13.0955 (Git)
Branch: logari81/sketch-diagnostics
Hash: bbf04bb040f4e489838d022712eca0862b2c17ae

I tested symmetric constraint in a variety of situations involving arcs and lines. The solver was able to identify redundant constraints. Following manual removal of the redundant constraint(s) the sketches were fully constrained. This greatly enhances the useability of sketcher.

Issue History

Date Modified Username Field Change
2012-05-01 23:12 mathrick New Issue
2012-05-01 23:12 mathrick File Added: symmetry-bug.FCStd
2012-05-01 23:57 mathrick Note Added: 0001991
2012-05-05 13:26 djreichel Note Added: 0002013
2012-05-05 13:27 djreichel File Added: MirrorConstraintFailExample.fcstd
2012-05-05 17:50 yorik Project FreeCAD => Sketcher
2012-05-06 12:40 djreichel Note Edited: 0002013
2012-05-14 07:31 logari81 Note Added: 0002039
2012-05-14 10:28 logari81 Assigned To => logari81
2012-05-14 10:28 logari81 Status new => confirmed
2012-05-14 10:28 logari81 Product Version 0.13 =>
2012-05-14 10:29 logari81 Summary Symmetry constraint broken for arc endpoints => Sketcher: Symmetry constraint broken for arc endpoints
2012-05-14 10:30 logari81 Status confirmed => assigned
2012-05-16 01:30 djreichel Note Added: 0002048
2012-05-16 01:46 djreichel Note Edited: 0002048
2012-07-13 09:09 logari81 Status assigned => resolved
2012-07-13 09:09 logari81 Fixed in Version => trunk
2012-07-13 09:09 logari81 Resolution open => fixed
2012-07-14 08:57 wmayer Status resolved => closed
2013-02-13 13:18 yorik Fixed in Version trunk => 0.13