View Issue Details

IDProjectCategoryView StatusLast Update
0000688FreeCADBugpublic2012-05-04 12:49
Reporterdjreichel Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.13 
Summary0000688: Gui issues: draft module rectangle tool always produces filled rectangle
Descriptionthe checkbox for filled seems to have no effect for the draft module rectangle tool.

Also, the continue checkbox can be checked already when a draft tool is (re)activated. In spite of this the command behaves as if the continue checkbox was not checked. If the checkbox is toggled off, then back on, the tool will create multiple objects.

The active command bar shows command: "point" when "polygon" or "rectangle" tool is activated. Shows "line" when "polyline" tool is activated.

Then here's an odd effect: If the polygon tool is activated, the continue checkbox is checked and then the rectangle tool is activated, the tool will produce alternating polygons and rectangles. (the rectangles are always filled, the polygons obey the selection of the "filled" checkbox)

Additional InformationFedora 16
Version: 0.13.0907 (Git)
Branch: master
Hash: a6aa5d1bd81329f3a4ab5d89d5d238faa97725ce
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2012-04-30 17:29

administrator   ~0001986

Ok I'll look into this all...
Next time, can you make one separate issue for each problem? It makes it easier for us.

djreichel

2012-04-30 17:40

reporter   ~0001987

yes, will do.

yorik

2012-05-01 19:12

administrator   ~0001989

Okay the problem with filled/unfilled rectangle is fixed, as well as the toolbar command names with commit 47d5333.

But the 2 other behaviours I cannot reproduce... Can you give me an exact procedure of how you did this:

- Have the continue button already checked when starting a new command? Normally it is always off after you finish a command
- Activate the rectangle tool while using the polygon tool? Normally commands are greyed out until you finish one

But maybe those problems were a consequence of the first one, so it might be fixed too now...

djreichel

2012-05-03 01:53

reporter   ~0002003

Yes, I see the rectangle filled/unfilled checkbox is working properly now, as well as the text labels for the active command bar.

These other issues are still present. On myFedora 16 if the checkbox was checked when a tool is closed, it is still checked when any drawing tool is then activated, though the tool does not continue unless the checkbox is toggled off then back on.

Also even while a drawing tool is activated, the drawing tool icons are not greyed out and may be selected giving this alternating rectangle/polygon creation I described. (only if the continue box has been selected)

I'm wondering if this is caused by differences in Qt 4.8.

yorik

2012-05-03 14:03

administrator   ~0002004

You're cancelling the command with the "Cancel" button right? I never use it (I press Escape), I just discovered a bug there that should be fixed now and likely caused your problems. Can you test again to see if it got solved?

djreichel

2012-05-03 23:14

reporter   ~0002005

Thanks, everything seems to be working great.

yorik

2012-05-04 12:49

administrator   ~0002010

One more bug closed, yay!

Issue History

Date Modified Username Field Change
2012-04-30 01:31 djreichel New Issue
2012-04-30 17:29 yorik Status new => assigned
2012-04-30 17:29 yorik Assigned To => yorik
2012-04-30 17:29 yorik Note Added: 0001986
2012-04-30 17:40 djreichel Note Added: 0001987
2012-05-01 19:12 yorik Note Added: 0001989
2012-05-03 01:53 djreichel Note Added: 0002003
2012-05-03 14:03 yorik Note Added: 0002004
2012-05-03 23:14 djreichel Note Added: 0002005
2012-05-04 12:49 yorik Note Added: 0002010
2012-05-04 12:49 yorik Status assigned => closed
2012-05-04 12:49 yorik Resolution open => fixed
2012-05-04 12:49 yorik Fixed in Version => 0.13