View Issue Details

IDProjectCategoryView StatusLast Update
0000685ArchBugpublic2012-05-16 22:42
Reportercsmwww Assigned Toyorik  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000685: Unable to change saved "wall" attributes (like Length - Err: Wall: 'NoneType' object has no attribute 'execute')
DescriptionNew to FreeCAD, first moderate drawing and I find I can no longer change the size any of the Wall items I have saved. Going back all saved file versions, the problem was there. I reduced to creating a new doc with one wall, saving, then opening that and the same problem exists. If I want to modify any wall sizes in my drawing I now have to create new wall and rebuild it (duplicated items are still problematic).

Simplified steps:

Initial run (Win XP, 32 bit, "-l" switch, new doc, wall, save):

1. File -> New document
2. Change to "ARCH" workbench.
3. Create wall object with toolbar button.
4. Save document

Second run (open doc, select wall, change length in data tab):

1. File -> Open document with wall (combined view, start workbench).
2. Click select Wall in "Labels & Attributes".
3. Click "data" tab below.
4. Click in "Length" and use up arrow.
5. Click on document name in "Labels & Attributes".

Exclamation point on "Wall" node, Error generated (in log below), and "view" does not move item. Save and open doc, and the Length change is still known, but the view does not render it with new length.
Additional InformationPython 2.6.2 (r262:71600, Jun 22 2009, 21:44:05) [MSC v.1500 32 bit (Intel)] on win32
Msg: FreeCAD 0.12, Libs: 0.12R5284

Support files attached:

- FreeCAD12.1.log (initial setup)
- FreeCad12.FCStd (file saved from initial setup)
- FreeCAD12.2.log (second run - problem)
- FreeCAD13.1.log (tangent below)

Somewhat tangential: I tried the same steps in 0.13 subsequently installed on the same machine, but in the initial step 3 I am left in active command "Point" and clicking returns to active command "none" creating no wall. Since I am neither sure if my step 3 is considered legit in 13, or if having 12 & 13 might have library issues, I add that here hoping it is relevant rather than filing another bug.
TagsNo tags attached.

Activities

2012-04-28 13:06

 

FreeCADWallChangeErr.zip (Attachment missing)

yorik

2012-04-28 14:28

administrator   ~0001978

The arch module is still very much work in progress, and a lot of things are changing, so before the next stable release you shouldn't expect very stable results, and a lot of things can be broken intermittently... But I'll look at this one

yorik

2012-04-28 21:47

administrator   ~0001980

Okay.. The "Length" property is no more used in 0.13 since all walls are based on 2D geometry. I'll remove it to avoid confusion

About your other bug, in 0.13, adding a new wall starts a drawing tool. I have no idea why it doesn't work for you, any error message appears?

csmwww

2012-04-28 23:09

reporter   ~0001981

Hi yorikvanhavre:

I can appreciate not wanting to go back and work on release 0.12 if the representation of an item has changed. However, when I open my simple test file in 0.13, the attached file made in pass 1 using version 0.12, I still see the "data" for a wall specifies only a single point, and I am unable to fathom how height, width, or length could thus be removed. All three seem required to define a wall "part", which is ultimately 3D. Perhaps it will become apparent if I am missing some trick in the GUI, and/or there is a bug here that gets resolved.

Barring opening the 0.12 test file, I still can't figure out how to make a wall in 0.13. In a new doc, I switch to Arch mode, click the wall tool, then the active command shows "Point".... clicking down in the canvas shows a hand, but upclick returns to active command to "none" without comment anywhere I can find, and with neither and object added to the tree not anything drawn. Perhaps I miss some tricks of the GUI.

Error messages: the original attached zip has the a file FreeCAD13.1.log which I had hand prefixed with the python command window output (which said nothing at this point), as well the log generated when from launching with the "-l" switch and trying to create a wall. Is there more verbosity or logging somehow?

From what I have seen so far, the GUI does a number of things without python command window output, and apparently no logging. For example, in the 0.12 reported issue the wall icon when the tree switched from "check mark" (modified and not evaluated?) to the explanation point and generated a logged "Err:", it did so without any python output nor any indication of what call might have been made and failed in the logs. Moreover, it is not clear to me what GUI "action" triggers apparent evaluation of a "check marked" item - nor in fact quite what the "check mark" means. But, it appears to me that at least sometimes if I have made a change that displays a "check mark", then click on another object, something seems to happen some times.

All this this leaves me at a loss how to dig deeper.

Thanks for looking, especially so quickly. I have finished the work on my immediate drawing by working around things that challenged me, so this is not urgent to me now. But it is nice to see you are so active.

Cris

yorik

2012-05-01 19:53

administrator   ~0001990

The length of a wall is now defined by its underlying line. In 0.13, when you draw a wall, it is based on a line. You log indeed doesn't provide any useful information about what's happening...

About python commands not being logged, it's normal, at the moment python workbenches are unable to log commands. About the check marks, it means an object needs to be recalculated.

Do the Draft tools (Line, circle, rectangle, etc) work for you? It might be the problem with the wall...

csmwww

2012-05-04 00:59

reporter   ~0002006

Last edited: 2012-05-04 01:04

After pondering much, I am convinced either my install is not working as expected, there are still enough bugs in 0.12 and 0.13 that any workflow is not consistent, and/or I am so far off understanding the UI paradigm that I am little use to you. Hoping to believe in a conflict between 012 and 013 installs that might support my first point, I uninstalled both version 0.12 and 0.13, rebooted, and installed FreeCAD_0.13.0899_x86_unstable_setup.msi, assuming pursuing things in the unstable development version is your preferred path. No change.

Further to foil my hopes to offer constructive feedback, pointing out the logs the program makes are not useful does nothing to help me provide you valuable feedback.

Barely accepting I am seeing anything like what you are seeing, I open the brand new 0.13 install, create a new document, switch to "view -> workbench -> draft", then click the "creates a 2-point line" tool. The "active command" becomes "Line", offering X,Y,Z, and a new "Line" appears in the Combo-View "Project" tab's tree (I believe this was what you wanted me to test). At this point the X,Y,Z remain zero as I remove around the new document canvas (in 0.12 they tracked coordinates) and clicking appears to do nothing (clicking set a point in 0.12). Clicking on the Active command's "Finish" or "Close" reverts "active command" to "none", and the "line" object in the Project tree vanishes. Conversely, in case it triggers something in you, I view the workbench "sketcher", create a "new sketch" in XY, and then the cursor tracks and clicking makes a point, and another a line.

Please keep in mind here that reverse engineering this product from "what I see" (not knowing from the inside like you do, and essentially having no manual), the subtle difference between these two workbenches draft and sketcher remains a mystery, and the immediately presented "constraints" (with 11 missing) unique to sketcher might as well be Pluto. I have no idea what more to offer, since I almost have no idea what is intended or is going on.

These steps are as simple as I can come up with, from a clean install, especially given what I feel is a "weak" grasp on this whole UI (which I suspect may substantially stem from the possibility at least enough significant things are not working as you expect making it hard for me to really get a feel for the intended UI).

If you are unable to reproduce this 0.13 set of steps, which in no way touches on the fact that in the "more working" 0.12 I can't change the size of the saved walls as originally reported, and the Python command window and written text logs are of no use to you, then I suspect I am of little as well.

Thanks for the start you have made on a noble project. Though losing my cool more times than I might be able to count, I was able to create some drawings at http://elliottcg.org/node/91 that are better than I could likely have done without your efforts so far. I will revert to 0.12 and try and struggle by the little work I have left to accomplish on my project.

yorik

2012-05-04 11:28

administrator   ~0002007

Hi

Sorry to hear about your struggle,
Yes there is definitely something wrong with your FreeCAD installation... Probably something to do with the python pivy module, but it's hard to tell from here. About the 0.12, the arch module in 0.12 was very, very new, and it has changed so much after that it would be very hard to port changes back to it. Besides, I believe it comes from the same problem (pivy not working). Maybe this comes from 3D drivers not properly installed or up to date.

Anyway, good that you managed to do what you wanted at the end.

Issue History

Date Modified Username Field Change
2012-04-28 13:06 csmwww New Issue
2012-04-28 13:06 csmwww File Added: FreeCADWallChangeErr.zip
2012-04-28 14:28 yorik Note Added: 0001978
2012-04-28 14:28 yorik Status new => assigned
2012-04-28 14:28 yorik Assigned To => yorik
2012-04-28 21:47 yorik Note Added: 0001980
2012-04-28 23:09 csmwww Note Added: 0001981
2012-05-01 19:53 yorik Note Added: 0001990
2012-05-03 13:22 yorik Status assigned => feedback
2012-05-04 00:59 csmwww Note Added: 0002006
2012-05-04 01:02 csmwww Note Edited: 0002006
2012-05-04 01:04 csmwww Note Edited: 0002006
2012-05-04 11:28 yorik Note Added: 0002007
2012-05-04 13:15 yorik Project FreeCAD => Arch
2012-05-16 22:42 yorik Status feedback => closed
2012-05-16 22:42 yorik Resolution open => fixed
2012-05-16 22:42 yorik Fixed in Version => 0.13