View Issue Details

IDProjectCategoryView StatusLast Update
0000680DraftBugpublic2012-05-22 18:11
ReporteracricfdAssigned Toyorik 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000680: Wrong rendering of DXF files
DescriptionWhen DXF file is inported to latest version freecad, the lines, arcs etc.. are not correctly displayed.Some of lines and circles are displaced from their locations.This problem is not found in 0.11 Version.

DXF file used for testing is attached here.
TagsNo tags attached.

Activities

2012-04-24 04:01

 

01.dxf (21,471 bytes)

jcc242

2012-04-24 15:54

reporter   ~0001965

I looked at your file, it renders the same in AutoCAD, FreeCAD, and LibreCAD. Is this possibly an export-to-dxf error? What program did you use to create the file?

yorik

2012-04-24 16:45

administrator   ~0001966

For me too it looks ok, same result in librecad and freecad...
Please give us the options that are enabled or disabled in the Edit->preferences->Draft->Import options->Dxf screen?

2012-05-02 07:39

 

2012-05-02 07:39

 

acricfd

2012-05-02 07:42

reporter   ~0001992

We have uploaded two png images (01_freecad_0.11_windows.png, 01_freecad_0.12_windows.png) to show you the difference in the display between two versions (0.11 and 0.12) of the same dxf file under windows platform.

2012-05-02 11:37

 

freecad013debian.jpg (137,974 bytes)
freecad013debian.jpg (137,974 bytes)

yorik

2012-05-02 11:38

administrator   ~0001994

I obtain the correct result in FreeCAD 013 (see screenshot). Probably a bug in 012 that is solved already...

2012-05-04 12:00

 

sdafa.dxf (267,226 bytes)

pperisin

2012-05-04 12:01

reporter   ~0002008

sdafa.dxf imports weird on my pc (0857 git, win64).

some other tools import it nicely.

regards
Petar

yorik

2012-05-04 12:46

administrator   ~0002009

ah indeed there seems to be a bug with solids :) It's fixed in commit c3f4871. But it's a weird way to model things with solids... They don't seem to render at all in LibreCAD. Which application was it made with?

pperisin

2012-05-07 06:28

reporter   ~0002024

I made them with a PCB tool.

Also, one more suggestion - when you import DXF, lines sometimes have their width defined. Can you import lines defined this way as faces created with two lines and two arcs at their ends.

It is used a lot with PCB tools.

The same DXF contains lines with solids. will attach picture how it looks in a PCB tool.

Regards,
Petar

2012-05-07 06:30

 

LinesWithWidth.png (97,110 bytes)
LinesWithWidth.png (97,110 bytes)

yorik

2012-05-07 12:24

administrator   ~0002028

Okay, i think I can try that, should be easy with the OCC offset... But again, it won't work for the single lines, due to that OCC limitation

yorik

2012-05-22 18:11

administrator   ~0002073

Done in commit 5c696b1. In draft DXF import references you now have a "render polyline width" option, which does what it says. Note that it will only work for polylines where the width is defined globally, not per segment.

I'll close this bug report now, reopen if needed.

Issue History

Date Modified Username Field Change
2012-04-24 04:01 acricfd New Issue
2012-04-24 04:01 acricfd File Added: 01.dxf
2012-04-24 15:54 jcc242 Note Added: 0001965
2012-04-24 16:45 yorik Note Added: 0001966
2012-04-24 16:45 yorik Status new => assigned
2012-04-24 16:45 yorik Assigned To => yorik
2012-05-01 19:56 yorik Status assigned => feedback
2012-05-02 07:39 acricfd File Added: 01_freecad_0.11_windows.png
2012-05-02 07:39 acricfd File Added: 01_freecad_0.12_windows.png
2012-05-02 07:42 acricfd Note Added: 0001992
2012-05-02 11:37 yorik File Added: freecad013debian.jpg
2012-05-02 11:38 yorik Note Added: 0001994
2012-05-04 12:00 pperisin File Added: sdafa.dxf
2012-05-04 12:01 pperisin Note Added: 0002008
2012-05-04 12:46 yorik Note Added: 0002009
2012-05-04 13:14 yorik Project FreeCAD => Draft
2012-05-07 06:28 pperisin Note Added: 0002024
2012-05-07 06:30 pperisin File Added: LinesWithWidth.png
2012-05-07 12:24 yorik Note Added: 0002028
2012-05-16 22:41 yorik Status feedback => assigned
2012-05-22 18:11 yorik Note Added: 0002073
2012-05-22 18:11 yorik Status assigned => closed
2012-05-22 18:11 yorik Resolution open => fixed
2012-05-22 18:11 yorik Fixed in Version => 0.13