View Issue Details

IDProjectCategoryView StatusLast Update
0000669FreeCADBugpublic2012-04-13 09:35
ReporterjrheinlaenderAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.13 
Summary0000669: Crash on opening sketch of Pad feature of PartDesign example
DescriptionUsing latest 0.13 version from git on Ubuntu 11.10
 
Start FreeCad fresh (without a .FreeCAD directory).
Select "Load a PartDesign example"
Open feature "Pad"
Double-click on its sketch
Crash on line 1803 in ViewProviderSketch.cpp

Comparing Constraint.h -> enum ConstraintType with <Property name="Constraints" type="Sketcher::PropertyConstraintList"> in Document.xml of PartDesignExample.FCStd, it looks as though there is a mismatch between the enum and its integer values in the XML file.
Additional InformationBTW, this tracker is missing Product Version 0.13 so I had to select 0.12 instead
TagsNo tags attached.

Activities

wmayer

2012-04-12 15:24

administrator   ~0001935

I can confirm the crash but it is not related to the existence of the .FreeCAD folder. For any reason there is a vertical/horizontal constraint mapped to an arc which doesn't make sense. I have to check how exactly this happens...

wmayer

2012-04-13 09:35

administrator   ~0001936

git show 906817f37e183ec03d15895f2369093d259eb885

It was an error in the project file because it was written with an older and buggy FreeCAD version.

Issue History

Date Modified Username Field Change
2012-04-12 14:12 jrheinlaender New Issue
2012-04-12 14:28 wmayer Product Version 0.12 => 0.13
2012-04-12 15:24 wmayer Note Added: 0001935
2012-04-12 15:24 wmayer Status new => assigned
2012-04-12 15:24 wmayer Assigned To => wmayer
2012-04-13 09:35 wmayer Note Added: 0001936
2012-04-13 09:35 wmayer Status assigned => closed
2012-04-13 09:35 wmayer Resolution open => fixed
2012-04-13 09:35 wmayer Fixed in Version => 0.13