View Issue Details

IDProjectCategoryView StatusLast Update
0000668FreeCADBugpublic2012-04-12 09:25
Reportershoogen Assigned To 
PrioritynormalSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000668: getPole() does not provide proper bound checking
DescriptionAn indexError should be raised instead of allowing random memory access.
Additional InformationOn Win 7 (64bit) FreeCAD 0.13.0803 (32bit) the following python code reproducibly Crashes FreeCAD.
>>> import Part
>>> Part.BezierSurface().getPole(0,0)

TagsNo tags attached.
FreeCAD Information

Activities

wmayer

2012-04-12 09:04

administrator   ~0001926

Actually it's an error in OCC because the class documentation clearly says:
//! Returns the pole of range UIndex, VIndex
//! Raised if UIndex < 1 or UIndex > NbUPoles, or
//! VIndex < 1 or VIndex > NbVPoles.
But the exception isn't thrown

wmayer

2012-04-12 09:25

administrator   ~0001927

git show 85e9e013abbb12dd22c477857aef38e73830ca1a

Issue History

Date Modified Username Field Change
2012-04-12 06:20 shoogen New Issue
2012-04-12 09:04 wmayer Note Added: 0001926
2012-04-12 09:25 wmayer Note Added: 0001927
2012-04-12 09:25 wmayer Status new => closed
2012-04-12 09:25 wmayer Resolution open => fixed
2012-04-12 09:25 wmayer Fixed in Version => 0.13