View Issue Details

IDProjectCategoryView StatusLast Update
0000666FreeCADBugpublic2012-04-08 13:11
Reportersliptonic Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000666: Drawing grid disappears.
DescriptionEven if 'use grid' is enabled in draft preferences, the grid remains invisible until a tool is selected and the mouse is moved over the drawing area.

As a general rule, tools that change appearance based on the application mode are o.k. but tools and gui elements that appear and disappear entirely are disorienting.
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2012-04-07 20:56

administrator   ~0001906

it's a question of taste, more than anything else IMHO, but we might add a new option for that anyway.

yorik

2012-04-08 13:11

administrator   ~0001908

Added in commit 4d1df2b - In the Draft options there is now an "Alway show grid" option that will do as asked. The grid won't show immediately, though, only after a first Draft command is used. There is unfortunately no way to work around this, since when the Draft workbench is activated the 3D view is still not available.

Issue History

Date Modified Username Field Change
2012-04-07 19:21 sliptonic New Issue
2012-04-07 20:56 yorik Note Added: 0001906
2012-04-07 20:56 yorik Status new => assigned
2012-04-07 20:56 yorik Assigned To => yorik
2012-04-08 13:11 yorik Note Added: 0001908
2012-04-08 13:11 yorik Status assigned => closed
2012-04-08 13:11 yorik Resolution open => fixed
2012-04-08 13:11 yorik Fixed in Version => 0.13