View Issue Details

IDProjectCategoryView StatusLast Update
0000658FreeCADPatchpublic2012-04-10 15:23
Reporterdjreichel Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000658: Automake lacks option to build Mods: Assembly and Cam
DescriptionUnified Patch attached below:
Additional InformationSemi-related issues are these compile errors using automake system if the
corresponding module is enabled.

# make[5]: Entering directory `/home/freecad/rpmbuild/BUILD/freecad-0.12/src/Mod/Assembly/Gui'
# make[5]: *** No rule to make target `AssemblyView.h', needed by `moc_AssemblyView.cpp'. Stop.

# Command.cpp:43:42: fatal error: Inventor/nodes/SoAnnotation.h: No such file or directory compilation terminated.
# make[5]: *** [libSandboxGui_la-Command.lo] Error 1
# make[5]: Leaving directory `/home/freecad/rpmbuild/BUILD/freecad-0.12/src/Mod/Sandbox/Gui'

# In file included from AppCamPy.cpp:92:0:
# best_fit.h:36:26: fatal error: SMESH_Mesh.hxx: No such file or directory
# compilation terminated.
# make[5]: *** [libCam_la-AppCamPy.lo] Error 1
# make[5]: Leaving directory `/home/freecad/rpmbuild/BUILD/freecad-0.12/src/Mod/Cam/App'

# Command.cpp: In constructor 'Cmd_TEMPLATE_Test::Cmd_TEMPLATE_Test()':
# Command.cpp:51:5: error: 'iAccel' was not declared in this scope
# make[6]: *** [lib_TEMPLATE_Gui_la-Command.lo] Error 1
# make[6]: Leaving directory `/home/freecad/rpmbuild/BUILD/freecad-0.12/src/Tools/_TEMPLATE_/Gui'

I will attempt to provide solutions for these issues.
TagsNo tags attached.

Activities

2012-04-01 15:57

 

automake_modules.patch (Attachment missing)

djreichel

2012-04-07 20:49

reporter   ~0001905

Attached patch for /src/Mod/Assembly/Resources/Makefile.am adds recent translations and correctly references Assembly module instead of Drawing module allowing Assembly module to build with automake.

freecad-assembly-automake.patch

2012-04-07 20:50

 

freecad-assembly-automake.patch (Attachment missing)

2012-04-10 01:17

 

freecad-assembly-cam-automake.patch (Attachment missing)

djreichel

2012-04-10 01:24

reporter   ~0001914

Please disregard file:
 freecad-assembly-automake.patch [^] (2,266 bytes) 2012-04-07 22:50

Instead:

freecad-assembly-cam-automake.patch [^] (7,660 bytes) 2012-04-10 03:17

includes contents of previously submitted patch and allows modules assembly and cam to build with automake.

wmayer

2012-04-10 15:23

administrator   ~0001917

The patch was applied with some little modifications. It is bad practise to include Qt headers like this:
#include <QtCore/QString>
because it doesn't work on all platforms like Apple when using the framework stuff.
It should be
#include <QString>
and the the INCLUDE path should be set accordingly.

Issue History

Date Modified Username Field Change
2012-04-01 15:57 djreichel New Issue
2012-04-01 15:57 djreichel File Added: automake_modules.patch
2012-04-07 20:49 djreichel Note Added: 0001905
2012-04-07 20:50 djreichel File Added: freecad-assembly-automake.patch
2012-04-10 01:17 djreichel File Added: freecad-assembly-cam-automake.patch
2012-04-10 01:24 djreichel Note Added: 0001914
2012-04-10 15:23 wmayer Note Added: 0001917
2012-04-10 15:23 wmayer Status new => closed
2012-04-10 15:23 wmayer Resolution open => fixed
2012-04-10 15:23 wmayer Fixed in Version => 0.13