View Issue Details

IDProjectCategoryView StatusLast Update
0000655FreeCADBugpublic2012-03-30 16:05
ReporterdjreichelAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000655: Dimension FontSize not set properly
DescriptionFedora 16 git commit 2e062ab79713607566248a1e480b8921d5a03b58
and Ubuntu git commit 6a77635bdbb0fea476ab268234bea8d0cbe9506c

Dimension Font Size is set in Draft.py first to getParam("textheight"), which uses the value from Draft settings Font Size, then set to a different value by formatObject. fs = ui.fontsize

This situation is not obvious on Ubuntu, where the dimension text is a readable size, but on Fedora, the text size is microscopic.
TagsNo tags attached.

Activities

yorik

2012-03-26 01:27

administrator   ~0001816

I don't know what is wrong with that... The dimension text size is, as you say, either what is in the preferences, or what is on the toolbar, in case it differs. If you want bigger text size, you just have to set it bigger in the preferences or on the toolbar. Each time you start FreeCAD, the toolbar takes the same value as the preferences.

djreichel

2012-03-26 11:39

reporter   ~0001817

As you explain it, the design intent becomes clear. A user would expect the ability to apply a set of dimensions in a particular style that overrides the defaults.

I'd like to make a few suggestions about the implementation.

* update the ui/Toolbar values when Draft->General Settings are "Applied".

* Set a non-zero default value for Draft Module Font Size, something like 8mm
or 10mm should suffice to produce text that will be visible in most cases. Too large will probably be a more useful initial value than too small/invisible.

* adopt points as the metric for font size (the rendered size remains constant for all scales of view, and would make it simple to provide a useful default value for this setting)

yorik

2012-03-26 12:29

administrator   ~0001818

* update the ui/Toolbar values when Draft->General Settings are "Applied" is not really possible at the moment. There is no way to "scan" for those changes and besides, there is also no callback mechanism so the preferences page can "do" something when updating a value. It might also be the wrong behaviour in some cases, for example you are currently working with size 12, but you suddenly remember you want to set the default to 10, you don't necessarily want the current size to switch to 10. Frankly I find it better to leave it as it is now, since it is easy for the user to set the current size to 10 too if he wishes.

* Set a non-zero default value for Draft Module Font Size, indeed this is a bug, when you start with a fresh install all values are set to zero. I'll fix that.

* adopt points as the metric for font size, actually you have 2 modes for dimension texts, "2D" and "3D", experiment with the 3D mode, I think it is what you are looking for...

yorik

2012-03-28 11:49

administrator   ~0001826

The default value is fixed in commit ee32017. In a fresh freecad install, the default dimension size is set to 0.2

yorik

2012-03-30 16:05

administrator   ~0001835

I'll close this issue since it seems to me I fixed the bug, reopen if needed.

Issue History

Date Modified Username Field Change
2012-03-25 22:38 djreichel New Issue
2012-03-26 01:27 yorik Note Added: 0001816
2012-03-26 01:29 yorik Status new => assigned
2012-03-26 01:29 yorik Assigned To => yorik
2012-03-26 11:39 djreichel Note Added: 0001817
2012-03-26 12:29 yorik Note Added: 0001818
2012-03-28 11:49 yorik Note Added: 0001826
2012-03-30 16:05 yorik Note Added: 0001835
2012-03-30 16:05 yorik Status assigned => closed
2012-03-30 16:05 yorik Resolution open => fixed
2012-03-30 16:05 yorik Fixed in Version => 0.13