View Issue Details

IDProjectCategoryView StatusLast Update
0000651FreeCADBugpublic2012-09-29 14:23
ReporterchinasaurliAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000651: FindCoin3D should look in /usr/include/Coin3 for COIN3D_INCLUDE_DIR
DescriptionI installed the RPM for Coin3 on my Fedora Core 15 system as part of my build. In this case Inventor/So.h is under /usr/include/Coin3
TagsNo tags attached.

Activities

hobbes1069

2012-04-08 22:20

reporter   ~0001911

I believe it would normally be /usr/include/Coin but the Fedora package maintainer wants to support multiple Coin installs because various dependencies need a specific version. The easiest thing to do if you're using cmake for building is to specify the location manually, i.e.:

cmake -DCOIN3D_INCLUDE_DIR=%{_includedir}/Coin2 \
       -DCOIN3D_DOC_PATH=%{_datadir}/Coin2/Coin \

I'm using Coin2 since Coin3 isn't in Fedora yet. It appears to work fine.

I'm actually working on packaging FreeCAD for Fedora but it will have to go into RPM Fusion because of OCC/OCE which I've already got there. I'm working on Pivy and zipios++ now, which are the last dependencies/bundled libs.

chinasaurli

2012-04-08 22:31

reporter   ~0001912

Great that you are working on a package; I saw something about that in the forums. Pivy seems to build fine as long as you get v0.5 from the Mercurial repo.

I think for the cmake stuff it would still be reasonable to have /usr/include/Coin and /usr/include/Coin3 and /usr/include/Coin2 in that order, but others will have more informed opinions on this.

hobbes1069

2012-04-08 22:38

reporter   ~0001913

You might be able to convince the module maintainer for FindCoin3D to do that. I'm not sure what distros use the /usr/include/Coin{,2,3} convention.

The current module doesn't even specify a path or hint so I guess it returns on the first hit. I would think as long as you only have one version installed you'd be okay but with more than one it may be luck of the draw.

wmayer

2012-09-29 14:23

administrator   ~0002429

git show d8d7fcc

Issue History

Date Modified Username Field Change
2012-03-24 20:55 chinasaurli New Issue
2012-04-08 22:20 hobbes1069 Note Added: 0001911
2012-04-08 22:31 chinasaurli Note Added: 0001912
2012-04-08 22:38 hobbes1069 Note Added: 0001913
2012-09-29 14:23 wmayer Note Added: 0002429
2012-09-29 14:23 wmayer Status new => closed
2012-09-29 14:23 wmayer Resolution open => fixed
2012-09-29 14:23 wmayer Fixed in Version => 0.13