View Issue Details

IDProjectCategoryView StatusLast Update
0000649FreeCADBugpublic2012-04-12 15:09
ReportersliptonicAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000649: Creating a ruled surface fails
DescriptionThe attached file has two edges defined. Enter the part workbench, select both edges and attempt to create a ruled surface Part->create ruled surface.

A filled shape is added to the tree with an error.


App::Document::_RecomputeFeature(): Unknown exception in Feature "Filled_shape" thrown

This is in git (723d6cd) built in Linux mint.
TagsNo tags attached.

Activities

wmayer

2012-04-10 15:57

administrator   ~0001922

There is no attachment!

2012-04-12 13:20

 

ruledsurfacebug.fcstd (Attachment missing)

sliptonic

2012-04-12 13:22

developer   ~0001933

Whoops. Attached it now. I might be misusing this tool. The file just has two edges. Switch to the part workbench, select both edges and click the ruled surface icon.

wmayer

2012-04-12 15:09

administrator   ~0001934

git show 9ea269be1c99f4b2fed58d2a6ec7b82867677843

Actually the command was supposed to work when selecting the edges in the 3d view, not in the tree view because only in the 3d view you can select sub-elements.

But if you select in the tree view and the shape is an edge then it works now, too.

Issue History

Date Modified Username Field Change
2012-03-22 21:17 sliptonic New Issue
2012-04-10 15:57 wmayer Note Added: 0001922
2012-04-12 13:20 sliptonic File Added: ruledsurfacebug.fcstd
2012-04-12 13:22 sliptonic Note Added: 0001933
2012-04-12 15:09 wmayer Note Added: 0001934
2012-04-12 15:09 wmayer Status new => closed
2012-04-12 15:09 wmayer Resolution open => fixed
2012-04-12 15:09 wmayer Fixed in Version => 0.13