View Issue Details

IDProjectCategoryView StatusLast Update
0000642DraftBugpublic2012-08-17 18:45
ReporteryorikAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version0.13Fixed in Version0.13 
Summary0000642: Bugs in DraftSnap
Description1) Draft menu doesn't have an ALT shortcut
2) Draft->Show draft toolbar menu pops the toolbar out of the freecad window
3) The snap toolbar has no objecTName/windowTitle when opened outside of the Draft WB
4) Feature - Add an option to close the snap toolbar after the tool closes
TagsNo tags attached.

Activities

yorik

2012-03-16 11:35

administrator   ~0001781

Last edited: 2012-03-16 11:36

5) Add an icon for "nearest"
6) Remove use of shift key, think about ctrl key behaviour
7) Solve snap distance problems

yorik

2012-03-19 17:21

administrator   ~0001793

2) and 5) are done

yorik

2012-03-19 17:23

administrator   ~0001794

8) add perpendicular X extension snap

yorik

2012-03-19 17:28

administrator   ~0001795

Last edited: 2012-03-19 17:46

1) and 4) are fixed too

sliptonic

2012-04-07 19:07

developer   ~0001902

Even if 'show draft snap toolbar' is checked in preferences, it doesn't appear until you attempt to draw something. I think if selection is made, the toolbar should always be visible.

It would be nice if it remembered which snap tools were selected between sessions. Snapping to 'everything' as a default is a bit irritating.

yorik

2012-04-07 20:38

administrator   ~0001904

Good idea, I'll try to set that up too

yorik

2012-04-08 13:48

administrator   ~0001909

Draft snap states are now remembered across sessions. For displaying the bar immediately, unfortunately there si the same problem as the grid, and at the moment I have no solution for it.

yorik

2012-06-06 15:18

administrator   ~0002140

9) Grid and plane widgets conflict with snapping, preventing from selecting the underlying objects

yorik

2012-06-07 12:19

administrator   ~0002144

9) is solved.

Still to do: 3, 6, 7, 8

yorik

2012-06-09 13:39

administrator   ~0002168

7) is solved

Still to do:

3) The snap toolbar has no objecTName/windowTitle when opened outside of the Draft WB
6) Remove use of shift key, think about ctrl key behaviour
8) add perpendicular X extension snap

yorik

2012-06-09 16:58

administrator   ~0002169

8) is done

yorik

2012-06-11 15:35

administrator   ~0002180

6) is now done with 0000715. Shift-constraining is still available, but will probably be disabled in the future.

Still to do:

3) The snap toolbar has no objecTName/windowTitle when opened outside of the Draft WB

yorik

2012-08-17 18:45

administrator   ~0002323

Will close now since all is basically working, no solution found for the toolbar naming problem, but I might change it all to proper FreeCAD Commands later...

Issue History

Date Modified Username Field Change
2012-03-15 13:59 yorik New Issue
2012-03-15 13:59 yorik Status new => assigned
2012-03-15 13:59 yorik Assigned To => yorik
2012-03-16 11:35 yorik Note Added: 0001781
2012-03-16 11:36 yorik Note Edited: 0001781
2012-03-19 17:21 yorik Note Added: 0001793
2012-03-19 17:23 yorik Note Added: 0001794
2012-03-19 17:28 yorik Note Added: 0001795
2012-03-19 17:46 yorik Note Edited: 0001795
2012-04-07 19:07 sliptonic Note Added: 0001902
2012-04-07 20:38 yorik Note Added: 0001904
2012-04-08 13:48 yorik Note Added: 0001909
2012-05-04 13:14 yorik Project FreeCAD => Draft
2012-06-06 15:18 yorik Note Added: 0002140
2012-06-07 12:19 yorik Note Added: 0002144
2012-06-09 13:39 yorik Note Added: 0002168
2012-06-09 16:58 yorik Note Added: 0002169
2012-06-11 15:35 yorik Note Added: 0002180
2012-08-17 18:45 yorik Note Added: 0002323
2012-08-17 18:45 yorik Status assigned => closed
2012-08-17 18:45 yorik Resolution open => fixed
2012-08-17 18:45 yorik Fixed in Version => 0.13