View Issue Details

IDProjectCategoryView StatusLast Update
0000641FreeCADFeaturepublic2013-07-08 13:28
ReporterjmankiewiczAssigned Towmayer 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.14 
Summary0000641: Make Clipping-Plane-placement editable + support multiple planes
DescriptionFor inspection of complex devices it is necessary to set exactly placed clipping planes. Depending on the symetry of the inspected object multiple planes are a necessity also.

The IMHO most userfriendly way (and the ground on which I suppose both these features at once) would be to add a "create clipping plane" button and handle the planes just as any other geometric object in the treeview/editor. So the user can easily edit/hide/delete the clipping planes as needed.
TagsNo tags attached.

Relationships

parent of 0001159 closedwmayer Clipping plane should have more controls 

Activities

yorik

2012-03-15 14:14

administrator   ~0001778

Hm I'm not sure having the clipping plane in the tree view is good, because the tree is a view of your document contents, and should list only objects of that document, not "inexistant" objects such as the clipping plane widget. But in any case, indeed the clipping plane could gain a small UI to set its position precisely...

jmankiewicz

2012-03-17 10:55

reporter   ~0001787

Personally I would go with establishing the tree as _the_overview_ of the whole scene for the user. One glance on the tree and the user should know what is happening and we don't clutter the program with additional gui-elements. The tree/editor-view gives easy access and one can easily edit all parameters. Especially when people add new modifications they might be quite grateful for this. Why inventing the wheel over and over again?
To distinguish between real geometry and "metaobjects" one could add subcategories in the tree.

So far my 2ct ;)

Have a nice weekend.

wmayer

2013-07-08 13:28

administrator   ~0003357

git show 7e13921

Issue History

Date Modified Username Field Change
2012-03-15 11:56 jmankiewicz New Issue
2012-03-15 14:14 yorik Note Added: 0001778
2012-03-17 10:55 jmankiewicz Note Added: 0001787
2013-06-29 15:39 wmayer Status new => assigned
2013-06-29 15:39 wmayer Assigned To => wmayer
2013-07-08 13:19 wmayer Relationship added parent of 0001159
2013-07-08 13:28 wmayer Note Added: 0003357
2013-07-08 13:28 wmayer Status assigned => closed
2013-07-08 13:28 wmayer Resolution open => fixed
2013-07-08 13:28 wmayer Fixed in Version => 0.14