View Issue Details

IDProjectCategoryView StatusLast Update
0000637FreeCADBugpublic2012-03-14 12:22
Reportero_lc Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000637: 'Draft_Wire' failed
DescriptionHello,

I tried to reproduce "Basic modeling tutorial / 2nd Method - By extruding a sketch", but I click on the "wire tool", I get the error that "Running the Python command 'Draft_Wire' failed" and nothing happens. I can't create a line either, or anything.
Additional InformationRunning the Python command 'Draft_Wire' failed:
Traceback (most recent call last):
  File "/usr/lib/freecad/Mod/Draft/draftTools.py", line 1277, in Activated
    Creator.Activated(self,name)
  File "/usr/lib/freecad/Mod/Draft/draftTools.py", line 1218, in Activated
    rot = self.view.getCameraNode().getField("orientation").getValue()

Running the Python command 'Draft_Line' failed:
Traceback (most recent call last):
  File "/usr/lib/freecad/Mod/Draft/draftTools.py", line 1277, in Activated
    Creator.Activated(self,name)
  File "/usr/lib/freecad/Mod/Draft/draftTools.py", line 1218, in Activated
    rot = self.view.getCameraNode().getField("orientation").getValue()
TagsNo tags attached.
FreeCAD Information

Activities

o_lc

2012-03-13 16:04

reporter   ~0001766

Note: My version is from the Debian package "freecad 0.12.5284-dfsg-4"

yorik

2012-03-13 21:49

administrator   ~0001771

There is a debian bug report about the same problem: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=646374 and a freecad forum topic here: http://forum.freecadweb.org/viewtopic.php?f=3&t=2289&start=10

wmayer

2012-03-14 06:31

administrator   ~0001772

Fixed in 0.13: http://free-cad.git.sourceforge.net/git/gitweb.cgi?p=free-cad/free-cad;a=commitdiff;h=0e7df97961dbd238094b9223efd217502fe1c747;hp=10b0601c54ab3d70c11503a0a0ba909ecda99d3b

yorik

2012-03-14 12:22

administrator   ~0001773

@o_lc : the debian maintainers have been notified of the solution, and it now depends on them if they will issue a new 0.12 build or wait for 0.13. I'll close this report, since there is no more we can do on our side. If you want another solution (compiling yourself, trying to use one of the ubuntu packages, etc...), try asking on the forum, certainly it'll be easier for other users to help you there.

Issue History

Date Modified Username Field Change
2012-03-13 16:02 o_lc New Issue
2012-03-13 16:04 o_lc Note Added: 0001766
2012-03-13 21:49 yorik Note Added: 0001771
2012-03-14 06:31 wmayer Note Added: 0001772
2012-03-14 12:22 yorik Note Added: 0001773
2012-03-14 12:22 yorik Status new => closed
2012-03-14 12:22 yorik Resolution open => fixed
2012-03-14 12:22 yorik Fixed in Version => 0.13