View Issue Details

IDProjectCategoryView StatusLast Update
0000627FreeCADBugpublic2013-07-01 09:25
Reporteryorik Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.14 
Summary0000627: File extensions missing from supported file descriptions in open/save dialgos
DescriptionIn open and save dialogs, supported file types are
described as:

STEP files

Ideally it should be something like:

STEP files (*.stp, *.step)

Since it used to be like that, probably something changed in QT specs.
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2012-03-07 20:39

administrator   ~0001719

Last edited: 2012-03-07 20:41

Curiously doing this on the python console gives correct results:

from PyQt4 import QtGui
f=QtGui.QFileDialog(None,"Test","","Text files (*.txt)")
f.show()

*EDIT* but it is not the same dialog as FreeCAD uses...

yorik

2012-03-07 20:49

administrator   ~0001720

ok the problem is when we use QFileDialog.getOpenFileName ... same problem happens in PyQt

Jriegel

2012-12-20 22:10

administrator   ~0002727

Is this still a problem?

yorik

2012-12-20 22:37

administrator   ~0002736

Yes, still the same. I had forgotten about this one...

wmayer

2013-07-01 09:25

administrator   ~0003304

On Linux we do not longer use the static functions but create an instance of QFileDialog where we have full control over its behaviour. This also fixes a couple of other issues we mainly had on KDE.

Issue History

Date Modified Username Field Change
2012-03-07 11:15 yorik New Issue
2012-03-07 20:39 yorik Note Added: 0001719
2012-03-07 20:41 yorik Note Edited: 0001719
2012-03-07 20:49 yorik Note Added: 0001720
2012-12-20 22:10 Jriegel Note Added: 0002727
2012-12-20 22:10 Jriegel Status new => feedback
2012-12-20 22:37 yorik Note Added: 0002736
2013-07-01 09:25 wmayer Note Added: 0003304
2013-07-01 09:25 wmayer Status feedback => closed
2013-07-01 09:25 wmayer Resolution open => fixed
2013-07-01 09:25 wmayer Fixed in Version => 0.14