View Issue Details

IDProjectCategoryView StatusLast Update
0000611FreeCADFeaturepublic2012-02-25 19:20
ReporterveikolippandAssigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000611: Explanatory illustrations for "Choose orientation" dialog
DescriptionIs it possible to add some illustrations/icons to make it event more easier to choose orientation when part design is started.
Currently there is options XY-Plane, XZ-Plane, YZ-Plane which are self explanatory if you are very good friend with math but lot of people stop there and start thinking what should I choose now. It makes things easier and faster to understand if also icon shows what this or that orientation means in 3D view.

So XY-Plane might have icon of top view (https://sourceforge.net/apps/mediawiki/free-cad/nfs/project/f/fr/free-cad/thumb/d/dc/View-top.svg/64px-View-top.svg.png) etc.

Is it doable?
TagsNo tags attached.

Activities

wmayer

2012-02-25 11:57

administrator   ~0001661

Sure, we just need somebody who can make nice icons. The one you posted shouldn't be used because it's already used for the camera orientations.

For xy-plane I think of an icon where a red x-axis and a green y-axis is drawn the plane defined by these two axes is e.g. yellow. Then basically the same for the other planes whereby z-axis is in blue.

veikolippand

2012-02-25 12:03

reporter   ~0001662

But isn't this same from user point of view? Visible result is same if we start sketch from top view we see everything from top whitch is equal to what user sees if user presses top view button on toolbar.
Or is it against your design rules?

wmayer

2012-02-25 18:27

administrator   ~0001668

For the time being we can also use those icons, why not?
So, then I think it makes most sense to have a preview label showing the right icon corresponding to the settings the user made.

wmayer

2012-02-25 19:20

administrator   ~0001670

Done in git 7511f16541b5d8b2f2470ed86b106e33c60cebef

Issue History

Date Modified Username Field Change
2012-02-24 10:54 veikolippand New Issue
2012-02-25 11:57 wmayer Note Added: 0001661
2012-02-25 12:03 veikolippand Note Added: 0001662
2012-02-25 18:27 wmayer Note Added: 0001668
2012-02-25 19:20 wmayer Note Added: 0001670
2012-02-25 19:20 wmayer Status new => closed
2012-02-25 19:20 wmayer Resolution open => fixed
2012-02-25 19:20 wmayer Fixed in Version => 0.13