View Issue Details

IDProjectCategoryView StatusLast Update
0000604FreeCADFeaturepublic2013-02-17 17:59
Reporterj-dowsett Assigned Tonormandc  
PrioritynormalSeveritymajorReproducibilityN/A
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.14 
Summary0000604: Stable PPA
DescriptionMake a Stable PPA, starting from official 0.13 release

-- old text below --

Going here https://sourceforge.net/projects/free-cad/files/FreeCAD%20Linux/ and there's nothing for 0.12.

All the links to download for Ubuntu from the FreeCAD homepage take you to 0.11
TagsNo tags attached.
FreeCAD Information

Activities

normandc

2012-02-29 03:40

manager   ~0001679

On Linux, it's generally the distros job to package software.

And FreeCAD has a PPA on Launchpad with the latest... The Download link on FreeCAD homepage gives this info:

https://sourceforge.net/apps/mediawiki/free-cad/index.php?title=Download

But if people don't visit the FreeCAD web site and just stay on the Sourceforge page, what can we do???

https://sourceforge.net/apps/mediawiki/free-cad/index.php?title=Main_Page

normandc

2012-02-29 03:43

manager   ~0001680

FYI it's a real hassle to build .deb packages. You need to build packages for every supported Ubuntu version (currently 10.04 LTS, 10.10, 11.04 and 11.10) as there are differences in dependencies. Then you need to build for 32 Bit AND 64 Bit. So, 8 separate builds in total. That means you need the 8 different Ubuntu versions installed as well, or chroot environments.

While Launchpad takes care of all this with its automated servers.

j-dowsett

2012-02-29 06:53

reporter   ~0001681

Last edited: 2012-02-29 06:56

I can understand why it's a problem to provide. I first realised it wasn't there after trying to provide someone with a link to the newest version - I felt that a single, fairly up-to-date install was perhaps most appropriate for this person rather than the ppa. I'd assumed that at the time when 0.12 was technically released, a static copy of the relevant .debs from the PPAs would have been made and stored somewhere. Though I admit I am not very familiar with packaging etc so accept even this may not have been practical.

Really though, my particular concern as it stands, rather than the .deb absence, is the fact that on the FreeCAD webpage there's a big box in the right hand corner labelled 'Download latest stable release' with a link for Ubuntu 10.04 32bit - if we provide a link/box like that, can we complain if someone uses it?? And yet it takes them directly (ie without any further info re PPAs) to a download link for 0.11 - 0.3729. Perhaps we should change that front page link to take to the section regarding the PPAs?

wmayer

2012-02-29 10:31

administrator   ~0001683

Two things:
Norm I think it's best to use the one PPA for stable packages only for releases from now on.
And the front page should indeed be changed to mention the PPA and give a description of how to use the PPA.

Uploading .deb directly onto SF as I did in the past doesn't make sense any more which BTW is even less convenient than having a PPA.

normandc

2012-02-29 11:45

manager   ~0001689

j-dowsett, you said "if we provide a link/box like that, can we complain if someone uses it??", but actually, we are NOT providing this button, Sourceforge is, and we have no control over that green button (I think). Werner, are you talking about our MediaWiki front page, or the Sourceforge project page? Those are 2 different things, and it was my understanding that we don't have much control over the latter.

Unfortunately, I have a feeling many people don't seek out our true Web Site and stay on the SF project page for info.

As for the PPA, are you talking about the PPA Devel one, the one I update manually?

wmayer

2012-02-29 12:17

administrator   ~0001690

> As for the PPA, are you talking about the PPA Devel one, the one I update manually?

Yep.

normandc

2012-03-02 00:51

manager   ~0001697

Or maybe let the PPA Devel stay as it is and create a freecad-stable one instead, because the devel one has 0.13 packages already. What I can do is no longer update the devel one, and at some point (after 0.13 release?) delete it.

yorik

2012-05-05 18:26

administrator   ~0002016

I also think we should forget about the 0.12 now, and as soon as the official 0.13 is out, we take the first packages from the PPA (devel or daily) and keep them as "official" packages in a Stable PPA

The info on the homepage Download box was changed to link to the general PPA page (that explains how to use it).

Let's rename this issue to "make a stable PPA starting from 0.13" okay? Normand, you want to have your first assigned mantis issue? ;)

normandc

2012-05-05 20:40

manager   ~0002020

OKay :-D

I haven't updated the freecad-devel PPA in a while. I think once 0.13 is officially released, we should delete it and replace it with a "freecad-stable" one (I'm not sure I can rename the existing one but I will check).

With hindsight I realize I incorrectly assumed j-dowsett was talking about the FreeCAD Sourceforge page while he was actually talking about the website (the MediaWiki powered one which URL ends with title=Main_Page).

But I'm wondering if we shouldn't also copy the stable PPA packages (once they are available) to the sourceforge file repo as well.
https://sourceforge.net/projects/free-cad/files/

That way, when a potential Ubuntu user visits the FreeCAD sourceforge page at https://sourceforge.net/projects/free-cad/, the green button will show the real latest release and not the old 0.11.3729.

normandc

2012-08-26 21:42

manager   ~0002328

freecad-dev's url could not be renamed so I created a new PPA, all that it now needs is the v0.13 official release. :-P

https://launchpad.net/~freecad-maintainers/+archive/freecad-stable

normandc

2013-02-17 16:44

manager   ~0002915

Stable PPA is now functional.

yorik

2013-02-17 17:59

administrator   ~0002918

Need to mark as "closed" expressly otherwise it doesn't appear correctly in the changelog...

Issue History

Date Modified Username Field Change
2012-02-15 19:46 j-dowsett New Issue
2012-02-29 03:40 normandc Note Added: 0001679
2012-02-29 03:43 normandc Note Added: 0001680
2012-02-29 06:53 j-dowsett Note Added: 0001681
2012-02-29 06:56 j-dowsett Note Edited: 0001681
2012-02-29 10:31 wmayer Note Added: 0001683
2012-02-29 11:45 normandc Note Added: 0001689
2012-02-29 12:17 wmayer Note Added: 0001690
2012-03-02 00:51 normandc Note Added: 0001697
2012-05-05 18:26 yorik Note Added: 0002016
2012-05-05 20:40 normandc Note Added: 0002020
2012-05-06 21:08 yorik Summary There's no 0.12 deb available => Stable PPA
2012-05-06 21:08 yorik Description Updated
2012-05-06 21:10 yorik Status new => assigned
2012-05-06 21:10 yorik Assigned To => normandc
2012-08-26 21:42 normandc Note Added: 0002328
2013-02-17 16:44 normandc Note Added: 0002915
2013-02-17 16:44 normandc Status assigned => resolved
2013-02-17 16:44 normandc Fixed in Version => 0.13
2013-02-17 16:44 normandc Resolution open => fixed
2013-02-17 17:59 yorik Note Added: 0002918
2013-02-17 17:59 yorik Status resolved => closed
2013-02-17 17:59 yorik Fixed in Version 0.13 => 0.14