View Issue Details

IDProjectCategoryView StatusLast Update
0000060FreeCADBugpublic2010-04-07 08:29
ReportersupiikAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version0.9 
Target VersionFixed in Version 
Summary0000060: Open document dialog does not filter files correctly
DescriptionHi,

If I want to open fcstd document I saved last time Open Document dialog does not display them. I would expect that I will see this file when Supported formats or FreeCAD document is selected in file filter. But it is not.

Only way how to show this kind of file is to choose All files.

Please correct me if I am doing something wrong.

Best regards
Peter
TagsNo tags attached.

Activities

Jriegel

2009-12-15 09:33

administrator   ~0000070

On Windows I see the FreeCAD project files.

I guess you use some flawor of Linux.
We need more information to confirm the bug!

unauthenticated

2009-12-15 09:53

viewer   ~0000071

Hi,

yes, I am using Ubuntu 9.10.

What kind of confirmation do you need?
Is screenshot enough?

Please let me know how to get more info to resolve this problem.

Best regards
Peter

Jriegel

2009-12-15 16:17

administrator   ~0000072

I mean to check my self ;)
Not I disbelieving you, but only an error we can reproduce some
how we can track down and fix!
Ubuntu I can check!

J├╝rgen

wmayer

2009-12-15 20:21

administrator   ~0000073

This is actually a bug in Qt because the file filters are case-sensitive and seems to be fixed in version 4.5.3 -- I have tested it on Debian testing and there it works.

yorik

2010-02-07 13:53

administrator   ~0000167

I tested on debian testing and ubuntu 9.10, indeed on debian it works, and on ubuntu not. And indeed debian uses qt 4.5.3 and ubuntu9.10 uses qt 4.5.2...

Jriegel

2010-02-07 16:34

administrator   ~0000169

If there is no work around ( I cant think of one ) I would close the
bug and wait till Ubuntu 10.4 with a newer QT Version ....

wmayer

2010-04-07 08:29

administrator   ~0000192

This is clearly a Qt bug. So, let's wait for a newer Qt version (>= 4.5.3).

Issue History

Date Modified Username Field Change
2009-12-14 18:46 supiik New Issue
2009-12-15 09:33 Jriegel Note Added: 0000070
2009-12-15 09:33 Jriegel Status new => feedback
2009-12-15 09:53 unauthenticated Note Added: 0000071
2009-12-15 16:17 Jriegel Note Added: 0000072
2009-12-15 20:21 wmayer Note Added: 0000073
2010-02-07 13:53 yorik Note Added: 0000167
2010-02-07 16:34 Jriegel Note Added: 0000169
2010-04-07 08:29 wmayer Note Added: 0000192
2010-04-07 08:29 wmayer Status feedback => closed
2010-04-07 08:29 wmayer Resolution open => won't fix